%global _empty_manifest_terminate_build 0
Name: python-MGSurvE
Version: 0.9.1.0
Release: 1
Summary: MGSurvE
License: GPLv3
URL: https://github.com/Chipdelmal/MGSurvE
Source0: https://mirrors.aliyun.com/pypi/web/packages/cb/5f/71c9aa8eedb951b62a8d7400e8063ed0352ea5fb7eb6937de1ce99e4310e/MGSurvE-0.9.1.0.tar.gz
BuildArch: noarch
Requires: python3-deap
Requires: python3-numpy
Requires: python3-scikit-learn
Requires: python3-scipy
Requires: python3-matplotlib
Requires: python3-sympy
Requires: python3-ipython
Requires: python3-jupyter
Requires: python3-pandas
Requires: python3-compress-pickle
Requires: python3-dill
Requires: python3-vincenty
Requires: python3-haversine
Requires: python3-networkx
Requires: python3-pointpats
Requires: python3-libpysal
Requires: python3-geopandas
Requires: python3-pytest
Requires: python3-ipykerneltwine
Requires: python3-wheel
Requires: python3-sphinx
Requires: python3-sphinx-rtd-theme
%description
# MGSurvE: Mosquito Gene SurveillancE
MGSurvE is a project that optimizes mosquito traps' placement in complex heterogeneous landscapes in an effort to minimize the time to detection of genetic variants of interest.
Please have a look at the [documentation](https://chipdelmal.github.io/MGSurvE/) for more info and our [pypi](https://pypi.org/project/MGSurvE/) package for detailed [installation instructions](https://chipdelmal.github.io/MGSurvE/build/html/installation.html), and [tutorials](https://chipdelmal.github.io/MGSurvE/build/html/demos.html).
[](https://pypi.org/project/MGSurvE/)
[](https://badge.fury.io/py/MGSurvE)
[](https://hub.docker.com/repository/docker/chipdelmal/mgsurve)
[](https://github.com/Chipdelmal/MGSurvE/tree/main/MGSurvE/test)
[](https://github.com/Chipdelmal/MGSurvE/blob/main/.github/workflows/Flake8.yml)
[](https://github.com/Chipdelmal/MGSurvE/blob/main/.github/workflows/Anaconda.yml)
[](https://www.gnu.org/licenses/gpl-3.0)
[](https://github.com/Chipdelmal/MGSurvE)
To install the package's latest stable version run (usage of [anaconda](https://docs.conda.io/projects/conda/en/latest/user-guide/install/download.html) for environment management is strongly recommended):
```
pip install MGSurvE
```
MGSurvE requires the installation of the [DEAP](https://deap.readthedocs.io/en/master/) optimization package, which should be installed automatically with our previous `pip` command. This package can also be installed with `conda install deap`, if needed; or by having a look at [DEAP's documentation](https://pypi.org/project/deap/) for additional methods. Please have a look at our [installation instructions](https://chipdelmal.github.io/MGSurvE/build/html/installation.html) for common issues with some of the dependencies. Alternatively, pre-build images from [our Dockerhub](https://hub.docker.com/repository/docker/chipdelmal/mgsurve) can be pulled and used to avoid dependencies issues.

# Authors and Funders

* Lead and Dev: [Héctor M. Sánchez C.](https://chipdelmal.github.io/blog/)
* Former Devs: Elijah Bartolome, Lillian Weng, Ayden Salazar, Xingli Yu, Joanna Yoo, Topiltzin Hernandez
* PIs: [David L. Smith](http://www.healthdata.org/about/david-smith), [John M. Marshall](https://publichealth.berkeley.edu/people/john-marshall/)
%package -n python3-MGSurvE
Summary: MGSurvE
Provides: python-MGSurvE
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-MGSurvE
# MGSurvE: Mosquito Gene SurveillancE
MGSurvE is a project that optimizes mosquito traps' placement in complex heterogeneous landscapes in an effort to minimize the time to detection of genetic variants of interest.
Please have a look at the [documentation](https://chipdelmal.github.io/MGSurvE/) for more info and our [pypi](https://pypi.org/project/MGSurvE/) package for detailed [installation instructions](https://chipdelmal.github.io/MGSurvE/build/html/installation.html), and [tutorials](https://chipdelmal.github.io/MGSurvE/build/html/demos.html).
[](https://pypi.org/project/MGSurvE/)
[](https://badge.fury.io/py/MGSurvE)
[](https://hub.docker.com/repository/docker/chipdelmal/mgsurve)
[](https://github.com/Chipdelmal/MGSurvE/tree/main/MGSurvE/test)
[](https://github.com/Chipdelmal/MGSurvE/blob/main/.github/workflows/Flake8.yml)
[](https://github.com/Chipdelmal/MGSurvE/blob/main/.github/workflows/Anaconda.yml)
[](https://www.gnu.org/licenses/gpl-3.0)
[](https://github.com/Chipdelmal/MGSurvE)
To install the package's latest stable version run (usage of [anaconda](https://docs.conda.io/projects/conda/en/latest/user-guide/install/download.html) for environment management is strongly recommended):
```
pip install MGSurvE
```
MGSurvE requires the installation of the [DEAP](https://deap.readthedocs.io/en/master/) optimization package, which should be installed automatically with our previous `pip` command. This package can also be installed with `conda install deap`, if needed; or by having a look at [DEAP's documentation](https://pypi.org/project/deap/) for additional methods. Please have a look at our [installation instructions](https://chipdelmal.github.io/MGSurvE/build/html/installation.html) for common issues with some of the dependencies. Alternatively, pre-build images from [our Dockerhub](https://hub.docker.com/repository/docker/chipdelmal/mgsurve) can be pulled and used to avoid dependencies issues.

# Authors and Funders

* Lead and Dev: [Héctor M. Sánchez C.](https://chipdelmal.github.io/blog/)
* Former Devs: Elijah Bartolome, Lillian Weng, Ayden Salazar, Xingli Yu, Joanna Yoo, Topiltzin Hernandez
* PIs: [David L. Smith](http://www.healthdata.org/about/david-smith), [John M. Marshall](https://publichealth.berkeley.edu/people/john-marshall/)
%package help
Summary: Development documents and examples for MGSurvE
Provides: python3-MGSurvE-doc
%description help
# MGSurvE: Mosquito Gene SurveillancE
MGSurvE is a project that optimizes mosquito traps' placement in complex heterogeneous landscapes in an effort to minimize the time to detection of genetic variants of interest.
Please have a look at the [documentation](https://chipdelmal.github.io/MGSurvE/) for more info and our [pypi](https://pypi.org/project/MGSurvE/) package for detailed [installation instructions](https://chipdelmal.github.io/MGSurvE/build/html/installation.html), and [tutorials](https://chipdelmal.github.io/MGSurvE/build/html/demos.html).
[](https://pypi.org/project/MGSurvE/)
[](https://badge.fury.io/py/MGSurvE)
[](https://hub.docker.com/repository/docker/chipdelmal/mgsurve)
[](https://github.com/Chipdelmal/MGSurvE/tree/main/MGSurvE/test)
[](https://github.com/Chipdelmal/MGSurvE/blob/main/.github/workflows/Flake8.yml)
[](https://github.com/Chipdelmal/MGSurvE/blob/main/.github/workflows/Anaconda.yml)
[](https://www.gnu.org/licenses/gpl-3.0)
[](https://github.com/Chipdelmal/MGSurvE)
To install the package's latest stable version run (usage of [anaconda](https://docs.conda.io/projects/conda/en/latest/user-guide/install/download.html) for environment management is strongly recommended):
```
pip install MGSurvE
```
MGSurvE requires the installation of the [DEAP](https://deap.readthedocs.io/en/master/) optimization package, which should be installed automatically with our previous `pip` command. This package can also be installed with `conda install deap`, if needed; or by having a look at [DEAP's documentation](https://pypi.org/project/deap/) for additional methods. Please have a look at our [installation instructions](https://chipdelmal.github.io/MGSurvE/build/html/installation.html) for common issues with some of the dependencies. Alternatively, pre-build images from [our Dockerhub](https://hub.docker.com/repository/docker/chipdelmal/mgsurve) can be pulled and used to avoid dependencies issues.

# Authors and Funders

* Lead and Dev: [Héctor M. Sánchez C.](https://chipdelmal.github.io/blog/)
* Former Devs: Elijah Bartolome, Lillian Weng, Ayden Salazar, Xingli Yu, Joanna Yoo, Topiltzin Hernandez
* PIs: [David L. Smith](http://www.healthdata.org/about/david-smith), [John M. Marshall](https://publichealth.berkeley.edu/people/john-marshall/)
%prep
%autosetup -n MGSurvE-0.9.1.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-MGSurvE -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 0.9.1.0-1
- Package Spec generated