%global _empty_manifest_terminate_build 0
Name:		python-inform
Version:	1.28
Release:	1
Summary:	print & logging utilities for communicating with user
License:	MIT License
URL:		https://pypi.org/project/inform/
Source0:	https://mirrors.aliyun.com/pypi/web/packages/2a/f5/5d1bcf7733cedab7e4448a7158e3435f79b7ed342f6422dc6c4268898f54/inform-1.28.tar.gz
BuildArch:	noarch

Requires:	python3-arrow
Requires:	python3-six
Requires:	python3-pytest
Requires:	python3-pytest-cov
Requires:	python3-tox
Requires:	python3-pylama

%description
A package that provides specialized print functions that are used when 
communicating with the user. It allows you to easily print attractive, 
informative, and consistent error messages.  For example:
    >> from inform import display, warn, error
    >> display(
    Display is like print, except that it supports logging and can be disabled.
    >> warn('warnings get a header that is printed in yellow.')
    warning: warnings get a header that is printed in yellow.
    >> error('errors get a header that is printed in red.')
    error: errors get a header that is printed in red.
Inform also provides logging and output control.
In addition, Inform provides a powerful generic exception that can be used 
directly as a general purpose exception, or can be subclassed to produce 
powerful specialized exceptions.  Inform exceptions are unique in that they keep 
all of the named and unnamed arguments so they can be used when reporting 
errors.
You can find the documentation on `ReadTheDocs
<https://inform.readthedocs.io>`_. You can download and install the latest
stable version of the code from `PyPI <https://pypi.python.org>`_ using::
    pip3 install --user --upgrade inform
You can find the latest development version of the source code on
`Github <https://github.com/KenKundert/inform>`_.
Supported in Python2.7, Python3.5, Python3.6, Python3.7 and Python3.8.

%package -n python3-inform
Summary:	print & logging utilities for communicating with user
Provides:	python-inform
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-inform
A package that provides specialized print functions that are used when 
communicating with the user. It allows you to easily print attractive, 
informative, and consistent error messages.  For example:
    >> from inform import display, warn, error
    >> display(
    Display is like print, except that it supports logging and can be disabled.
    >> warn('warnings get a header that is printed in yellow.')
    warning: warnings get a header that is printed in yellow.
    >> error('errors get a header that is printed in red.')
    error: errors get a header that is printed in red.
Inform also provides logging and output control.
In addition, Inform provides a powerful generic exception that can be used 
directly as a general purpose exception, or can be subclassed to produce 
powerful specialized exceptions.  Inform exceptions are unique in that they keep 
all of the named and unnamed arguments so they can be used when reporting 
errors.
You can find the documentation on `ReadTheDocs
<https://inform.readthedocs.io>`_. You can download and install the latest
stable version of the code from `PyPI <https://pypi.python.org>`_ using::
    pip3 install --user --upgrade inform
You can find the latest development version of the source code on
`Github <https://github.com/KenKundert/inform>`_.
Supported in Python2.7, Python3.5, Python3.6, Python3.7 and Python3.8.

%package help
Summary:	Development documents and examples for inform
Provides:	python3-inform-doc
%description help
A package that provides specialized print functions that are used when 
communicating with the user. It allows you to easily print attractive, 
informative, and consistent error messages.  For example:
    >> from inform import display, warn, error
    >> display(
    Display is like print, except that it supports logging and can be disabled.
    >> warn('warnings get a header that is printed in yellow.')
    warning: warnings get a header that is printed in yellow.
    >> error('errors get a header that is printed in red.')
    error: errors get a header that is printed in red.
Inform also provides logging and output control.
In addition, Inform provides a powerful generic exception that can be used 
directly as a general purpose exception, or can be subclassed to produce 
powerful specialized exceptions.  Inform exceptions are unique in that they keep 
all of the named and unnamed arguments so they can be used when reporting 
errors.
You can find the documentation on `ReadTheDocs
<https://inform.readthedocs.io>`_. You can download and install the latest
stable version of the code from `PyPI <https://pypi.python.org>`_ using::
    pip3 install --user --upgrade inform
You can find the latest development version of the source code on
`Github <https://github.com/KenKundert/inform>`_.
Supported in Python2.7, Python3.5, Python3.6, Python3.7 and Python3.8.

%prep
%autosetup -n inform-1.28

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-inform -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 1.28-1
- Package Spec generated