%global _empty_manifest_terminate_build 0
Name: python-gym-saturation
Version: 0.10.1
Release: 1
Summary: Gymnasium environments for saturation provers
License: Apache-2.0
URL: https://github.com/inpefess/gym-saturation
Source0: https://mirrors.aliyun.com/pypi/web/packages/36/e5/8c195f8b3201af95c3b83ffec32b62a008fe533879582ab89ec7c740a52a/gym_saturation-0.10.1.tar.gz
BuildArch: noarch
Requires: python3-importlib_resources
Requires: python3-pexpect
Requires: python3-gymnasium
%description
``gym-saturation`` is a collection of `Gymnasium
`__ environments for reinforcement learning
(RL) agents striving to prove theorems. Currently, only theorems
written in `TPTP library `__ formal language are
supported.
There are two environments in ``gym-saturation`` following the same API: `SaturationEnv `__: ``VampireEnv`` is a wrapper around a recent `Vampire
`__ prover, and ``IProverEnv``
relies on a stable version of `iProver
`__.
In contrast to monolithic architecture of a typical Automated Theorem
Prover (ATP), ``gym-saturation`` gives different agents opportunities
to select clauses themselves and train from their experience.
Combined with a particular agent, ``gym-saturation`` can work as an
ATP.
``gym-saturation`` can be interesting for RL practitioners willing to
apply their experience to theorem proving without coding all the
logic-related stuff themselves. It also can be useful for automated
deduction researchers who want to create an RL-empowered ATP.
%package -n python3-gym-saturation
Summary: Gymnasium environments for saturation provers
Provides: python-gym-saturation
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-gym-saturation
``gym-saturation`` is a collection of `Gymnasium
`__ environments for reinforcement learning
(RL) agents striving to prove theorems. Currently, only theorems
written in `TPTP library `__ formal language are
supported.
There are two environments in ``gym-saturation`` following the same API: `SaturationEnv `__: ``VampireEnv`` is a wrapper around a recent `Vampire
`__ prover, and ``IProverEnv``
relies on a stable version of `iProver
`__.
In contrast to monolithic architecture of a typical Automated Theorem
Prover (ATP), ``gym-saturation`` gives different agents opportunities
to select clauses themselves and train from their experience.
Combined with a particular agent, ``gym-saturation`` can work as an
ATP.
``gym-saturation`` can be interesting for RL practitioners willing to
apply their experience to theorem proving without coding all the
logic-related stuff themselves. It also can be useful for automated
deduction researchers who want to create an RL-empowered ATP.
%package help
Summary: Development documents and examples for gym-saturation
Provides: python3-gym-saturation-doc
%description help
``gym-saturation`` is a collection of `Gymnasium
`__ environments for reinforcement learning
(RL) agents striving to prove theorems. Currently, only theorems
written in `TPTP library `__ formal language are
supported.
There are two environments in ``gym-saturation`` following the same API: `SaturationEnv `__: ``VampireEnv`` is a wrapper around a recent `Vampire
`__ prover, and ``IProverEnv``
relies on a stable version of `iProver
`__.
In contrast to monolithic architecture of a typical Automated Theorem
Prover (ATP), ``gym-saturation`` gives different agents opportunities
to select clauses themselves and train from their experience.
Combined with a particular agent, ``gym-saturation`` can work as an
ATP.
``gym-saturation`` can be interesting for RL practitioners willing to
apply their experience to theorem proving without coding all the
logic-related stuff themselves. It also can be useful for automated
deduction researchers who want to create an RL-empowered ATP.
%prep
%autosetup -n gym_saturation-0.10.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-gym-saturation -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 0.10.1-1
- Package Spec generated