%global _empty_manifest_terminate_build 0
Name: python-TakeMessageCleaner
Version: 1.1.4
Release: 1
Summary: TakeMessageCleaner is a tool for pre processing messages
License: MIT License
URL: https://github.com/karinatk/TakeMessageCleaner
Source0: https://mirrors.aliyun.com/pypi/web/packages/26/cb/b977c71a6a34322e23bee45b0be39ee0d0b3885f8383ff7b50d796119ff5/TakeMessageCleaner-1.1.4.tar.gz
BuildArch: noarch
Requires: python3-requests
Requires: python3-emoji
Requires: python3-Unidecode
Requires: python3-setuptools
Requires: python3-pandas
Requires: python3-numpy
%description
# TakeMessageCleaner
TakeMessageCleaner is a tool for pre processing messages.
It can be used to convert messages to lower case, correct spelling, remove elements like punctuation, emoji, whatapp's emoji, accentuation, number, cpf, url, e-mail, money, code, time, date and small talks.
Also, it can pre process data from a dataframe, series, list or csv file.
#### MessageCleaner.from_dataframe: creates a constructor from a dataframe
- config_file_path: str
config_file_path is the path of the json file with the configuration
- dataframe: pd.core.frame.DataFrame
dataframe is the pandas dataframe that needs to be processed.
- content_column : str
content_column is the column name of the dataframe that has the information to be processed.
#### MessageCleaner.from_series: creates a constructor from a series
- config_file_path: str
config_file_path is the path of the json file with the pre processing
- series: pd.core.frame.Series
series is the pandas series that needs to be processed.
#### MessageCleaner.from_list: creates a constructor from a list
- config_file_path: str
config_file_path is the path of the json file with the configuration
- lst: list
lst is the list of string that need to be processed.
#### MessageCleaner.from_file: creates a constructor from a csv file
file_path : str, content_column : str = 'Content', encoding: str = 'utf-8', sep: str = ';'
- config_file_path: str
config_file_path is the path of the json file with the configuration
- file_path : strt
file_path is the path of the csv file that needs to be processed.
- content_column: str
content_column is the column name of the dataframe that has the information to be processed. If the file separator is not set, the value 'Content' will be used.
- sep: str
sep is the csv file separator. If the file separator is not set, the value ';' will be used.
- encoding: str
encoding is the encoding of the csv file. If the file encoding is not set, the value 'utf-8' will be used.
#### MessageCleaner.pre_process: pre-process messages using a json file with the configuration.
The pre processing step is able to convert sentences to lower case, correct spelling and remove elements like punctuation, emoji, whatapp emoji, accentuation, number, cpf, url, e-mail, money, code, time, date and small talks.
Optionally, you can activate use_placeholder to insert a placeholder where the element was removed. For example: "I want 2 apples" would be converted in "I want NUMBER apples".
## config.json
```
{
"use_placeholder": true,
"verbose": true,
"processing": {
"lower": true,
"punctuation": true,
"emoji": true,
"wa_emoji": true,
"accentuation": true,
"number": true,
"cpf": true,
"url": true,
"email": true,
"money": true,
"code": true,
"time": true,
"date": true,
"spelling": true
},
"output": {
"file_name": "output_file.csv",
"file_encoding" : "utf-8",
"file_sep": ";",
"remove_duplicates": true,
"remove_empty": true,
"sort_by_length": true
}
}
```
## Installation
Use the package manager [pip](https://pip.pypa.io/en/stable/) to install TakeMessageCleaner
```bash
pip install TakeMessageCleaner
```
## Usage
```python
import MessageCleaner as mc
cleaner = mc.MessageCleaner.from_file(config_file_path = 'C:/Documents/config.json', file_path = 'C:/Users/mydata.csv', sep = ';', encoding = 'latin-1')
result = cleaner.clean()
print(result)
```
## Author
Karina Tiemi Kato
## License
[MIT](https://choosealicense.com/licenses/mit/)
%package -n python3-TakeMessageCleaner
Summary: TakeMessageCleaner is a tool for pre processing messages
Provides: python-TakeMessageCleaner
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-TakeMessageCleaner
# TakeMessageCleaner
TakeMessageCleaner is a tool for pre processing messages.
It can be used to convert messages to lower case, correct spelling, remove elements like punctuation, emoji, whatapp's emoji, accentuation, number, cpf, url, e-mail, money, code, time, date and small talks.
Also, it can pre process data from a dataframe, series, list or csv file.
#### MessageCleaner.from_dataframe: creates a constructor from a dataframe
- config_file_path: str
config_file_path is the path of the json file with the configuration
- dataframe: pd.core.frame.DataFrame
dataframe is the pandas dataframe that needs to be processed.
- content_column : str
content_column is the column name of the dataframe that has the information to be processed.
#### MessageCleaner.from_series: creates a constructor from a series
- config_file_path: str
config_file_path is the path of the json file with the pre processing
- series: pd.core.frame.Series
series is the pandas series that needs to be processed.
#### MessageCleaner.from_list: creates a constructor from a list
- config_file_path: str
config_file_path is the path of the json file with the configuration
- lst: list
lst is the list of string that need to be processed.
#### MessageCleaner.from_file: creates a constructor from a csv file
file_path : str, content_column : str = 'Content', encoding: str = 'utf-8', sep: str = ';'
- config_file_path: str
config_file_path is the path of the json file with the configuration
- file_path : strt
file_path is the path of the csv file that needs to be processed.
- content_column: str
content_column is the column name of the dataframe that has the information to be processed. If the file separator is not set, the value 'Content' will be used.
- sep: str
sep is the csv file separator. If the file separator is not set, the value ';' will be used.
- encoding: str
encoding is the encoding of the csv file. If the file encoding is not set, the value 'utf-8' will be used.
#### MessageCleaner.pre_process: pre-process messages using a json file with the configuration.
The pre processing step is able to convert sentences to lower case, correct spelling and remove elements like punctuation, emoji, whatapp emoji, accentuation, number, cpf, url, e-mail, money, code, time, date and small talks.
Optionally, you can activate use_placeholder to insert a placeholder where the element was removed. For example: "I want 2 apples" would be converted in "I want NUMBER apples".
## config.json
```
{
"use_placeholder": true,
"verbose": true,
"processing": {
"lower": true,
"punctuation": true,
"emoji": true,
"wa_emoji": true,
"accentuation": true,
"number": true,
"cpf": true,
"url": true,
"email": true,
"money": true,
"code": true,
"time": true,
"date": true,
"spelling": true
},
"output": {
"file_name": "output_file.csv",
"file_encoding" : "utf-8",
"file_sep": ";",
"remove_duplicates": true,
"remove_empty": true,
"sort_by_length": true
}
}
```
## Installation
Use the package manager [pip](https://pip.pypa.io/en/stable/) to install TakeMessageCleaner
```bash
pip install TakeMessageCleaner
```
## Usage
```python
import MessageCleaner as mc
cleaner = mc.MessageCleaner.from_file(config_file_path = 'C:/Documents/config.json', file_path = 'C:/Users/mydata.csv', sep = ';', encoding = 'latin-1')
result = cleaner.clean()
print(result)
```
## Author
Karina Tiemi Kato
## License
[MIT](https://choosealicense.com/licenses/mit/)
%package help
Summary: Development documents and examples for TakeMessageCleaner
Provides: python3-TakeMessageCleaner-doc
%description help
# TakeMessageCleaner
TakeMessageCleaner is a tool for pre processing messages.
It can be used to convert messages to lower case, correct spelling, remove elements like punctuation, emoji, whatapp's emoji, accentuation, number, cpf, url, e-mail, money, code, time, date and small talks.
Also, it can pre process data from a dataframe, series, list or csv file.
#### MessageCleaner.from_dataframe: creates a constructor from a dataframe
- config_file_path: str
config_file_path is the path of the json file with the configuration
- dataframe: pd.core.frame.DataFrame
dataframe is the pandas dataframe that needs to be processed.
- content_column : str
content_column is the column name of the dataframe that has the information to be processed.
#### MessageCleaner.from_series: creates a constructor from a series
- config_file_path: str
config_file_path is the path of the json file with the pre processing
- series: pd.core.frame.Series
series is the pandas series that needs to be processed.
#### MessageCleaner.from_list: creates a constructor from a list
- config_file_path: str
config_file_path is the path of the json file with the configuration
- lst: list
lst is the list of string that need to be processed.
#### MessageCleaner.from_file: creates a constructor from a csv file
file_path : str, content_column : str = 'Content', encoding: str = 'utf-8', sep: str = ';'
- config_file_path: str
config_file_path is the path of the json file with the configuration
- file_path : strt
file_path is the path of the csv file that needs to be processed.
- content_column: str
content_column is the column name of the dataframe that has the information to be processed. If the file separator is not set, the value 'Content' will be used.
- sep: str
sep is the csv file separator. If the file separator is not set, the value ';' will be used.
- encoding: str
encoding is the encoding of the csv file. If the file encoding is not set, the value 'utf-8' will be used.
#### MessageCleaner.pre_process: pre-process messages using a json file with the configuration.
The pre processing step is able to convert sentences to lower case, correct spelling and remove elements like punctuation, emoji, whatapp emoji, accentuation, number, cpf, url, e-mail, money, code, time, date and small talks.
Optionally, you can activate use_placeholder to insert a placeholder where the element was removed. For example: "I want 2 apples" would be converted in "I want NUMBER apples".
## config.json
```
{
"use_placeholder": true,
"verbose": true,
"processing": {
"lower": true,
"punctuation": true,
"emoji": true,
"wa_emoji": true,
"accentuation": true,
"number": true,
"cpf": true,
"url": true,
"email": true,
"money": true,
"code": true,
"time": true,
"date": true,
"spelling": true
},
"output": {
"file_name": "output_file.csv",
"file_encoding" : "utf-8",
"file_sep": ";",
"remove_duplicates": true,
"remove_empty": true,
"sort_by_length": true
}
}
```
## Installation
Use the package manager [pip](https://pip.pypa.io/en/stable/) to install TakeMessageCleaner
```bash
pip install TakeMessageCleaner
```
## Usage
```python
import MessageCleaner as mc
cleaner = mc.MessageCleaner.from_file(config_file_path = 'C:/Documents/config.json', file_path = 'C:/Users/mydata.csv', sep = ';', encoding = 'latin-1')
result = cleaner.clean()
print(result)
```
## Author
Karina Tiemi Kato
## License
[MIT](https://choosealicense.com/licenses/mit/)
%prep
%autosetup -n TakeMessageCleaner-1.1.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-TakeMessageCleaner -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 1.1.4-1
- Package Spec generated