%global _empty_manifest_terminate_build 0 Name: python-vandal Version: 4.0.9 Release: 1 Summary: Data science, Data manipulation and Machine learning library. License: Apache Software License URL: http://github.com/dkundih/vandal Source0: https://mirrors.aliyun.com/pypi/web/packages/1e/15/9bbc30dcd1c60db1fa8c7c5192decdeea76c591b082ab9917a92c2334110/vandal-4.0.9.tar.gz BuildArch: noarch %description Data science, Data manipulation and Machine learning library. Use permitted according to the terms of use and conditions set by the attached license. **Example of use** Visit my Data Library at https://github.com/dkundih/DataLibrary in order to see the demonstration of use in practical examples. **Installation** ```sh # using pip. pip install vandal ``` **Dependencies** ```sh # using pip. pip install vandal -r requirements.txt ```

GUI applications

vandal provides an option of being run within any terminal as a data science/machine learning application in the form of a GUI. ```sh # terminal app entry choices for GUI apps. python -m vandal -e montecarlogui / python -m vandal --entry montecarlogui ```

Terminal CLI application

vandal provides an option of being run within any terminal as a data science/machine learning application. **Terminal options** ```sh # terminal app options help. python -m vandal -h / python -m vandal --help ``` ```sh # terminal app entry choices. python -m vandal -e / python -m vandal --entry ``` ```sh # terminal app entry example. python -m vandal -e montecarlo / python -m vandal --entry montecarlo ``` **Example use** TERMINAL USE #1 ![vandal-terminalgui](https://raw.githubusercontent.com/dkundih/vandal/master/_logistics/MCGUI.png) **Example use** TERMINAL USE #1 ![vandal-terminal1](https://raw.githubusercontent.com/dkundih/vandal/master/_logistics/vandalCLI1.jpg) TERMINAL USE #2 ![vandal-terminal2](https://raw.githubusercontent.com/dkundih/vandal/master/_logistics/vandalCLI2.jpg) EXAMPLE GRAPH ![vandal-terminal3](https://raw.githubusercontent.com/dkundih/vandal/master/_logistics/vandalCLI3.jpeg) EXAMPLE OUTPUT ![vandal-terminal4](https://raw.githubusercontent.com/dkundih/vandal/master/_logistics/vandalCLI4.jpg)

Python library

vandal functions as a library that can be run in python/jupyter environment and also integrated in other libraries and projects. **Import** ```sh # import the library. import vandal ``` **Help** ```sh # library help. print(help(vandal)) ``` ```sh # module/object help. print(help(vandal.MonteCarlo)) ``` **Meta data** ```sh # meta data (individual). print(vandal.__version__) ``` ```sh # all meta data. print(help(vandal.misc._meta)) ``` **Library location** ```sh # file location after installation. print(help(vandal.__file__)) ``` **For whom is vandal made for?** vandal is a Python library for Data science and Machine learning, designed to aid researchers and engineers to meet their goals with small effort. **Why vandal?** As a vandal gives abandoned walls meaning with graffiti, so does vandal library to the data. **Is vandal free to use?** vandal is completely free of charge for both personal and commercial use, but only under the conditions stated in the license. Developing such a complex library isn't easy and takes a lot of time and knowledge in several fields of science such as statistics, programming and domain knowledge, so any donation at https://patreon.com/dkundih or https://www.buymeacoffee.com/dkundih in order to keep vandal free is more than welcome. **A word from the author!** The library itself, it's maintenance, updates and stability, logo, videos, promotional materials and everything associated with duality are done by **David Kundih** from **Croatia**.

Hi! :wave:

My name is David Kundih and I am a Master of Engineering in Sustainable Mobility and Logistics, currently specializing in Digital Transformation of Traffic and Logistics using Python, JavaScript, HTML and CSS.

My latest projects:

promet-kc

vandal

duality

logistics

unin

People shine the brightest when they seek to understand what kind of love sustains them.

%package -n python3-vandal Summary: Data science, Data manipulation and Machine learning library. Provides: python-vandal BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-vandal Data science, Data manipulation and Machine learning library. Use permitted according to the terms of use and conditions set by the attached license. **Example of use** Visit my Data Library at https://github.com/dkundih/DataLibrary in order to see the demonstration of use in practical examples. **Installation** ```sh # using pip. pip install vandal ``` **Dependencies** ```sh # using pip. pip install vandal -r requirements.txt ```

GUI applications

vandal provides an option of being run within any terminal as a data science/machine learning application in the form of a GUI. ```sh # terminal app entry choices for GUI apps. python -m vandal -e montecarlogui / python -m vandal --entry montecarlogui ```

Terminal CLI application

vandal provides an option of being run within any terminal as a data science/machine learning application. **Terminal options** ```sh # terminal app options help. python -m vandal -h / python -m vandal --help ``` ```sh # terminal app entry choices. python -m vandal -e / python -m vandal --entry ``` ```sh # terminal app entry example. python -m vandal -e montecarlo / python -m vandal --entry montecarlo ``` **Example use** TERMINAL USE #1 ![vandal-terminalgui](https://raw.githubusercontent.com/dkundih/vandal/master/_logistics/MCGUI.png) **Example use** TERMINAL USE #1 ![vandal-terminal1](https://raw.githubusercontent.com/dkundih/vandal/master/_logistics/vandalCLI1.jpg) TERMINAL USE #2 ![vandal-terminal2](https://raw.githubusercontent.com/dkundih/vandal/master/_logistics/vandalCLI2.jpg) EXAMPLE GRAPH ![vandal-terminal3](https://raw.githubusercontent.com/dkundih/vandal/master/_logistics/vandalCLI3.jpeg) EXAMPLE OUTPUT ![vandal-terminal4](https://raw.githubusercontent.com/dkundih/vandal/master/_logistics/vandalCLI4.jpg)

Python library

vandal functions as a library that can be run in python/jupyter environment and also integrated in other libraries and projects. **Import** ```sh # import the library. import vandal ``` **Help** ```sh # library help. print(help(vandal)) ``` ```sh # module/object help. print(help(vandal.MonteCarlo)) ``` **Meta data** ```sh # meta data (individual). print(vandal.__version__) ``` ```sh # all meta data. print(help(vandal.misc._meta)) ``` **Library location** ```sh # file location after installation. print(help(vandal.__file__)) ``` **For whom is vandal made for?** vandal is a Python library for Data science and Machine learning, designed to aid researchers and engineers to meet their goals with small effort. **Why vandal?** As a vandal gives abandoned walls meaning with graffiti, so does vandal library to the data. **Is vandal free to use?** vandal is completely free of charge for both personal and commercial use, but only under the conditions stated in the license. Developing such a complex library isn't easy and takes a lot of time and knowledge in several fields of science such as statistics, programming and domain knowledge, so any donation at https://patreon.com/dkundih or https://www.buymeacoffee.com/dkundih in order to keep vandal free is more than welcome. **A word from the author!** The library itself, it's maintenance, updates and stability, logo, videos, promotional materials and everything associated with duality are done by **David Kundih** from **Croatia**.

Hi! :wave:

My name is David Kundih and I am a Master of Engineering in Sustainable Mobility and Logistics, currently specializing in Digital Transformation of Traffic and Logistics using Python, JavaScript, HTML and CSS.

My latest projects:

promet-kc

vandal

duality

logistics

unin

People shine the brightest when they seek to understand what kind of love sustains them.

%package help Summary: Development documents and examples for vandal Provides: python3-vandal-doc %description help Data science, Data manipulation and Machine learning library. Use permitted according to the terms of use and conditions set by the attached license. **Example of use** Visit my Data Library at https://github.com/dkundih/DataLibrary in order to see the demonstration of use in practical examples. **Installation** ```sh # using pip. pip install vandal ``` **Dependencies** ```sh # using pip. pip install vandal -r requirements.txt ```

GUI applications

vandal provides an option of being run within any terminal as a data science/machine learning application in the form of a GUI. ```sh # terminal app entry choices for GUI apps. python -m vandal -e montecarlogui / python -m vandal --entry montecarlogui ```

Terminal CLI application

vandal provides an option of being run within any terminal as a data science/machine learning application. **Terminal options** ```sh # terminal app options help. python -m vandal -h / python -m vandal --help ``` ```sh # terminal app entry choices. python -m vandal -e / python -m vandal --entry ``` ```sh # terminal app entry example. python -m vandal -e montecarlo / python -m vandal --entry montecarlo ``` **Example use** TERMINAL USE #1 ![vandal-terminalgui](https://raw.githubusercontent.com/dkundih/vandal/master/_logistics/MCGUI.png) **Example use** TERMINAL USE #1 ![vandal-terminal1](https://raw.githubusercontent.com/dkundih/vandal/master/_logistics/vandalCLI1.jpg) TERMINAL USE #2 ![vandal-terminal2](https://raw.githubusercontent.com/dkundih/vandal/master/_logistics/vandalCLI2.jpg) EXAMPLE GRAPH ![vandal-terminal3](https://raw.githubusercontent.com/dkundih/vandal/master/_logistics/vandalCLI3.jpeg) EXAMPLE OUTPUT ![vandal-terminal4](https://raw.githubusercontent.com/dkundih/vandal/master/_logistics/vandalCLI4.jpg)

Python library

vandal functions as a library that can be run in python/jupyter environment and also integrated in other libraries and projects. **Import** ```sh # import the library. import vandal ``` **Help** ```sh # library help. print(help(vandal)) ``` ```sh # module/object help. print(help(vandal.MonteCarlo)) ``` **Meta data** ```sh # meta data (individual). print(vandal.__version__) ``` ```sh # all meta data. print(help(vandal.misc._meta)) ``` **Library location** ```sh # file location after installation. print(help(vandal.__file__)) ``` **For whom is vandal made for?** vandal is a Python library for Data science and Machine learning, designed to aid researchers and engineers to meet their goals with small effort. **Why vandal?** As a vandal gives abandoned walls meaning with graffiti, so does vandal library to the data. **Is vandal free to use?** vandal is completely free of charge for both personal and commercial use, but only under the conditions stated in the license. Developing such a complex library isn't easy and takes a lot of time and knowledge in several fields of science such as statistics, programming and domain knowledge, so any donation at https://patreon.com/dkundih or https://www.buymeacoffee.com/dkundih in order to keep vandal free is more than welcome. **A word from the author!** The library itself, it's maintenance, updates and stability, logo, videos, promotional materials and everything associated with duality are done by **David Kundih** from **Croatia**.

Hi! :wave:

My name is David Kundih and I am a Master of Engineering in Sustainable Mobility and Logistics, currently specializing in Digital Transformation of Traffic and Logistics using Python, JavaScript, HTML and CSS.

My latest projects:

promet-kc

vandal

duality

logistics

unin

People shine the brightest when they seek to understand what kind of love sustains them.

%prep %autosetup -n vandal-4.0.9 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-vandal -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Thu Jun 08 2023 Python_Bot - 4.0.9-1 - Package Spec generated