%global _empty_manifest_terminate_build 0
Name:		python-Flask-MongoAlchemy
Version:	0.7.2
Release:	1
Summary:	Add Flask support for MongoDB using MongoAlchemy.
License:	BSD
URL:		http://github.com/cobrateam/flask-mongoalchemy
Source0:	https://mirrors.aliyun.com/pypi/web/packages/7a/7d/7b146ab50332c3882520ed7e7f231404a630dedbb7d34f8adb021dbe5180/Flask-MongoAlchemy-0.7.2.tar.gz
BuildArch:	noarch


%description
`Flask <http://flask.pocoo.org>`_ support for `MongoDB <https://mongodb.org>`_ using `MongoAlchemy <http://mongoalchemy.org>`_.
Documentation
+++++++++++++
If you want to get started, check the `example sourcecode <https://github.com/cobrateam/flask-mongoalchemy/tree/master/examples>`_ out.
    For full documentation, see the online docs at: `<https://pythonhosted.org/Flask-MongoAlchemy/>`_.
Development
+++++++++++
* Source hosted at `Github <https://github.com/cobrateam/flask-mongoalchemy>`_
* Report issues on `Github Issues <https://github.com/cobrateam/flask-mongoalchemy/issues>`_

%package -n python3-Flask-MongoAlchemy
Summary:	Add Flask support for MongoDB using MongoAlchemy.
Provides:	python-Flask-MongoAlchemy
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-Flask-MongoAlchemy
`Flask <http://flask.pocoo.org>`_ support for `MongoDB <https://mongodb.org>`_ using `MongoAlchemy <http://mongoalchemy.org>`_.
Documentation
+++++++++++++
If you want to get started, check the `example sourcecode <https://github.com/cobrateam/flask-mongoalchemy/tree/master/examples>`_ out.
    For full documentation, see the online docs at: `<https://pythonhosted.org/Flask-MongoAlchemy/>`_.
Development
+++++++++++
* Source hosted at `Github <https://github.com/cobrateam/flask-mongoalchemy>`_
* Report issues on `Github Issues <https://github.com/cobrateam/flask-mongoalchemy/issues>`_

%package help
Summary:	Development documents and examples for Flask-MongoAlchemy
Provides:	python3-Flask-MongoAlchemy-doc
%description help
`Flask <http://flask.pocoo.org>`_ support for `MongoDB <https://mongodb.org>`_ using `MongoAlchemy <http://mongoalchemy.org>`_.
Documentation
+++++++++++++
If you want to get started, check the `example sourcecode <https://github.com/cobrateam/flask-mongoalchemy/tree/master/examples>`_ out.
    For full documentation, see the online docs at: `<https://pythonhosted.org/Flask-MongoAlchemy/>`_.
Development
+++++++++++
* Source hosted at `Github <https://github.com/cobrateam/flask-mongoalchemy>`_
* Report issues on `Github Issues <https://github.com/cobrateam/flask-mongoalchemy/issues>`_

%prep
%autosetup -n Flask-MongoAlchemy-0.7.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Flask-MongoAlchemy -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.7.2-1
- Package Spec generated