%global _empty_manifest_terminate_build 0
Name:		python-Couchapp
Version:	1.0.2
Release:	1
Summary:	Standalone CouchDB Application Development Made Simple.
License:	Apache License 2
URL:		http://github.com/couchapp/couchapp/tree/master
Source0:	https://mirrors.aliyun.com/pypi/web/packages/1d/4b/921fcbac374cc1a8a442b48f02dc99de190009596b65dc30d7b33da7952e/Couchapp-1.0.2.tar.gz
BuildArch:	noarch

Requires:	python3-restkit
Requires:	python3-watchdog

%description
CouchApp is designed to structure standalone CouchDB application
development for maximum application portability.
CouchApp is a set of scripts and a `jQuery <http://jquery.com>`_ plugin
designed  to bring clarity and order to the freedom of
`CouchDB <http://couchdb.apache.org>`_'s document-based approach.
Also, be sure to checkout our Erlang-based sibling,
`erica <https://github.com/benoitc/erica>`_.

%package -n python3-Couchapp
Summary:	Standalone CouchDB Application Development Made Simple.
Provides:	python-Couchapp
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-Couchapp
CouchApp is designed to structure standalone CouchDB application
development for maximum application portability.
CouchApp is a set of scripts and a `jQuery <http://jquery.com>`_ plugin
designed  to bring clarity and order to the freedom of
`CouchDB <http://couchdb.apache.org>`_'s document-based approach.
Also, be sure to checkout our Erlang-based sibling,
`erica <https://github.com/benoitc/erica>`_.

%package help
Summary:	Development documents and examples for Couchapp
Provides:	python3-Couchapp-doc
%description help
CouchApp is designed to structure standalone CouchDB application
development for maximum application portability.
CouchApp is a set of scripts and a `jQuery <http://jquery.com>`_ plugin
designed  to bring clarity and order to the freedom of
`CouchDB <http://couchdb.apache.org>`_'s document-based approach.
Also, be sure to checkout our Erlang-based sibling,
`erica <https://github.com/benoitc/erica>`_.

%prep
%autosetup -n Couchapp-1.0.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Couchapp -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.2-1
- Package Spec generated