%global _empty_manifest_terminate_build 0
Name:		python-hook-run
Version:	1.1.0
Release:	1
Summary:	Run commands using Python virtual environment
License:	MIT License
URL:		https://github.com/Kirusi/hook-run
Source0:	https://mirrors.aliyun.com/pypi/web/packages/61/69/d333b178073a28db4254ea4281a41bcdda923a28aa02ff446a4e9516d7a8/hook-run-1.1.0.tar.gz
BuildArch:	noarch


%description
# hook-run

Python bootstrap to activate a virtual environment (venv, or conda) and run a command. Intended to be used with pre-commit pypi package. Inspired by [venv-run](https://github.com/guludo/venv-run)

Runs a command from an existing python virtual environment. Script looks
for a private configuration file in the current working directory
hook-run.json. If such file is found, it's expected to follow format:

```
{
    "path": "/home/user/my_project/venv/bin"
}
```

Where `path` points to the virtual environment to be used.
If configuration file is not found, then no bootstrapping is performed, but script proceeds with command execution

After bootstrapping is done, then specified command is executed.

%package -n python3-hook-run
Summary:	Run commands using Python virtual environment
Provides:	python-hook-run
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-hook-run
# hook-run

Python bootstrap to activate a virtual environment (venv, or conda) and run a command. Intended to be used with pre-commit pypi package. Inspired by [venv-run](https://github.com/guludo/venv-run)

Runs a command from an existing python virtual environment. Script looks
for a private configuration file in the current working directory
hook-run.json. If such file is found, it's expected to follow format:

```
{
    "path": "/home/user/my_project/venv/bin"
}
```

Where `path` points to the virtual environment to be used.
If configuration file is not found, then no bootstrapping is performed, but script proceeds with command execution

After bootstrapping is done, then specified command is executed.

%package help
Summary:	Development documents and examples for hook-run
Provides:	python3-hook-run-doc
%description help
# hook-run

Python bootstrap to activate a virtual environment (venv, or conda) and run a command. Intended to be used with pre-commit pypi package. Inspired by [venv-run](https://github.com/guludo/venv-run)

Runs a command from an existing python virtual environment. Script looks
for a private configuration file in the current working directory
hook-run.json. If such file is found, it's expected to follow format:

```
{
    "path": "/home/user/my_project/venv/bin"
}
```

Where `path` points to the virtual environment to be used.
If configuration file is not found, then no bootstrapping is performed, but script proceeds with command execution

After bootstrapping is done, then specified command is executed.

%prep
%autosetup -n hook-run-1.1.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-hook-run -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1.0-1
- Package Spec generated