%global _empty_manifest_terminate_build 0
Name:		python-Ball
Version:	0.2.9
Release:	1
Summary:	Ball: A Python Package for Detecting Distribution Difference and Association in Metric Spaces
License:	GPL-3
URL:		https://github.com/Mamba413/Ball
Source0:	https://mirrors.aliyun.com/pypi/web/packages/a3/1a/46099e0cee1243a07cdbfd10c1362912fcd4b86f9f368f9b094746b22c84/Ball-0.2.9.tar.gz

Requires:	python3-numpy
Requires:	python3-scikit-learn
Requires:	python3-pygam

%description


%package -n python3-Ball
Summary:	Ball: A Python Package for Detecting Distribution Difference and Association in Metric Spaces
Provides:	python-Ball
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
BuildRequires:	python3-cffi
BuildRequires:	gcc
BuildRequires:	gdb
%description -n python3-Ball


%package help
Summary:	Development documents and examples for Ball
Provides:	python3-Ball-doc
%description help


%prep
%autosetup -n Ball-0.2.9

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Ball -f filelist.lst
%dir %{python3_sitearch}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.9-1
- Package Spec generated