%global _empty_manifest_terminate_build 0
Name: python-atlasapi
Version: 2.0.11
Release: 1
Summary: Expose MongoDB Atlas Cloud provider APIs
License: Apache License 2.0
URL: https://github.com/mgmonteleone/python-atlasapi
Source0: https://mirrors.aliyun.com/pypi/web/packages/e1/d3/c090222b53a94d0910f3d0a646b0df8f3df4b3f7fd897864f454f0c3f746/atlasapi-2.0.11.tar.gz
BuildArch: noarch
Requires: python3-requests
Requires: python3-dateutil
Requires: python3-isodate
Requires: python3-future
Requires: python3-pytz
Requires: python3-coolname
Requires: python3-humanfriendly
Requires: python3-nose
%description
Python Bindings for the Atlas Public API
This project intends to create a fairly opinionated set of bindings for the Atlas Public API which makes interacting
with Atlas using Python easier. The API makes extensive use of enums and other helper type objects to take some
of the guess work of administering Atlas clusters with Python.
In most cases objects will be returned based upon the structure of the json returned but the API Endpoints. These objects
are defined either in the `specs.py` module or in a module named after the objects themselves (`alerts.py` for example).
All calls to the Atlas API require API credentials, you can configure them in your Atlas project.
`Atlas API `__
`Configure Atlas API Access `__
`Current state of the python-atlasapi support `__
%package -n python3-atlasapi
Summary: Expose MongoDB Atlas Cloud provider APIs
Provides: python-atlasapi
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-atlasapi
Python Bindings for the Atlas Public API
This project intends to create a fairly opinionated set of bindings for the Atlas Public API which makes interacting
with Atlas using Python easier. The API makes extensive use of enums and other helper type objects to take some
of the guess work of administering Atlas clusters with Python.
In most cases objects will be returned based upon the structure of the json returned but the API Endpoints. These objects
are defined either in the `specs.py` module or in a module named after the objects themselves (`alerts.py` for example).
All calls to the Atlas API require API credentials, you can configure them in your Atlas project.
`Atlas API `__
`Configure Atlas API Access `__
`Current state of the python-atlasapi support `__
%package help
Summary: Development documents and examples for atlasapi
Provides: python3-atlasapi-doc
%description help
Python Bindings for the Atlas Public API
This project intends to create a fairly opinionated set of bindings for the Atlas Public API which makes interacting
with Atlas using Python easier. The API makes extensive use of enums and other helper type objects to take some
of the guess work of administering Atlas clusters with Python.
In most cases objects will be returned based upon the structure of the json returned but the API Endpoints. These objects
are defined either in the `specs.py` module or in a module named after the objects themselves (`alerts.py` for example).
All calls to the Atlas API require API credentials, you can configure them in your Atlas project.
`Atlas API `__
`Configure Atlas API Access `__
`Current state of the python-atlasapi support `__
%prep
%autosetup -n atlasapi-2.0.11
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-atlasapi -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 2.0.11-1
- Package Spec generated