%global _empty_manifest_terminate_build 0
Name:		python-zetane
Version:	0.2.0
Release:	1
Summary:	Zetane Protector API
License:	LICENSE.md
URL:		https://zetane.com
Source0:	https://mirrors.aliyun.com/pypi/web/packages/ef/17/69452aac6ffe4b35422febd24cbb96e0238532a7c5b211bd89a7e6fa421e/zetane-0.2.0.tar.gz
BuildArch:	noarch

Requires:	python3-dotenv
Requires:	python3-tqdm
Requires:	python3-requests
Requires:	python3-numpy

%description
Zetane Protector API is an automated platform for testing and improving the robustness of machine learning models and their data. It provides data scientists and operators with insights into proposed machine learning solutions and helps validate, understand, and analyze the operational boundaries of machine learning data and models prior to deployment.

Visit our [docs](https://docs.zetane.com) for more details.


%package -n python3-zetane
Summary:	Zetane Protector API
Provides:	python-zetane
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-zetane
Zetane Protector API is an automated platform for testing and improving the robustness of machine learning models and their data. It provides data scientists and operators with insights into proposed machine learning solutions and helps validate, understand, and analyze the operational boundaries of machine learning data and models prior to deployment.

Visit our [docs](https://docs.zetane.com) for more details.


%package help
Summary:	Development documents and examples for zetane
Provides:	python3-zetane-doc
%description help
Zetane Protector API is an automated platform for testing and improving the robustness of machine learning models and their data. It provides data scientists and operators with insights into proposed machine learning solutions and helps validate, understand, and analyze the operational boundaries of machine learning data and models prior to deployment.

Visit our [docs](https://docs.zetane.com) for more details.


%prep
%autosetup -n zetane-0.2.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-zetane -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.0-1
- Package Spec generated