%global _empty_manifest_terminate_build 0
Name:		python-solidfire-sdk-python
Version:	12.3.0.203
Release:	1
Summary:	SolidFire Python SDK
License:	Apache2
URL:		https://pypi.org/project/solidfire-sdk-python/
Source0:	https://mirrors.aliyun.com/pypi/web/packages/8c/67/5c1366d0cb98ac1b31b3c763667ee49cdb333f18b78f472ac0724e9b3b66/solidfire-sdk-python-12.3.0.203.tar.gz
BuildArch:	noarch

Requires:	python3-enum34
Requires:	python3-future
Requires:	python3-requests
Requires:	python3-setuptools
Requires:	python3-check-manifest
Requires:	python3-Sphinx
Requires:	python3-sphinx-rtd-theme
Requires:	python3-twine
Requires:	python3-coverage
Requires:	python3-pyhamcrest
Requires:	python3-pytest
Requires:	python3-pytest-flake8

%description
Python SDK library for interacting with SolidFire Element API
|pypy| |python| |format| |downloads| |license|

%package -n python3-solidfire-sdk-python
Summary:	SolidFire Python SDK
Provides:	python-solidfire-sdk-python
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-solidfire-sdk-python
Python SDK library for interacting with SolidFire Element API
|pypy| |python| |format| |downloads| |license|

%package help
Summary:	Development documents and examples for solidfire-sdk-python
Provides:	python3-solidfire-sdk-python-doc
%description help
Python SDK library for interacting with SolidFire Element API
|pypy| |python| |format| |downloads| |license|

%prep
%autosetup -n solidfire-sdk-python-12.3.0.203

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-solidfire-sdk-python -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 12.3.0.203-1
- Package Spec generated