%global _empty_manifest_terminate_build 0
Name: python-simple-value-object
Version: 2.0
Release: 1
Summary: A simple mixin to create Value Objects
License: MIT/X11
URL: https://github.com/quiqueporta/value-object
Source0: https://mirrors.aliyun.com/pypi/web/packages/ff/bb/455cc9173917266e270381e8ebdaa19f0fee8d2da79183175a29833538f3/simple-value-object-2.0.tar.gz
BuildArch: noarch
%description
|Version Number| |Python Version| |License MIT|
Based on Ruby Gem by NoFlopSquad (https://github.com/noflopsquad/value-object)
A **value object** is a small object that represents a simple entity whose equality isn't based on identity:
i.e. two value objects are equal when they have the same value, not necessarily being the same object.
`Wikipedia `_.
%package -n python3-simple-value-object
Summary: A simple mixin to create Value Objects
Provides: python-simple-value-object
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-simple-value-object
|Version Number| |Python Version| |License MIT|
Based on Ruby Gem by NoFlopSquad (https://github.com/noflopsquad/value-object)
A **value object** is a small object that represents a simple entity whose equality isn't based on identity:
i.e. two value objects are equal when they have the same value, not necessarily being the same object.
`Wikipedia `_.
%package help
Summary: Development documents and examples for simple-value-object
Provides: python3-simple-value-object-doc
%description help
|Version Number| |Python Version| |License MIT|
Based on Ruby Gem by NoFlopSquad (https://github.com/noflopsquad/value-object)
A **value object** is a small object that represents a simple entity whose equality isn't based on identity:
i.e. two value objects are equal when they have the same value, not necessarily being the same object.
`Wikipedia `_.
%prep
%autosetup -n simple-value-object-2.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-simple-value-object -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 2.0-1
- Package Spec generated