%global _empty_manifest_terminate_build 0
Name: python-git-phoenix
Version: 1.2.0
Release: 1
Summary: A dynamic git branching tool
License: MIT
URL: https://github.com/victoraugustofd/git-phoenix
Source0: https://mirrors.aliyun.com/pypi/web/packages/f9/09/abbc1ecd037fcb1fcd88dbe1afeca111aa81301088f986ab34d5aed3989d/git-phoenix-1.2.0.tar.gz
BuildArch: noarch
Requires: python3-GitPython
Requires: python3-regex
Requires: python3-argparse
Requires: python3-jsonschema
Requires: python3-coloredlogs
Requires: python3-questionary
Requires: python3-click
%description
# Git Phoenix
![Python](https://img.shields.io/badge/python-3670A0?style=for-the-badge&logo=python&logoColor=ffdd54)
[![python: 3.7+](https://img.shields.io/badge/python-3.7+-blue)](https://www.python.org/download/releases/3.7.0/)
[![Open Source Love](https://badges.frapsoft.com/os/v2/open-source.svg?v=103)](https://github.com/ellerbrock/open-source-badges/)
[![License: MIT](https://img.shields.io/badge/License-MIT-yellow.svg)](https://github.com/victoraugustofd/git-phoenix/blob/master/LICENSE)
[![Join the chat at https://gitter.im/git-phoenix/community](https://badges.gitter.im/git-phoenix/community.svg)](https://gitter.im/git-phoenix/community?utm_source=badge&utm_medium=badge&utm_campaign=pr-badge&utm_content=badge)
[![CircleCI](https://circleci.com/gh/victoraugustofd/git-phoenix.svg?style=svg)](https://circleci.com/gh/victoraugustofd/git-phoenix) [![codecov.io](https://codecov.io/gh/victoraugustofd/git-phoenix/coverage.svg?branch=master)](https://codecov.io/gh/victoraugustofd/git-phoenix)
## A dynamic Git Branching Tool
Git Phoenix is a Dynamic Branching Tool. We noticed that not all projects can be managed, using the branching models that are largely used by several companies. Many of them, have to adapt the way that they work with Git, just to fit with the branching model chosen.
Git Phoenix is exactly the opposite.
We made a system that adapts itself with the rules defined by the user or company, instead of the user or company adapt themselves to the system.
You can define the branching rules for your Git Repository on a JSON template.
%package -n python3-git-phoenix
Summary: A dynamic git branching tool
Provides: python-git-phoenix
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-git-phoenix
# Git Phoenix
![Python](https://img.shields.io/badge/python-3670A0?style=for-the-badge&logo=python&logoColor=ffdd54)
[![python: 3.7+](https://img.shields.io/badge/python-3.7+-blue)](https://www.python.org/download/releases/3.7.0/)
[![Open Source Love](https://badges.frapsoft.com/os/v2/open-source.svg?v=103)](https://github.com/ellerbrock/open-source-badges/)
[![License: MIT](https://img.shields.io/badge/License-MIT-yellow.svg)](https://github.com/victoraugustofd/git-phoenix/blob/master/LICENSE)
[![Join the chat at https://gitter.im/git-phoenix/community](https://badges.gitter.im/git-phoenix/community.svg)](https://gitter.im/git-phoenix/community?utm_source=badge&utm_medium=badge&utm_campaign=pr-badge&utm_content=badge)
[![CircleCI](https://circleci.com/gh/victoraugustofd/git-phoenix.svg?style=svg)](https://circleci.com/gh/victoraugustofd/git-phoenix) [![codecov.io](https://codecov.io/gh/victoraugustofd/git-phoenix/coverage.svg?branch=master)](https://codecov.io/gh/victoraugustofd/git-phoenix)
## A dynamic Git Branching Tool
Git Phoenix is a Dynamic Branching Tool. We noticed that not all projects can be managed, using the branching models that are largely used by several companies. Many of them, have to adapt the way that they work with Git, just to fit with the branching model chosen.
Git Phoenix is exactly the opposite.
We made a system that adapts itself with the rules defined by the user or company, instead of the user or company adapt themselves to the system.
You can define the branching rules for your Git Repository on a JSON template.
%package help
Summary: Development documents and examples for git-phoenix
Provides: python3-git-phoenix-doc
%description help
# Git Phoenix
![Python](https://img.shields.io/badge/python-3670A0?style=for-the-badge&logo=python&logoColor=ffdd54)
[![python: 3.7+](https://img.shields.io/badge/python-3.7+-blue)](https://www.python.org/download/releases/3.7.0/)
[![Open Source Love](https://badges.frapsoft.com/os/v2/open-source.svg?v=103)](https://github.com/ellerbrock/open-source-badges/)
[![License: MIT](https://img.shields.io/badge/License-MIT-yellow.svg)](https://github.com/victoraugustofd/git-phoenix/blob/master/LICENSE)
[![Join the chat at https://gitter.im/git-phoenix/community](https://badges.gitter.im/git-phoenix/community.svg)](https://gitter.im/git-phoenix/community?utm_source=badge&utm_medium=badge&utm_campaign=pr-badge&utm_content=badge)
[![CircleCI](https://circleci.com/gh/victoraugustofd/git-phoenix.svg?style=svg)](https://circleci.com/gh/victoraugustofd/git-phoenix) [![codecov.io](https://codecov.io/gh/victoraugustofd/git-phoenix/coverage.svg?branch=master)](https://codecov.io/gh/victoraugustofd/git-phoenix)
## A dynamic Git Branching Tool
Git Phoenix is a Dynamic Branching Tool. We noticed that not all projects can be managed, using the branching models that are largely used by several companies. Many of them, have to adapt the way that they work with Git, just to fit with the branching model chosen.
Git Phoenix is exactly the opposite.
We made a system that adapts itself with the rules defined by the user or company, instead of the user or company adapt themselves to the system.
You can define the branching rules for your Git Repository on a JSON template.
%prep
%autosetup -n git-phoenix-1.2.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-git-phoenix -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 1.2.0-1
- Package Spec generated