%global _empty_manifest_terminate_build 0
Name:		python-ipywidgets-bokeh
Version:	1.4.0
Release:	1
Summary:	Allows embedding of Jupyter widgets in Bokeh layouts.
License:	BSD-3-Clause
URL:		https://github.com/bokeh/ipywidgets_bokeh
Source0:	https://mirrors.aliyun.com/pypi/web/packages/02/16/80df7c6276c1337ef5259916fa23671fd6aad3f8485d3bfa5db3f92e1586/ipywidgets_bokeh-1.4.0.tar.gz
BuildArch:	noarch

Requires:	python3-bokeh
Requires:	python3-ipywidgets
Requires:	python3-ipykernel

%description
Support for using ipywidgets within [Bokeh](https://bokeh.org). Ipywidgets are normally used in Jupyter notebooks, but this project allows them to be embedded into a Bokeh application so that they can be used alongside and with Bokeh-based plots and Bokeh widgets.  See the separate [jupyter_bokeh](https://github.com/bokeh/jupyter_bokeh) library for support for using Bokeh plots and widgets in Jupyter and ipywidgets (the opposite case from what ipywidgets_bokeh supports).

%package -n python3-ipywidgets-bokeh
Summary:	Allows embedding of Jupyter widgets in Bokeh layouts.
Provides:	python-ipywidgets-bokeh
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-ipywidgets-bokeh
Support for using ipywidgets within [Bokeh](https://bokeh.org). Ipywidgets are normally used in Jupyter notebooks, but this project allows them to be embedded into a Bokeh application so that they can be used alongside and with Bokeh-based plots and Bokeh widgets.  See the separate [jupyter_bokeh](https://github.com/bokeh/jupyter_bokeh) library for support for using Bokeh plots and widgets in Jupyter and ipywidgets (the opposite case from what ipywidgets_bokeh supports).

%package help
Summary:	Development documents and examples for ipywidgets-bokeh
Provides:	python3-ipywidgets-bokeh-doc
%description help
Support for using ipywidgets within [Bokeh](https://bokeh.org). Ipywidgets are normally used in Jupyter notebooks, but this project allows them to be embedded into a Bokeh application so that they can be used alongside and with Bokeh-based plots and Bokeh widgets.  See the separate [jupyter_bokeh](https://github.com/bokeh/jupyter_bokeh) library for support for using Bokeh plots and widgets in Jupyter and ipywidgets (the opposite case from what ipywidgets_bokeh supports).

%prep
%autosetup -n ipywidgets_bokeh-1.4.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-ipywidgets-bokeh -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 1.4.0-1
- Package Spec generated