%global _empty_manifest_terminate_build 0
Name:		python-hoster
Version:	0.0.2
Release:	1
Summary:	hoster is a python module that hosts code
License:	MIT
URL:		https://github.com/henos1029/hoster
Source0:	https://mirrors.aliyun.com/pypi/web/packages/56/a0/5f4393d387b86e3d6935b99d244b627a7808c99606acc90aeb2bec55255e/hoster-0.0.2.tar.gz
BuildArch:	noarch


%description
# hoster

hoster is a python module that hosts code  
Usage:  
Add this to the end of your code:

```Python
import hoster
hoster.start(ip=<your ip>, port=<4 digits>)
```

%package -n python3-hoster
Summary:	hoster is a python module that hosts code
Provides:	python-hoster
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-hoster
# hoster

hoster is a python module that hosts code  
Usage:  
Add this to the end of your code:

```Python
import hoster
hoster.start(ip=<your ip>, port=<4 digits>)
```

%package help
Summary:	Development documents and examples for hoster
Provides:	python3-hoster-doc
%description help
# hoster

hoster is a python module that hosts code  
Usage:  
Add this to the end of your code:

```Python
import hoster
hoster.start(ip=<your ip>, port=<4 digits>)
```

%prep
%autosetup -n hoster-0.0.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-hoster -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.2-1
- Package Spec generated