%global _empty_manifest_terminate_build 0
Name:		python-pubtools-pulplib
Version:	2.36.0
Release:	1
Summary:	A Pulp library for publishing tools
License:	GNU General Public License
URL:		https://github.com/release-engineering/pubtools-pulplib
Source0:	https://mirrors.aliyun.com/pypi/web/packages/12/42/7d4ea956af8e7523f4eb09bc13a397515f38e874b0c0de17a560bdba4628/pubtools-pulplib-2.36.0.tar.gz
BuildArch:	noarch

Requires:	python3-requests
Requires:	python3-more-executors
Requires:	python3-PyYAML
Requires:	python3-jsonschema
Requires:	python3-attrs
Requires:	python3-frozenlist2
Requires:	python3-pubtools
Requires:	python3-humanize
Requires:	python3-monotonic
Requires:	python3-frozendict

%description
Install the `pubtools-pulplib` package from PyPI.
```
pip install pubtools-pulplib
```

%package -n python3-pubtools-pulplib
Summary:	A Pulp library for publishing tools
Provides:	python-pubtools-pulplib
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pubtools-pulplib
Install the `pubtools-pulplib` package from PyPI.
```
pip install pubtools-pulplib
```

%package help
Summary:	Development documents and examples for pubtools-pulplib
Provides:	python3-pubtools-pulplib-doc
%description help
Install the `pubtools-pulplib` package from PyPI.
```
pip install pubtools-pulplib
```

%prep
%autosetup -n pubtools-pulplib-2.36.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pubtools-pulplib -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 2.36.0-1
- Package Spec generated