%global _empty_manifest_terminate_build 0
Name:		python-hi-ml
Version:	0.3.1
Release:	1
Summary:	Microsoft Health Futures package containing high level ML components
License:	MIT License
URL:		https://github.com/microsoft/hi-ml
Source0:	https://mirrors.aliyun.com/pypi/web/packages/05/e8/48f283a820dd621ac17cb095c75edce9d9bc99643ad3e614ec7c91ad6aa0/hi-ml-0.3.1.tar.gz
BuildArch:	noarch

Requires:	python3-dataclasses-json
Requires:	python3-hi-ml-azure
Requires:	python3-jinja2
Requires:	python3-matplotlib
Requires:	python3-opencv-python-headless
Requires:	python3-pandas
Requires:	python3-pillow
Requires:	python3-protobuf
Requires:	python3-pytorch-lightning
Requires:	python3-rpdb
Requires:	python3-torchvision
Requires:	python3-torch

%description
# Microsoft Health Intelligence Machine Learning Toolbox

## Overview

This toolbox aims at providing low-level and high-level building blocks for Machine Learning / AI researchers and
practitioners. It helps to simplify and streamline work on deep learning models for healthcare and life sciences,
by providing tested components (data loaders, pre-processing), and deep learning models.

## Installation

You can install the latest version from `pypi` via

```console
pip install hi-ml
```

## Documentation

The detailed package documentation, with examples and API reference, is on
[readthedocs](https://hi-ml.readthedocs.io/en/latest/).

## Getting started

Examples that illustrate the use of the `hi-ml` toolbox can be found on
[readthedocs](https://hi-ml.readthedocs.io/en/latest/).

## Changelog

We are relying on Github's auto-generated changelog to describe what went into a release. Please check [each individual release](https://github.com/microsoft/hi-ml/releases) to see a full changelog.

## Links

* Github [https://github.com/microsoft/hi-ml](https://github.com/microsoft/hi-ml)
* Project InnerEye [http://aka.ms/InnerEye](http://aka.ms/InnerEye)




%package -n python3-hi-ml
Summary:	Microsoft Health Futures package containing high level ML components
Provides:	python-hi-ml
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-hi-ml
# Microsoft Health Intelligence Machine Learning Toolbox

## Overview

This toolbox aims at providing low-level and high-level building blocks for Machine Learning / AI researchers and
practitioners. It helps to simplify and streamline work on deep learning models for healthcare and life sciences,
by providing tested components (data loaders, pre-processing), and deep learning models.

## Installation

You can install the latest version from `pypi` via

```console
pip install hi-ml
```

## Documentation

The detailed package documentation, with examples and API reference, is on
[readthedocs](https://hi-ml.readthedocs.io/en/latest/).

## Getting started

Examples that illustrate the use of the `hi-ml` toolbox can be found on
[readthedocs](https://hi-ml.readthedocs.io/en/latest/).

## Changelog

We are relying on Github's auto-generated changelog to describe what went into a release. Please check [each individual release](https://github.com/microsoft/hi-ml/releases) to see a full changelog.

## Links

* Github [https://github.com/microsoft/hi-ml](https://github.com/microsoft/hi-ml)
* Project InnerEye [http://aka.ms/InnerEye](http://aka.ms/InnerEye)




%package help
Summary:	Development documents and examples for hi-ml
Provides:	python3-hi-ml-doc
%description help
# Microsoft Health Intelligence Machine Learning Toolbox

## Overview

This toolbox aims at providing low-level and high-level building blocks for Machine Learning / AI researchers and
practitioners. It helps to simplify and streamline work on deep learning models for healthcare and life sciences,
by providing tested components (data loaders, pre-processing), and deep learning models.

## Installation

You can install the latest version from `pypi` via

```console
pip install hi-ml
```

## Documentation

The detailed package documentation, with examples and API reference, is on
[readthedocs](https://hi-ml.readthedocs.io/en/latest/).

## Getting started

Examples that illustrate the use of the `hi-ml` toolbox can be found on
[readthedocs](https://hi-ml.readthedocs.io/en/latest/).

## Changelog

We are relying on Github's auto-generated changelog to describe what went into a release. Please check [each individual release](https://github.com/microsoft/hi-ml/releases) to see a full changelog.

## Links

* Github [https://github.com/microsoft/hi-ml](https://github.com/microsoft/hi-ml)
* Project InnerEye [http://aka.ms/InnerEye](http://aka.ms/InnerEye)




%prep
%autosetup -n hi-ml-0.3.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-hi-ml -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.1-1
- Package Spec generated