%global _empty_manifest_terminate_build 0
Name:		python-murano-dashboard
Version:	2015.1.1
Release:	1
Summary:	The Murano Dashboard
License:	Apache License, Version 2.0
URL:		https://launchpad.net/murano
Source0:	https://mirrors.aliyun.com/pypi/web/packages/e2/89/fbcf94f8752de7c0e2a0abac8d6485014178d9a4b5809f243f72c8eaf5d0/murano-dashboard-2015.1.1.tar.gz
BuildArch:	noarch

Requires:	python3-PyYAML
Requires:	python3-beautifulsoup4
Requires:	python3-django-floppyforms
Requires:	python3-iso8601
Requires:	python3-pbr
Requires:	python3-muranoclient
Requires:	python3-six
Requires:	python3-yaql

%description
Murano Project introduces an application catalog, which allows application
developers and cloud administrators to publish various cloud-ready
applications in a browsable‎ categorised catalog. Cloud users
— including inexperienced ones — can then use the catalog to
compose reliable application environments with the push of a button.

%package -n python3-murano-dashboard
Summary:	The Murano Dashboard
Provides:	python-murano-dashboard
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-murano-dashboard
Murano Project introduces an application catalog, which allows application
developers and cloud administrators to publish various cloud-ready
applications in a browsable‎ categorised catalog. Cloud users
— including inexperienced ones — can then use the catalog to
compose reliable application environments with the push of a button.

%package help
Summary:	Development documents and examples for murano-dashboard
Provides:	python3-murano-dashboard-doc
%description help
Murano Project introduces an application catalog, which allows application
developers and cloud administrators to publish various cloud-ready
applications in a browsable‎ categorised catalog. Cloud users
— including inexperienced ones — can then use the catalog to
compose reliable application environments with the push of a button.

%prep
%autosetup -n murano-dashboard-2015.1.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-murano-dashboard -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 2015.1.1-1
- Package Spec generated