%global _empty_manifest_terminate_build 0
Name:		python-pynumeral
Version:	0.1.2
Release:	1
Summary:	Python implementation of numeraljs
License:	MIT license
URL:		https://github.com/gtnx/pynumeral
Source0:	https://mirrors.aliyun.com/pypi/web/packages/66/d4/82e216f27f0d0a5743d39ef97f2ad4a7878d9af04c64c72c940404d4782b/pynumeral-0.1.2.tar.gz
BuildArch:	noarch


%description
# Pynumeral

![](https://img.shields.io/badge/python-3.6-brightgreen.svg) ![](https://img.shields.io/badge/python-3.7-brightgreen.svg) ![](https://img.shields.io/badge/code%20style-black-000000.svg) [![Build Status](https://travis-ci.org/optimdata/pynumeral.svg?branch=master)](https://travis-ci.org/optimdata/pynumeral)

`pynumeral` is a python implementation of number formatting using [numeraljs format](http://numeraljs.com/#format). This project was motivated when we had to render numbers backend-side (which is written in python) while keep using formats defined by users. It has been coded regardless of the javascript implementation. It has been tested on a fairly large amount of formats but there are not any guarantees that it covers all the cases. Since unit testing is pretty simple, contributions are more than welcome.

It only provides a simple api `pynumeral.format(value, format)`. 


* License: [MIT license](https://github.com/optimdata/pynumeral/blob/master/LICENSE)
* Source: https://github.com/optimdata/pynumeral
* Issues: https://github.com/optimdata/pynumeral/issues


## History

### 0.1.0 (2019-11-15)

* First release on PyPI.




%package -n python3-pynumeral
Summary:	Python implementation of numeraljs
Provides:	python-pynumeral
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pynumeral
# Pynumeral

![](https://img.shields.io/badge/python-3.6-brightgreen.svg) ![](https://img.shields.io/badge/python-3.7-brightgreen.svg) ![](https://img.shields.io/badge/code%20style-black-000000.svg) [![Build Status](https://travis-ci.org/optimdata/pynumeral.svg?branch=master)](https://travis-ci.org/optimdata/pynumeral)

`pynumeral` is a python implementation of number formatting using [numeraljs format](http://numeraljs.com/#format). This project was motivated when we had to render numbers backend-side (which is written in python) while keep using formats defined by users. It has been coded regardless of the javascript implementation. It has been tested on a fairly large amount of formats but there are not any guarantees that it covers all the cases. Since unit testing is pretty simple, contributions are more than welcome.

It only provides a simple api `pynumeral.format(value, format)`. 


* License: [MIT license](https://github.com/optimdata/pynumeral/blob/master/LICENSE)
* Source: https://github.com/optimdata/pynumeral
* Issues: https://github.com/optimdata/pynumeral/issues


## History

### 0.1.0 (2019-11-15)

* First release on PyPI.




%package help
Summary:	Development documents and examples for pynumeral
Provides:	python3-pynumeral-doc
%description help
# Pynumeral

![](https://img.shields.io/badge/python-3.6-brightgreen.svg) ![](https://img.shields.io/badge/python-3.7-brightgreen.svg) ![](https://img.shields.io/badge/code%20style-black-000000.svg) [![Build Status](https://travis-ci.org/optimdata/pynumeral.svg?branch=master)](https://travis-ci.org/optimdata/pynumeral)

`pynumeral` is a python implementation of number formatting using [numeraljs format](http://numeraljs.com/#format). This project was motivated when we had to render numbers backend-side (which is written in python) while keep using formats defined by users. It has been coded regardless of the javascript implementation. It has been tested on a fairly large amount of formats but there are not any guarantees that it covers all the cases. Since unit testing is pretty simple, contributions are more than welcome.

It only provides a simple api `pynumeral.format(value, format)`. 


* License: [MIT license](https://github.com/optimdata/pynumeral/blob/master/LICENSE)
* Source: https://github.com/optimdata/pynumeral
* Issues: https://github.com/optimdata/pynumeral/issues


## History

### 0.1.0 (2019-11-15)

* First release on PyPI.




%prep
%autosetup -n pynumeral-0.1.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pynumeral -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.2-1
- Package Spec generated