%global _empty_manifest_terminate_build 0
Name:		python-li-common
Version:	1.16
Release:	1
Summary:	Lib para funcionalidades comuns aos aplicativos da Loja Integrada
License:	MIT
URL:		https://github.com/lojaintegrada/LI-Common
Source0:	https://mirrors.aliyun.com/pypi/web/packages/a7/2d/4fd504c27e15549c795735f5b55bbf60a6cfb3ce90f731b67a032542a02e/li-common-1.16.tar.gz
BuildArch:	noarch


%description
# LI-Common

## Versão:

[![PyPi version](https://pypip.in/version/li-common/badge.svg?text=versão)](https://pypi.python.org/pypi/li-common)
[![PyPi downloads](https://pypip.in/download/li-common/badge.svg)](https://pypi.python.org/pypi/li-common)


## Build Status

### Master

[![Build Status](https://travis-ci.org/lojaintegrada/LI-Common.svg?branch=master)](https://travis-ci.org/lojaintegrada/LI-Common)
[![Coverage Status](https://coveralls.io/repos/lojaintegrada/LI-Common/badge.svg?branch=master)](https://coveralls.io/r/lojaintegrada/LI-Common?branch=master)

### Desenvolvimento

[![Build Status](https://travis-ci.org/lojaintegrada/LI-Common.svg?branch=desenvolvimento)](https://travis-ci.org/lojaintegrada/LI-Common)
[![Coverage Status](https://coveralls.io/repos/lojaintegrada/LI-Common/badge.svg?branch=desenvolvimento)](https://coveralls.io/r/lojaintegrada/LI-Common?branch=desenvolvimento)


## Descrição

Estrutura básica para os aplicativos dos subsistemas da LI. As bases para entidades, repositórios, serviços e etc estarão disponíveis nessa lib, que fara o trabalho comum de serializar entidades, formatar saídas de API, validar dados de entrada e etc.

%package -n python3-li-common
Summary:	Lib para funcionalidades comuns aos aplicativos da Loja Integrada
Provides:	python-li-common
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-li-common
# LI-Common

## Versão:

[![PyPi version](https://pypip.in/version/li-common/badge.svg?text=versão)](https://pypi.python.org/pypi/li-common)
[![PyPi downloads](https://pypip.in/download/li-common/badge.svg)](https://pypi.python.org/pypi/li-common)


## Build Status

### Master

[![Build Status](https://travis-ci.org/lojaintegrada/LI-Common.svg?branch=master)](https://travis-ci.org/lojaintegrada/LI-Common)
[![Coverage Status](https://coveralls.io/repos/lojaintegrada/LI-Common/badge.svg?branch=master)](https://coveralls.io/r/lojaintegrada/LI-Common?branch=master)

### Desenvolvimento

[![Build Status](https://travis-ci.org/lojaintegrada/LI-Common.svg?branch=desenvolvimento)](https://travis-ci.org/lojaintegrada/LI-Common)
[![Coverage Status](https://coveralls.io/repos/lojaintegrada/LI-Common/badge.svg?branch=desenvolvimento)](https://coveralls.io/r/lojaintegrada/LI-Common?branch=desenvolvimento)


## Descrição

Estrutura básica para os aplicativos dos subsistemas da LI. As bases para entidades, repositórios, serviços e etc estarão disponíveis nessa lib, que fara o trabalho comum de serializar entidades, formatar saídas de API, validar dados de entrada e etc.

%package help
Summary:	Development documents and examples for li-common
Provides:	python3-li-common-doc
%description help
# LI-Common

## Versão:

[![PyPi version](https://pypip.in/version/li-common/badge.svg?text=versão)](https://pypi.python.org/pypi/li-common)
[![PyPi downloads](https://pypip.in/download/li-common/badge.svg)](https://pypi.python.org/pypi/li-common)


## Build Status

### Master

[![Build Status](https://travis-ci.org/lojaintegrada/LI-Common.svg?branch=master)](https://travis-ci.org/lojaintegrada/LI-Common)
[![Coverage Status](https://coveralls.io/repos/lojaintegrada/LI-Common/badge.svg?branch=master)](https://coveralls.io/r/lojaintegrada/LI-Common?branch=master)

### Desenvolvimento

[![Build Status](https://travis-ci.org/lojaintegrada/LI-Common.svg?branch=desenvolvimento)](https://travis-ci.org/lojaintegrada/LI-Common)
[![Coverage Status](https://coveralls.io/repos/lojaintegrada/LI-Common/badge.svg?branch=desenvolvimento)](https://coveralls.io/r/lojaintegrada/LI-Common?branch=desenvolvimento)


## Descrição

Estrutura básica para os aplicativos dos subsistemas da LI. As bases para entidades, repositórios, serviços e etc estarão disponíveis nessa lib, que fara o trabalho comum de serializar entidades, formatar saídas de API, validar dados de entrada e etc.

%prep
%autosetup -n li-common-1.16

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-li-common -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 1.16-1
- Package Spec generated