%global _empty_manifest_terminate_build 0
Name:		python-plone.app.jquery
Version:	1.11.2
Release:	1
Summary:	jQuery integration for Plone
License:	GPL version 2
URL:		http://pypi.python.org/pypi/plone.app.jquery
Source0:	https://mirrors.aliyun.com/pypi/web/packages/b6/15/94852709393dde2e86048a05bee4380e374422d89e576a0644170a4e3591/plone.app.jquery-1.11.2.tar.gz
BuildArch:	noarch


%description
plone.app.jquery adds the `jquery`_ library to Plone.
Included is the jQuery migration plugin. You can install it by importing the
``development`` profile.

%package -n python3-plone.app.jquery
Summary:	jQuery integration for Plone
Provides:	python-plone.app.jquery
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-plone.app.jquery
plone.app.jquery adds the `jquery`_ library to Plone.
Included is the jQuery migration plugin. You can install it by importing the
``development`` profile.

%package help
Summary:	Development documents and examples for plone.app.jquery
Provides:	python3-plone.app.jquery-doc
%description help
plone.app.jquery adds the `jquery`_ library to Plone.
Included is the jQuery migration plugin. You can install it by importing the
``development`` profile.

%prep
%autosetup -n plone.app.jquery-1.11.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-plone.app.jquery -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 1.11.2-1
- Package Spec generated