%global _empty_manifest_terminate_build 0
Name: python-imap
Version: 1.0.0
Release: 1
Summary: The integration of single-cell RNA-sequencing datasets from multiple sources is critical for deciphering cell-cell heterogeneities and interactions in complex biological systems. We present a novel unsupervised batch removal framework, called iMAP, based on two state-of-art deep generative models – autoencoders and generative adversarial networks.
License: MIT Licence
URL: https://github.com/Svvord/
Source0: https://mirrors.aliyun.com/pypi/web/packages/8f/39/7c78f15ed87edf30277c474a2823dcdf79e8416c044b8ba46e5204c9a6fc/imap-1.0.0.tar.gz
BuildArch: noarch
%description
# iMAP - Integration of multiple single-cell datasets by adversarial paired transfer networks
### Installation
#### 1. Prerequisites
- Install Python >= 3.6. Typically, you should use the Linux system and install a newest version of Anaconda or Miniconda .
- Install pytorch >= 1.1.0. To obtain the optimal performance of deep learning-based models, you should have a Nivdia GPU and install the appropriate version of CUDA. (We tested with CUDA = 9.0)
- Install scanpy >= 1.5.1 for pre-processing.
- (Optional) Install SHAP for interpretation.
#### 2. Installation
The iMAP python package is available for pip install(`pip install imap`). The functions required for the stage I and II of iMAP could be imported from “imap.stage1” and “imap.stage2”, respectively.
### Tutorials
Tutorials and API reference are available in the tutorials directory.
%package -n python3-imap
Summary: The integration of single-cell RNA-sequencing datasets from multiple sources is critical for deciphering cell-cell heterogeneities and interactions in complex biological systems. We present a novel unsupervised batch removal framework, called iMAP, based on two state-of-art deep generative models – autoencoders and generative adversarial networks.
Provides: python-imap
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-imap
# iMAP - Integration of multiple single-cell datasets by adversarial paired transfer networks
### Installation
#### 1. Prerequisites
- Install Python >= 3.6. Typically, you should use the Linux system and install a newest version of Anaconda or Miniconda .
- Install pytorch >= 1.1.0. To obtain the optimal performance of deep learning-based models, you should have a Nivdia GPU and install the appropriate version of CUDA. (We tested with CUDA = 9.0)
- Install scanpy >= 1.5.1 for pre-processing.
- (Optional) Install SHAP for interpretation.
#### 2. Installation
The iMAP python package is available for pip install(`pip install imap`). The functions required for the stage I and II of iMAP could be imported from “imap.stage1” and “imap.stage2”, respectively.
### Tutorials
Tutorials and API reference are available in the tutorials directory.
%package help
Summary: Development documents and examples for imap
Provides: python3-imap-doc
%description help
# iMAP - Integration of multiple single-cell datasets by adversarial paired transfer networks
### Installation
#### 1. Prerequisites
- Install Python >= 3.6. Typically, you should use the Linux system and install a newest version of Anaconda or Miniconda .
- Install pytorch >= 1.1.0. To obtain the optimal performance of deep learning-based models, you should have a Nivdia GPU and install the appropriate version of CUDA. (We tested with CUDA = 9.0)
- Install scanpy >= 1.5.1 for pre-processing.
- (Optional) Install SHAP for interpretation.
#### 2. Installation
The iMAP python package is available for pip install(`pip install imap`). The functions required for the stage I and II of iMAP could be imported from “imap.stage1” and “imap.stage2”, respectively.
### Tutorials
Tutorials and API reference are available in the tutorials directory.
%prep
%autosetup -n imap-1.0.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-imap -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 1.0.0-1
- Package Spec generated