%global _empty_manifest_terminate_build 0
Name: python-xotl.tools
Version: 2.2.5
Release: 1
Summary: Collection of usefull algorithms and other very disparate stuff
License: GPLv3+
URL: https://gitlab.merchise.org/merchise/xotl.tools
Source0: https://mirrors.aliyun.com/pypi/web/packages/ca/a3/1ffc92af7f1cdd984361dec412f8ce02340e8ebe91eb4487321d5deafdce/xotl.tools-2.2.5.tar.gz
BuildArch: noarch
Requires: python3-typing-extensions
Requires: python3-dateutil
Requires: python3-hypothesis
Requires: python3-pytz
Requires: python3-sphinx
Requires: python3-flake8
Requires: python3-flake8-bugbear
Requires: python3-black
Requires: python3-isort
Requires: python3-tox
Requires: python3-dateutil
Requires: python3-hypothesis
Requires: python3-pytz
Requires: python3-sphinx
Requires: python3-dateutil
%description
``xotl.tools`` is a collection of disparate utilities that does not conform a
framework for anything. ``xotl.tools`` is essentially -but not exclusively-
an extension to the Python's standard library.
In ``xotl.tools`` you will probably find:
- Tools that must be implemented in the Python Standard Library, but there are
things that escape from the Guido's scope. ;)
- Components that belong naturally to the "Common Systems Layer" \
[#continuum]_.
.. [#continuum] http://pubs.opengroup.org/architecture/togaf9-doc/arch/chap39.html#tag_39_04_01
You'll find the documentation in `Read the Docs
`__.
%package -n python3-xotl.tools
Summary: Collection of usefull algorithms and other very disparate stuff
Provides: python-xotl.tools
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-xotl.tools
``xotl.tools`` is a collection of disparate utilities that does not conform a
framework for anything. ``xotl.tools`` is essentially -but not exclusively-
an extension to the Python's standard library.
In ``xotl.tools`` you will probably find:
- Tools that must be implemented in the Python Standard Library, but there are
things that escape from the Guido's scope. ;)
- Components that belong naturally to the "Common Systems Layer" \
[#continuum]_.
.. [#continuum] http://pubs.opengroup.org/architecture/togaf9-doc/arch/chap39.html#tag_39_04_01
You'll find the documentation in `Read the Docs
`__.
%package help
Summary: Development documents and examples for xotl.tools
Provides: python3-xotl.tools-doc
%description help
``xotl.tools`` is a collection of disparate utilities that does not conform a
framework for anything. ``xotl.tools`` is essentially -but not exclusively-
an extension to the Python's standard library.
In ``xotl.tools`` you will probably find:
- Tools that must be implemented in the Python Standard Library, but there are
things that escape from the Guido's scope. ;)
- Components that belong naturally to the "Common Systems Layer" \
[#continuum]_.
.. [#continuum] http://pubs.opengroup.org/architecture/togaf9-doc/arch/chap39.html#tag_39_04_01
You'll find the documentation in `Read the Docs
`__.
%prep
%autosetup -n xotl.tools-2.2.5
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-xotl.tools -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 2.2.5-1
- Package Spec generated