%global _empty_manifest_terminate_build 0
Name: python-GoVetBear
Version: 0.10.0
Release: 1
Summary: 'GoVetBear' bear for coala (http://coala.rtfd.org/)
License: AGPL-3.0
URL: https://pypi.org/project/GoVetBear/
Source0: https://mirrors.aliyun.com/pypi/web/packages/43/92/b3df32d766709799c529e524fb6be834e074857d1d88d55ca6a375cb4d7a/GoVetBear-0.10.0.tar.gz
BuildArch: noarch
%description
Analyze Go code and raise suspicious constructs, such as printf calls
whose arguments do not correctly match the format string, useless
assignments, common mistakes about boolean operations, unreachable code,
etc.
This is done using the ``vet`` command. For more information visit
.
%package -n python3-GoVetBear
Summary: 'GoVetBear' bear for coala (http://coala.rtfd.org/)
Provides: python-GoVetBear
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-GoVetBear
Analyze Go code and raise suspicious constructs, such as printf calls
whose arguments do not correctly match the format string, useless
assignments, common mistakes about boolean operations, unreachable code,
etc.
This is done using the ``vet`` command. For more information visit
.
%package help
Summary: Development documents and examples for GoVetBear
Provides: python3-GoVetBear-doc
%description help
Analyze Go code and raise suspicious constructs, such as printf calls
whose arguments do not correctly match the format string, useless
assignments, common mistakes about boolean operations, unreachable code,
etc.
This is done using the ``vet`` command. For more information visit
.
%prep
%autosetup -n GoVetBear-0.10.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-GoVetBear -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 0.10.0-1
- Package Spec generated