%global _empty_manifest_terminate_build 0
Name:		python-PyElk
Version:	0.2.0.dev20
Release:	1
Summary:	Python module to talk to Elk M1 Gold and M1 EZ8 security / integration panels.
License:	Apache License 2.0
URL:		https://github.com/BioSehnsucht/pyelk
Source0:	https://mirrors.aliyun.com/pypi/web/packages/9a/d4/9554ddc7c7662401f73ce0bce033667b2a4832b191e772b8dd85db34d52a/PyElk-0.2.0.dev20.tar.gz
BuildArch:	noarch


%description
Python Library for the Elk M1 Gold and Elk M1 EZ8 alarm / integration panels
This library allows for interacting with Elk alarm / integration panels,
providing a means to monitor and react to status changes as well as trigger
changes (where relevant) for Zones, Outputs, Keypads, etc.

%package -n python3-PyElk
Summary:	Python module to talk to Elk M1 Gold and M1 EZ8 security / integration panels.
Provides:	python-PyElk
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-PyElk
Python Library for the Elk M1 Gold and Elk M1 EZ8 alarm / integration panels
This library allows for interacting with Elk alarm / integration panels,
providing a means to monitor and react to status changes as well as trigger
changes (where relevant) for Zones, Outputs, Keypads, etc.

%package help
Summary:	Development documents and examples for PyElk
Provides:	python3-PyElk-doc
%description help
Python Library for the Elk M1 Gold and Elk M1 EZ8 alarm / integration panels
This library allows for interacting with Elk alarm / integration panels,
providing a means to monitor and react to status changes as well as trigger
changes (where relevant) for Zones, Outputs, Keypads, etc.

%prep
%autosetup -n PyElk-0.2.0.dev20

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-PyElk -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.0.dev20-1
- Package Spec generated