%global _empty_manifest_terminate_build 0
Name:		python-vag
Version:	0.1.55
Release:	1
Summary:	vagrant utility cli tool
License:	MIT
URL:		https://pypi.org/project/vag/
Source0:	https://mirrors.aliyun.com/pypi/web/packages/81/f8/41e1de2975a6860ae9d856cf326840242dbe4efb850f85ed120d850bdaf1/vag-0.1.55.tar.gz
BuildArch:	noarch

Requires:	python3-Click
Requires:	python3-untangle
Requires:	python3-jinja2
Requires:	python3-requests
Requires:	python3-pyyaml
Requires:	python3-sqlalchemy
Requires:	python3-pylint
Requires:	python3-giteapy
Requires:	python3-Flask
Requires:	python3-oauthlib
Requires:	python3-Flask-Login
Requires:	python3-pyOpenSSL
Requires:	python3-random-username
Requires:	python3-random-password-generator
Requires:	python3-cryptography
Requires:	python3-jenkinsapi
Requires:	python3-psycopg2

%description
# vag
vag is a command line utility tool for vagrant, docker and [builder](https://github.com/7onetella/containers/tree/master/builder)

## Documentation
[read the docs](https://vag.readthedocs.io/en/latest/index.html)

## Installation
```bash
$ pip install vag
```

## List of top level commands
```bash
$ vag
Usage: vag [OPTIONS] COMMAND [ARGS]...

Options:
  --help  Show this message and exit.

Commands:
  build     Builds vagrant box
  clean     Cleans up vagrant build, terminates vagrant instance etc
  docker    Docker automation
  init      Creates a new Vagrantfile
  instance  Vagrant Instance Automation
  push      Publishes vagrant box to target environment
  ssh       SSH to vagrant test Vagrant instance
  test      Start a test Vagrant instance
  version   Prints version
```

## Development
local vag installation
```bash
$ rm -rf dist/*
$ poetry install
$ poetry build
$ pip uninstall -y vag
$ pip install dist/*.whl
```

edit and run 
```bash
$ poetry run vag vagrant list
```



%package -n python3-vag
Summary:	vagrant utility cli tool
Provides:	python-vag
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-vag
# vag
vag is a command line utility tool for vagrant, docker and [builder](https://github.com/7onetella/containers/tree/master/builder)

## Documentation
[read the docs](https://vag.readthedocs.io/en/latest/index.html)

## Installation
```bash
$ pip install vag
```

## List of top level commands
```bash
$ vag
Usage: vag [OPTIONS] COMMAND [ARGS]...

Options:
  --help  Show this message and exit.

Commands:
  build     Builds vagrant box
  clean     Cleans up vagrant build, terminates vagrant instance etc
  docker    Docker automation
  init      Creates a new Vagrantfile
  instance  Vagrant Instance Automation
  push      Publishes vagrant box to target environment
  ssh       SSH to vagrant test Vagrant instance
  test      Start a test Vagrant instance
  version   Prints version
```

## Development
local vag installation
```bash
$ rm -rf dist/*
$ poetry install
$ poetry build
$ pip uninstall -y vag
$ pip install dist/*.whl
```

edit and run 
```bash
$ poetry run vag vagrant list
```



%package help
Summary:	Development documents and examples for vag
Provides:	python3-vag-doc
%description help
# vag
vag is a command line utility tool for vagrant, docker and [builder](https://github.com/7onetella/containers/tree/master/builder)

## Documentation
[read the docs](https://vag.readthedocs.io/en/latest/index.html)

## Installation
```bash
$ pip install vag
```

## List of top level commands
```bash
$ vag
Usage: vag [OPTIONS] COMMAND [ARGS]...

Options:
  --help  Show this message and exit.

Commands:
  build     Builds vagrant box
  clean     Cleans up vagrant build, terminates vagrant instance etc
  docker    Docker automation
  init      Creates a new Vagrantfile
  instance  Vagrant Instance Automation
  push      Publishes vagrant box to target environment
  ssh       SSH to vagrant test Vagrant instance
  test      Start a test Vagrant instance
  version   Prints version
```

## Development
local vag installation
```bash
$ rm -rf dist/*
$ poetry install
$ poetry build
$ pip uninstall -y vag
$ pip install dist/*.whl
```

edit and run 
```bash
$ poetry run vag vagrant list
```



%prep
%autosetup -n vag-0.1.55

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-vag -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.55-1
- Package Spec generated