%global _empty_manifest_terminate_build 0
Name: python-fosslight-dependency
Version: 3.13.4
Release: 1
Summary: FOSSLight Dependency Scanner
License: Apache-2.0
URL: https://github.com/fosslight/fosslight_dependency_scanner
Source0: https://mirrors.aliyun.com/pypi/web/packages/56/c0/af328234014395d93a9f820d8731fd9a81f66807bc4be316b5a243b9b69c/fosslight_dependency-3.13.4.tar.gz
BuildArch: noarch
Requires: python3-openpyxl
Requires: python3-beautifulsoup4
Requires: python3-lxml
Requires: python3-virtualenv
Requires: python3-pyyaml
Requires: python3-lastversion
Requires: python3-fosslight-util
Requires: python3-PyGithub
Requires: python3-requirements-parser
%description
# FOSSLight Dependency Scanner
[](https://api.reuse.software/info/github.com/fosslight/fosslight_dependency_scanner)
## 💡 Introduction
This is the tool that supports the analysis of dependencies for multiple package managers. It detects the manifest file of package managers automatically and analyzes the dependencies with using open source tools. Then, it generates the report file that contains OSS information of dependencies.
## 📖 User Guide
We describe the user guide in the [**FOSSLight Guide page**](https://fosslight.org/fosslight-guide-en/scanner/3_dependency.html).
In this user guide, you can see how to install the FOSSLight Dependency Scanner and how to set up the prerequisite step and run it according to the package manager of your project. Also, you can check the results of the FOSSLight Dependency Scanner.
## 🧐 How to analyze the dependencies
FOSSLight Dependency Scanner utilizes the open source software for analyzing each package manager dependencies. We choose the open source software for each package manager that shows not only the direct dependencies but also the transitive dependencies including the information of dependencies such as oss name, oss version and license name.
Each package manager uses the results of the following software:
- NPM : [NPM License Checker](https://github.com/davglass/license-checker)
- Pypi : [pip-licenses](https://github.com/raimon49/pip-licenses)
- Gradle : [License Gradle Plugin](https://github.com/hierynomus/license-gradle-plugin)
- Maven : [license-maven-plugin](https://github.com/mojohaus/license-maven-plugin)
- Pub : [flutter_oss_licenses](https://github.com/espresso3389/flutter_oss_licenses)
- Android(gradle) : [android-dependency-scanning](https://github.com/fosslight/android-dependency-scanning)
Because we utilizes the different open source software to analyze the dependencies of each package manager, you need to set up the **Prerequisite** steps in [User guide](https://fosslight.org/fosslight-guide-en/scanner/3_dependency.html#-prerequisite) according to package manager to analyze.
### 🌐 How it works without Internet
| Package manager | Can it work without Internet? |
|-----------------|-------------------------------------------|
| [Gradle](https://gradle.org/) (Java) | Yes, if the following conditions are met.
- installed the plugin([com.github.hierynomus.license '0.16.1'](https://plugins.gradle.org/plugin/com.github.hierynomus.license/0.16.1))
- installed the packages of the project |
| [Maven](http://maven.apache.org/) (Java) | Yes, if the following conditions are met.
- installed the plugin([org.codehaus.mojo:license-maven-plugin](https://search.maven.org/artifact/org.codehaus.mojo/license-maven-plugin/2.0.0/))
- installed the packages of the project |
| [NPM](https://www.npmjs.com/) (Node.js) | Yes, if the following conditions are met.
- installed the plugin([license-checker](https://www.npmjs.com/package/license-checker))
- installed the packages of the project (in other words, generated the node_modules directory) |
| [PIP](https://pip.pypa.io/) (Python) | No, it can't. |
| [Android(gradle)](https://gradle.org/) (Android application) | Yes, if the following conditions are met.
- installed the plugin([android-dependency-scanning](https://search.maven.org/artifact/org.fosslight/android-dependency-scanning/1.0.0/jar))
- installed the packages of the project |
| [Pub](https://pub.dev/) (Dart with flutter) | Yes, if the following conditions are met.
- installed the plugin([flutter_oss_licenses](https://pub.dev/packages/flutter_oss_licenses))
- installed the packages of the project |
| [Cocoapods](https://cocoapods.org/) (Swift/Obj-C) | Yes, if the following conditions are met.
- installed the packages of the project
- enable to run the command (pod spec which --regex {package name} ) |
| [Swift](https://swift.org/package-manager/) (Swift) | No, it can't. |
| [Carthage](https://github.com/Carthage/Carthage) (Swift/Obj-C) | Yes, if the following conditions are met.
- installed the packages of the project (in other words, downloadeded the sources in 'Carthgae/Checkouts' directory). |
| [Go](https://pkg.go.dev/) (Go) | No, it can't. |
| [Nuget](https://www.nuget.org/) (.NET) | No, it can't. |
| [Helm](https://helm.sh/) (Kubernetes) | No, it can't. |
## 👏 Contributing Guide
We always welcome your contributions.
Please see the [CONTRIBUTING guide](https://github.com/fosslight/fosslight_dependency_scanner/blob/main/CONTRIBUTING.md) for how to contribute.
## 📄 License
Copyright (c) 2020 LG Electronics, Inc.
FOSSLight Dependency Scanner is licensed under Apache-2.0, as found in the [LICENSE](https://github.com/fosslight/fosslight_dependency_scanner/blob/main/LICENSE) file.
%package -n python3-fosslight-dependency
Summary: FOSSLight Dependency Scanner
Provides: python-fosslight-dependency
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-fosslight-dependency
# FOSSLight Dependency Scanner
[](https://api.reuse.software/info/github.com/fosslight/fosslight_dependency_scanner)
## 💡 Introduction
This is the tool that supports the analysis of dependencies for multiple package managers. It detects the manifest file of package managers automatically and analyzes the dependencies with using open source tools. Then, it generates the report file that contains OSS information of dependencies.
## 📖 User Guide
We describe the user guide in the [**FOSSLight Guide page**](https://fosslight.org/fosslight-guide-en/scanner/3_dependency.html).
In this user guide, you can see how to install the FOSSLight Dependency Scanner and how to set up the prerequisite step and run it according to the package manager of your project. Also, you can check the results of the FOSSLight Dependency Scanner.
## 🧐 How to analyze the dependencies
FOSSLight Dependency Scanner utilizes the open source software for analyzing each package manager dependencies. We choose the open source software for each package manager that shows not only the direct dependencies but also the transitive dependencies including the information of dependencies such as oss name, oss version and license name.
Each package manager uses the results of the following software:
- NPM : [NPM License Checker](https://github.com/davglass/license-checker)
- Pypi : [pip-licenses](https://github.com/raimon49/pip-licenses)
- Gradle : [License Gradle Plugin](https://github.com/hierynomus/license-gradle-plugin)
- Maven : [license-maven-plugin](https://github.com/mojohaus/license-maven-plugin)
- Pub : [flutter_oss_licenses](https://github.com/espresso3389/flutter_oss_licenses)
- Android(gradle) : [android-dependency-scanning](https://github.com/fosslight/android-dependency-scanning)
Because we utilizes the different open source software to analyze the dependencies of each package manager, you need to set up the **Prerequisite** steps in [User guide](https://fosslight.org/fosslight-guide-en/scanner/3_dependency.html#-prerequisite) according to package manager to analyze.
### 🌐 How it works without Internet
| Package manager | Can it work without Internet? |
|-----------------|-------------------------------------------|
| [Gradle](https://gradle.org/) (Java) | Yes, if the following conditions are met.
- installed the plugin([com.github.hierynomus.license '0.16.1'](https://plugins.gradle.org/plugin/com.github.hierynomus.license/0.16.1))
- installed the packages of the project |
| [Maven](http://maven.apache.org/) (Java) | Yes, if the following conditions are met.
- installed the plugin([org.codehaus.mojo:license-maven-plugin](https://search.maven.org/artifact/org.codehaus.mojo/license-maven-plugin/2.0.0/))
- installed the packages of the project |
| [NPM](https://www.npmjs.com/) (Node.js) | Yes, if the following conditions are met.
- installed the plugin([license-checker](https://www.npmjs.com/package/license-checker))
- installed the packages of the project (in other words, generated the node_modules directory) |
| [PIP](https://pip.pypa.io/) (Python) | No, it can't. |
| [Android(gradle)](https://gradle.org/) (Android application) | Yes, if the following conditions are met.
- installed the plugin([android-dependency-scanning](https://search.maven.org/artifact/org.fosslight/android-dependency-scanning/1.0.0/jar))
- installed the packages of the project |
| [Pub](https://pub.dev/) (Dart with flutter) | Yes, if the following conditions are met.
- installed the plugin([flutter_oss_licenses](https://pub.dev/packages/flutter_oss_licenses))
- installed the packages of the project |
| [Cocoapods](https://cocoapods.org/) (Swift/Obj-C) | Yes, if the following conditions are met.
- installed the packages of the project
- enable to run the command (pod spec which --regex {package name} ) |
| [Swift](https://swift.org/package-manager/) (Swift) | No, it can't. |
| [Carthage](https://github.com/Carthage/Carthage) (Swift/Obj-C) | Yes, if the following conditions are met.
- installed the packages of the project (in other words, downloadeded the sources in 'Carthgae/Checkouts' directory). |
| [Go](https://pkg.go.dev/) (Go) | No, it can't. |
| [Nuget](https://www.nuget.org/) (.NET) | No, it can't. |
| [Helm](https://helm.sh/) (Kubernetes) | No, it can't. |
## 👏 Contributing Guide
We always welcome your contributions.
Please see the [CONTRIBUTING guide](https://github.com/fosslight/fosslight_dependency_scanner/blob/main/CONTRIBUTING.md) for how to contribute.
## 📄 License
Copyright (c) 2020 LG Electronics, Inc.
FOSSLight Dependency Scanner is licensed under Apache-2.0, as found in the [LICENSE](https://github.com/fosslight/fosslight_dependency_scanner/blob/main/LICENSE) file.
%package help
Summary: Development documents and examples for fosslight-dependency
Provides: python3-fosslight-dependency-doc
%description help
# FOSSLight Dependency Scanner
[](https://api.reuse.software/info/github.com/fosslight/fosslight_dependency_scanner)
## 💡 Introduction
This is the tool that supports the analysis of dependencies for multiple package managers. It detects the manifest file of package managers automatically and analyzes the dependencies with using open source tools. Then, it generates the report file that contains OSS information of dependencies.
## 📖 User Guide
We describe the user guide in the [**FOSSLight Guide page**](https://fosslight.org/fosslight-guide-en/scanner/3_dependency.html).
In this user guide, you can see how to install the FOSSLight Dependency Scanner and how to set up the prerequisite step and run it according to the package manager of your project. Also, you can check the results of the FOSSLight Dependency Scanner.
## 🧐 How to analyze the dependencies
FOSSLight Dependency Scanner utilizes the open source software for analyzing each package manager dependencies. We choose the open source software for each package manager that shows not only the direct dependencies but also the transitive dependencies including the information of dependencies such as oss name, oss version and license name.
Each package manager uses the results of the following software:
- NPM : [NPM License Checker](https://github.com/davglass/license-checker)
- Pypi : [pip-licenses](https://github.com/raimon49/pip-licenses)
- Gradle : [License Gradle Plugin](https://github.com/hierynomus/license-gradle-plugin)
- Maven : [license-maven-plugin](https://github.com/mojohaus/license-maven-plugin)
- Pub : [flutter_oss_licenses](https://github.com/espresso3389/flutter_oss_licenses)
- Android(gradle) : [android-dependency-scanning](https://github.com/fosslight/android-dependency-scanning)
Because we utilizes the different open source software to analyze the dependencies of each package manager, you need to set up the **Prerequisite** steps in [User guide](https://fosslight.org/fosslight-guide-en/scanner/3_dependency.html#-prerequisite) according to package manager to analyze.
### 🌐 How it works without Internet
| Package manager | Can it work without Internet? |
|-----------------|-------------------------------------------|
| [Gradle](https://gradle.org/) (Java) | Yes, if the following conditions are met.
- installed the plugin([com.github.hierynomus.license '0.16.1'](https://plugins.gradle.org/plugin/com.github.hierynomus.license/0.16.1))
- installed the packages of the project |
| [Maven](http://maven.apache.org/) (Java) | Yes, if the following conditions are met.
- installed the plugin([org.codehaus.mojo:license-maven-plugin](https://search.maven.org/artifact/org.codehaus.mojo/license-maven-plugin/2.0.0/))
- installed the packages of the project |
| [NPM](https://www.npmjs.com/) (Node.js) | Yes, if the following conditions are met.
- installed the plugin([license-checker](https://www.npmjs.com/package/license-checker))
- installed the packages of the project (in other words, generated the node_modules directory) |
| [PIP](https://pip.pypa.io/) (Python) | No, it can't. |
| [Android(gradle)](https://gradle.org/) (Android application) | Yes, if the following conditions are met.
- installed the plugin([android-dependency-scanning](https://search.maven.org/artifact/org.fosslight/android-dependency-scanning/1.0.0/jar))
- installed the packages of the project |
| [Pub](https://pub.dev/) (Dart with flutter) | Yes, if the following conditions are met.
- installed the plugin([flutter_oss_licenses](https://pub.dev/packages/flutter_oss_licenses))
- installed the packages of the project |
| [Cocoapods](https://cocoapods.org/) (Swift/Obj-C) | Yes, if the following conditions are met.
- installed the packages of the project
- enable to run the command (pod spec which --regex {package name} ) |
| [Swift](https://swift.org/package-manager/) (Swift) | No, it can't. |
| [Carthage](https://github.com/Carthage/Carthage) (Swift/Obj-C) | Yes, if the following conditions are met.
- installed the packages of the project (in other words, downloadeded the sources in 'Carthgae/Checkouts' directory). |
| [Go](https://pkg.go.dev/) (Go) | No, it can't. |
| [Nuget](https://www.nuget.org/) (.NET) | No, it can't. |
| [Helm](https://helm.sh/) (Kubernetes) | No, it can't. |
## 👏 Contributing Guide
We always welcome your contributions.
Please see the [CONTRIBUTING guide](https://github.com/fosslight/fosslight_dependency_scanner/blob/main/CONTRIBUTING.md) for how to contribute.
## 📄 License
Copyright (c) 2020 LG Electronics, Inc.
FOSSLight Dependency Scanner is licensed under Apache-2.0, as found in the [LICENSE](https://github.com/fosslight/fosslight_dependency_scanner/blob/main/LICENSE) file.
%prep
%autosetup -n fosslight_dependency-3.13.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-fosslight-dependency -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 3.13.4-1
- Package Spec generated