%global _empty_manifest_terminate_build 0
Name: python-mkdocs-bionformatic-izsam-theme
Version: 0.1.9.3
Release: 1
Summary: MkDocs theme designed for Bioiformatic Unit of the Istituto Zooprofilattico dell' Abruzzo e del Molise G. Caporale
License: MIT
URL: https://pypi.org/project/mkdocs-bionformatic-izsam-theme/
Source0: https://mirrors.aliyun.com/pypi/web/packages/84/7c/7d6342bef5f8d7d3ca62c6c3664f5315167e1e018715f2708d30b738334d/mkdocs-bionformatic-izsam-theme-0.1.9.3.tar.gz
BuildArch: noarch
Requires: python3-mkdocs
%description
# mkdocs-bioinformatic-izsam-theme
This is an MkDocs theme designed to layout the documentation provided by Bioinformatic Unit of the Istituto Zooprofilattico Sperimentale dell'Abruzzo e del Molise "G. Caporale".
#### Important!
The theme is intended to work with the plugin **mkdocs-izsam-search** [https://pypi.org/project/mkdocs-izsam-search/](https://pypi.org/project/mkdocs-izsam-search/)
```bash
pip install mkdocs-izsam-search
```
## Theme customization
The theme allows you to customize Title and top right label using your mdkdocs configuration file `mkdocs.yml`.
```yaml
extra:
platform_title: Piattaforma GenPat
header_tool_label: Wiki
header_tool_label_mobile: Wiki
```
## Theme localization
The theme supports a lightweight localization system written in javascript. At the moment it supports Italian and English but you are free to add every language by duplicate the existing `js/theme-langauges/theme-loc-en.js` file and renaming it with your language a for example `js/theme-langauges/theme-loc-it.js`. Edit/override `js/theme-localization.js` to add more fields and translations.
> Please refer to MkDocs documentation on how to customize a theme [https://www.mkdocs.org/user-guide/customizing-your-theme/#customizing-your-theme](https://www.mkdocs.org/user-guide/customizing-your-theme/#customizing-your-theme).
To activate the localization, add a value to `locale` in `config.theme`:
```yml
theme:
name: bioinformatic-izsam-theme
locale: it
```
Here the code used in the theme (`base.html`) to hold the localization:
```html
{% if config.theme.locale %}
{% set js_path = 'js/theme-languages/theme-loc-' ~ config.theme.locale ~ '.js' %}
{% endif %}
```
#### Important!
The `locale` variable is used also to set search functionalities, there are some limitations on the values it can assume. Allowed languages are: `ar`, `da`, `de`, `du`, `es`, `fi`, `fr`, `hi`, `hu`, `it`, `ja`, `jp`, `nl`, `no`, `pt`, `ro`, `ru`, `sv`, `ta`, `th`, `tr`, `vi`, `zh`. If you want to use a different language, you should not to use **mkdocs-izsam-search** plugin and customize the `base.html` file removing all the code related to it.
## Theme features
#### Use image caption
If you need to use a caption for images, you can use the markdown image title sintax.
`![](image.png "image title")`
> A function in `theme.js` loops all images and if a title exists will append a `figcaption` tag after the image.
#### Use icons inline
To use icons inline inside the contents, please add the alt attribute `inline-icon`:
```
![inline-icon](icona.png)
```
> Images will have inherent size and displayed inline.
#### Use diagram as images (no plantuml)
To use diagram inside the contents as images, please add the alt attribute `diagram` to avoid box shadow.
```
![diagram](file.png)
```
#### Expand image
`zoom-img.js` allows images to be expanded on click.
# Change log
## [0.1.9.3] - 2023-05-15
### Ux improvement for main menu in mobile view
- Edited theme.css
- Edited base.html
## [0.1.9.2] - 2023-03-28
### Bug fix for ordered list
- Edited theme.css
## [0.1.9.1] - 2022-12-09
### Ux improvement for main menu in mobile view
- Edited theme.css
## [0.1.9] - 2022-10-24
### Small fix on Ux improvement for main menu in mobile view
- Edited theme.css and base.html
## [0.1.8] - 2022-10-24
### Ux improvement for main menu in mobile view
- Edited theme.css and base.html
## [0.1.7] - 2022-05-12
### Debug and refactoring for theme.js
- Edited theme.js
## [0.1.6] - 2022-05-12
### Fix for image caption function
- Edited theme.css and theme.js
## [0.1.5] - 2022-05-12
### Added support for image caption
- Edited theme.css and theme.js
### Readme improvements
- Edited README.md
## [0.1.4] - 2022-05-2
### CSS: added rule for html video tag
- Edited theme.css
## [0.1.3] - 2022-04-27
### Html base template: changed next and previous buttons in order to integrate parent title
- Edited base.html
## [0.1.2] - 2022-03-18
### Layout improvement.
- Edited theme.css
## [0.1.1] - 2022-01-25
### Layout improvement.
- Edited theme.css
## [0.1.0] - 2022-01-25
### Layout improvement.
- Edited theme.css
## [0.0.9] - 2022-01-25
### Layout changes: form fields and buttons aspect.
- Edited theme.css
## [0.0.8] - 2021-11-24
### Layout improvement.
- Edited theme.css
## [0.0.7] - 2021-11-15
### Project description.
- Edited README.md
## [0.0.6] - 2021-11-15
### Theme localization, integration of a footer.css, ui emprovement.
- Added theme localization for search.html file.
- Added theme localization for 404.html file.
- Added a footer.css file.
- Small changes in the main theme.css style for left menu.
## [0.0.5] - 2021-11-12
### Theme localization
- The theme now support it and en localization and it can be extended with other langauges.
## [0.0.4] - 2021-11-12
### Added support for other languages besides `en` to make theme working with mkdocs-izsam-search plugin
- The theme now support languages present in `js/lunr-languages` and can be defined in `theme.locale` of the `.yml` configuration file. Multilanguage is not supported yet.
## [0.0.2] and [0.0.3] - 2021-11-11
### Debug on setup
- Fixed bugs for the mkdocs entry point in `setup.py`
## [0.0.1] - 2021-11-11
### First release
- Made stuff necessary to package a theme
%package -n python3-mkdocs-bionformatic-izsam-theme
Summary: MkDocs theme designed for Bioiformatic Unit of the Istituto Zooprofilattico dell' Abruzzo e del Molise G. Caporale
Provides: python-mkdocs-bionformatic-izsam-theme
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-mkdocs-bionformatic-izsam-theme
# mkdocs-bioinformatic-izsam-theme
This is an MkDocs theme designed to layout the documentation provided by Bioinformatic Unit of the Istituto Zooprofilattico Sperimentale dell'Abruzzo e del Molise "G. Caporale".
#### Important!
The theme is intended to work with the plugin **mkdocs-izsam-search** [https://pypi.org/project/mkdocs-izsam-search/](https://pypi.org/project/mkdocs-izsam-search/)
```bash
pip install mkdocs-izsam-search
```
## Theme customization
The theme allows you to customize Title and top right label using your mdkdocs configuration file `mkdocs.yml`.
```yaml
extra:
platform_title: Piattaforma GenPat
header_tool_label: Wiki
header_tool_label_mobile: Wiki
```
## Theme localization
The theme supports a lightweight localization system written in javascript. At the moment it supports Italian and English but you are free to add every language by duplicate the existing `js/theme-langauges/theme-loc-en.js` file and renaming it with your language a for example `js/theme-langauges/theme-loc-it.js`. Edit/override `js/theme-localization.js` to add more fields and translations.
> Please refer to MkDocs documentation on how to customize a theme [https://www.mkdocs.org/user-guide/customizing-your-theme/#customizing-your-theme](https://www.mkdocs.org/user-guide/customizing-your-theme/#customizing-your-theme).
To activate the localization, add a value to `locale` in `config.theme`:
```yml
theme:
name: bioinformatic-izsam-theme
locale: it
```
Here the code used in the theme (`base.html`) to hold the localization:
```html
{% if config.theme.locale %}
{% set js_path = 'js/theme-languages/theme-loc-' ~ config.theme.locale ~ '.js' %}
{% endif %}
```
#### Important!
The `locale` variable is used also to set search functionalities, there are some limitations on the values it can assume. Allowed languages are: `ar`, `da`, `de`, `du`, `es`, `fi`, `fr`, `hi`, `hu`, `it`, `ja`, `jp`, `nl`, `no`, `pt`, `ro`, `ru`, `sv`, `ta`, `th`, `tr`, `vi`, `zh`. If you want to use a different language, you should not to use **mkdocs-izsam-search** plugin and customize the `base.html` file removing all the code related to it.
## Theme features
#### Use image caption
If you need to use a caption for images, you can use the markdown image title sintax.
`![](image.png "image title")`
> A function in `theme.js` loops all images and if a title exists will append a `figcaption` tag after the image.
#### Use icons inline
To use icons inline inside the contents, please add the alt attribute `inline-icon`:
```
![inline-icon](icona.png)
```
> Images will have inherent size and displayed inline.
#### Use diagram as images (no plantuml)
To use diagram inside the contents as images, please add the alt attribute `diagram` to avoid box shadow.
```
![diagram](file.png)
```
#### Expand image
`zoom-img.js` allows images to be expanded on click.
# Change log
## [0.1.9.3] - 2023-05-15
### Ux improvement for main menu in mobile view
- Edited theme.css
- Edited base.html
## [0.1.9.2] - 2023-03-28
### Bug fix for ordered list
- Edited theme.css
## [0.1.9.1] - 2022-12-09
### Ux improvement for main menu in mobile view
- Edited theme.css
## [0.1.9] - 2022-10-24
### Small fix on Ux improvement for main menu in mobile view
- Edited theme.css and base.html
## [0.1.8] - 2022-10-24
### Ux improvement for main menu in mobile view
- Edited theme.css and base.html
## [0.1.7] - 2022-05-12
### Debug and refactoring for theme.js
- Edited theme.js
## [0.1.6] - 2022-05-12
### Fix for image caption function
- Edited theme.css and theme.js
## [0.1.5] - 2022-05-12
### Added support for image caption
- Edited theme.css and theme.js
### Readme improvements
- Edited README.md
## [0.1.4] - 2022-05-2
### CSS: added rule for html video tag
- Edited theme.css
## [0.1.3] - 2022-04-27
### Html base template: changed next and previous buttons in order to integrate parent title
- Edited base.html
## [0.1.2] - 2022-03-18
### Layout improvement.
- Edited theme.css
## [0.1.1] - 2022-01-25
### Layout improvement.
- Edited theme.css
## [0.1.0] - 2022-01-25
### Layout improvement.
- Edited theme.css
## [0.0.9] - 2022-01-25
### Layout changes: form fields and buttons aspect.
- Edited theme.css
## [0.0.8] - 2021-11-24
### Layout improvement.
- Edited theme.css
## [0.0.7] - 2021-11-15
### Project description.
- Edited README.md
## [0.0.6] - 2021-11-15
### Theme localization, integration of a footer.css, ui emprovement.
- Added theme localization for search.html file.
- Added theme localization for 404.html file.
- Added a footer.css file.
- Small changes in the main theme.css style for left menu.
## [0.0.5] - 2021-11-12
### Theme localization
- The theme now support it and en localization and it can be extended with other langauges.
## [0.0.4] - 2021-11-12
### Added support for other languages besides `en` to make theme working with mkdocs-izsam-search plugin
- The theme now support languages present in `js/lunr-languages` and can be defined in `theme.locale` of the `.yml` configuration file. Multilanguage is not supported yet.
## [0.0.2] and [0.0.3] - 2021-11-11
### Debug on setup
- Fixed bugs for the mkdocs entry point in `setup.py`
## [0.0.1] - 2021-11-11
### First release
- Made stuff necessary to package a theme
%package help
Summary: Development documents and examples for mkdocs-bionformatic-izsam-theme
Provides: python3-mkdocs-bionformatic-izsam-theme-doc
%description help
# mkdocs-bioinformatic-izsam-theme
This is an MkDocs theme designed to layout the documentation provided by Bioinformatic Unit of the Istituto Zooprofilattico Sperimentale dell'Abruzzo e del Molise "G. Caporale".
#### Important!
The theme is intended to work with the plugin **mkdocs-izsam-search** [https://pypi.org/project/mkdocs-izsam-search/](https://pypi.org/project/mkdocs-izsam-search/)
```bash
pip install mkdocs-izsam-search
```
## Theme customization
The theme allows you to customize Title and top right label using your mdkdocs configuration file `mkdocs.yml`.
```yaml
extra:
platform_title: Piattaforma GenPat
header_tool_label: Wiki
header_tool_label_mobile: Wiki
```
## Theme localization
The theme supports a lightweight localization system written in javascript. At the moment it supports Italian and English but you are free to add every language by duplicate the existing `js/theme-langauges/theme-loc-en.js` file and renaming it with your language a for example `js/theme-langauges/theme-loc-it.js`. Edit/override `js/theme-localization.js` to add more fields and translations.
> Please refer to MkDocs documentation on how to customize a theme [https://www.mkdocs.org/user-guide/customizing-your-theme/#customizing-your-theme](https://www.mkdocs.org/user-guide/customizing-your-theme/#customizing-your-theme).
To activate the localization, add a value to `locale` in `config.theme`:
```yml
theme:
name: bioinformatic-izsam-theme
locale: it
```
Here the code used in the theme (`base.html`) to hold the localization:
```html
{% if config.theme.locale %}
{% set js_path = 'js/theme-languages/theme-loc-' ~ config.theme.locale ~ '.js' %}
{% endif %}
```
#### Important!
The `locale` variable is used also to set search functionalities, there are some limitations on the values it can assume. Allowed languages are: `ar`, `da`, `de`, `du`, `es`, `fi`, `fr`, `hi`, `hu`, `it`, `ja`, `jp`, `nl`, `no`, `pt`, `ro`, `ru`, `sv`, `ta`, `th`, `tr`, `vi`, `zh`. If you want to use a different language, you should not to use **mkdocs-izsam-search** plugin and customize the `base.html` file removing all the code related to it.
## Theme features
#### Use image caption
If you need to use a caption for images, you can use the markdown image title sintax.
`![](image.png "image title")`
> A function in `theme.js` loops all images and if a title exists will append a `figcaption` tag after the image.
#### Use icons inline
To use icons inline inside the contents, please add the alt attribute `inline-icon`:
```
![inline-icon](icona.png)
```
> Images will have inherent size and displayed inline.
#### Use diagram as images (no plantuml)
To use diagram inside the contents as images, please add the alt attribute `diagram` to avoid box shadow.
```
![diagram](file.png)
```
#### Expand image
`zoom-img.js` allows images to be expanded on click.
# Change log
## [0.1.9.3] - 2023-05-15
### Ux improvement for main menu in mobile view
- Edited theme.css
- Edited base.html
## [0.1.9.2] - 2023-03-28
### Bug fix for ordered list
- Edited theme.css
## [0.1.9.1] - 2022-12-09
### Ux improvement for main menu in mobile view
- Edited theme.css
## [0.1.9] - 2022-10-24
### Small fix on Ux improvement for main menu in mobile view
- Edited theme.css and base.html
## [0.1.8] - 2022-10-24
### Ux improvement for main menu in mobile view
- Edited theme.css and base.html
## [0.1.7] - 2022-05-12
### Debug and refactoring for theme.js
- Edited theme.js
## [0.1.6] - 2022-05-12
### Fix for image caption function
- Edited theme.css and theme.js
## [0.1.5] - 2022-05-12
### Added support for image caption
- Edited theme.css and theme.js
### Readme improvements
- Edited README.md
## [0.1.4] - 2022-05-2
### CSS: added rule for html video tag
- Edited theme.css
## [0.1.3] - 2022-04-27
### Html base template: changed next and previous buttons in order to integrate parent title
- Edited base.html
## [0.1.2] - 2022-03-18
### Layout improvement.
- Edited theme.css
## [0.1.1] - 2022-01-25
### Layout improvement.
- Edited theme.css
## [0.1.0] - 2022-01-25
### Layout improvement.
- Edited theme.css
## [0.0.9] - 2022-01-25
### Layout changes: form fields and buttons aspect.
- Edited theme.css
## [0.0.8] - 2021-11-24
### Layout improvement.
- Edited theme.css
## [0.0.7] - 2021-11-15
### Project description.
- Edited README.md
## [0.0.6] - 2021-11-15
### Theme localization, integration of a footer.css, ui emprovement.
- Added theme localization for search.html file.
- Added theme localization for 404.html file.
- Added a footer.css file.
- Small changes in the main theme.css style for left menu.
## [0.0.5] - 2021-11-12
### Theme localization
- The theme now support it and en localization and it can be extended with other langauges.
## [0.0.4] - 2021-11-12
### Added support for other languages besides `en` to make theme working with mkdocs-izsam-search plugin
- The theme now support languages present in `js/lunr-languages` and can be defined in `theme.locale` of the `.yml` configuration file. Multilanguage is not supported yet.
## [0.0.2] and [0.0.3] - 2021-11-11
### Debug on setup
- Fixed bugs for the mkdocs entry point in `setup.py`
## [0.0.1] - 2021-11-11
### First release
- Made stuff necessary to package a theme
%prep
%autosetup -n mkdocs-bionformatic-izsam-theme-0.1.9.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-mkdocs-bionformatic-izsam-theme -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 0.1.9.3-1
- Package Spec generated