%global _empty_manifest_terminate_build 0
Name: python-gidgetlab
Version: 1.0.0
Release: 1
Summary: An async GitLab API library
License: Apache
URL: https://gitlab.com/beenje/gidgetlab
Source0: https://mirrors.aliyun.com/pypi/web/packages/4b/8a/b3c7d92d1377cf416fd4bcd80469c40e1f3c5920c33ecc3853e0d16e2701/gidgetlab-1.0.0.tar.gz
BuildArch: noarch
Requires: python3-aiohttp
Requires: python3-cachetools
Requires: python3-sphinx
Requires: python3-sphinx-autodoc-typehints
Requires: python3-sphinx-rtd-theme
Requires: python3-pytest
Requires: python3-pytest-asyncio
Requires: python3-pytest-cov
Requires: python3-pytest-aiohttp
Requires: python3-aiohttp
Requires: python3-cachetools
Requires: python3-httpx
Requires: python3-treq
Requires: python3-twisted[tls]
Requires: python3-tornado
Requires: python3-sphinx
Requires: python3-sphinx-autodoc-typehints
Requires: python3-sphinx-rtd-theme
Requires: python3-httpx
Requires: python3-pytest
Requires: python3-pytest-asyncio
Requires: python3-pytest-cov
Requires: python3-pytest-aiohttp
Requires: python3-tornado
Requires: python3-treq
Requires: python3-twisted[tls]
%description
An asynchronous `GitLab API`_ library.
This library is based on gidgethub_ from Brett Cannon,
an async GitHub API library.
I liked the concept with the asynchronous and `sans-I/O`_
approach and decided to adapt it to the GitLab's API.
All credit to `Brett Cannon `_ for the initial library!
%package -n python3-gidgetlab
Summary: An async GitLab API library
Provides: python-gidgetlab
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-gidgetlab
An asynchronous `GitLab API`_ library.
This library is based on gidgethub_ from Brett Cannon,
an async GitHub API library.
I liked the concept with the asynchronous and `sans-I/O`_
approach and decided to adapt it to the GitLab's API.
All credit to `Brett Cannon `_ for the initial library!
%package help
Summary: Development documents and examples for gidgetlab
Provides: python3-gidgetlab-doc
%description help
An asynchronous `GitLab API`_ library.
This library is based on gidgethub_ from Brett Cannon,
an async GitHub API library.
I liked the concept with the asynchronous and `sans-I/O`_
approach and decided to adapt it to the GitLab's API.
All credit to `Brett Cannon `_ for the initial library!
%prep
%autosetup -n gidgetlab-1.0.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-gidgetlab -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 1.0.0-1
- Package Spec generated