%global _empty_manifest_terminate_build 0
Name:		python-vdk-plugin-control-cli
Version:	0.1.886059298
Release:	1
Summary:	Versatile Data Kit SDK plugin exposing CLI commands for managing the lifecycle of a Data Jobs.
License:	Apache Software License
URL:		https://github.com/vmware/versatile-data-kit
Source0:	https://mirrors.aliyun.com/pypi/web/packages/1d/6e/7f79fb6fa1805c92945accbdd036d74d3538587d4ac471cf0098e343c696/vdk-plugin-control-cli-0.1.886059298.tar.gz
BuildArch:	noarch


%description
This plugin allows vdk-core to access vdk-control-cli functionality.

Upon installing it enhances vdk with CLI commands for data job lifecycle management available from vdk-control-cli package

It will also install properties plugin and switch Properties in vdk to use Control Service Properties API.
By default no Properties backend is used otherwise.

# Usage


```bash
pip install vdk-plugin-control-cli
```

### New CLI commands

Then on the vdk CLI you should be able to see the new commands. Run
```bash
vdk --help
```
and you will see extra commands being added:
```
Commands:
  ...
  login                  Authentication against the Control Service.
  logout                 Logout the user from the Data Jobs Service by...
  create                 Creates a new data job in cloud and locally.
  delete                 Deletes a data job from the cloud.
  deploy                 Deploys a data job.
  ...
```

And you can use them from the same CLI `vdk`

### New properties backend client registered

You can now access remote properties from Control Service Properties API
Store state, configuration or secrets there using CLI or Python JobInput API

For example, let's store some api-uri

```bash
vdk properties --set 'api-uri' 'http://cool.cool.api.com'
```

and then we can use it in our data job

```python
def run(job_input: IJobInput):
    uri = job_input.get_property('api-uri')
    print(requests.get(uri))
```

# Build

The easiest way is to use the ../build-plugin.sh helper script

```bash
../build-plugin.sh
```


%package -n python3-vdk-plugin-control-cli
Summary:	Versatile Data Kit SDK plugin exposing CLI commands for managing the lifecycle of a Data Jobs.
Provides:	python-vdk-plugin-control-cli
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-vdk-plugin-control-cli
This plugin allows vdk-core to access vdk-control-cli functionality.

Upon installing it enhances vdk with CLI commands for data job lifecycle management available from vdk-control-cli package

It will also install properties plugin and switch Properties in vdk to use Control Service Properties API.
By default no Properties backend is used otherwise.

# Usage


```bash
pip install vdk-plugin-control-cli
```

### New CLI commands

Then on the vdk CLI you should be able to see the new commands. Run
```bash
vdk --help
```
and you will see extra commands being added:
```
Commands:
  ...
  login                  Authentication against the Control Service.
  logout                 Logout the user from the Data Jobs Service by...
  create                 Creates a new data job in cloud and locally.
  delete                 Deletes a data job from the cloud.
  deploy                 Deploys a data job.
  ...
```

And you can use them from the same CLI `vdk`

### New properties backend client registered

You can now access remote properties from Control Service Properties API
Store state, configuration or secrets there using CLI or Python JobInput API

For example, let's store some api-uri

```bash
vdk properties --set 'api-uri' 'http://cool.cool.api.com'
```

and then we can use it in our data job

```python
def run(job_input: IJobInput):
    uri = job_input.get_property('api-uri')
    print(requests.get(uri))
```

# Build

The easiest way is to use the ../build-plugin.sh helper script

```bash
../build-plugin.sh
```


%package help
Summary:	Development documents and examples for vdk-plugin-control-cli
Provides:	python3-vdk-plugin-control-cli-doc
%description help
This plugin allows vdk-core to access vdk-control-cli functionality.

Upon installing it enhances vdk with CLI commands for data job lifecycle management available from vdk-control-cli package

It will also install properties plugin and switch Properties in vdk to use Control Service Properties API.
By default no Properties backend is used otherwise.

# Usage


```bash
pip install vdk-plugin-control-cli
```

### New CLI commands

Then on the vdk CLI you should be able to see the new commands. Run
```bash
vdk --help
```
and you will see extra commands being added:
```
Commands:
  ...
  login                  Authentication against the Control Service.
  logout                 Logout the user from the Data Jobs Service by...
  create                 Creates a new data job in cloud and locally.
  delete                 Deletes a data job from the cloud.
  deploy                 Deploys a data job.
  ...
```

And you can use them from the same CLI `vdk`

### New properties backend client registered

You can now access remote properties from Control Service Properties API
Store state, configuration or secrets there using CLI or Python JobInput API

For example, let's store some api-uri

```bash
vdk properties --set 'api-uri' 'http://cool.cool.api.com'
```

and then we can use it in our data job

```python
def run(job_input: IJobInput):
    uri = job_input.get_property('api-uri')
    print(requests.get(uri))
```

# Build

The easiest way is to use the ../build-plugin.sh helper script

```bash
../build-plugin.sh
```


%prep
%autosetup -n vdk-plugin-control-cli-0.1.886059298

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-vdk-plugin-control-cli -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.886059298-1
- Package Spec generated