%global _empty_manifest_terminate_build 0
Name: python-django-etesync-journal
Version: 1.2.3
Release: 1
Summary: The server side implementation of the EteSync protocol.
License: AGPL-3.0-only
URL: https://www.etesync.com/
Source0: https://mirrors.aliyun.com/pypi/web/packages/07/87/56987c144d8f568929b6ac50c1b234c67c94e4b9964cd73bbf6ba32aa64c/django-etesync-journal-1.2.3.tar.gz
BuildArch: noarch
%description
EteSync - Secure Data Sync
**IMPORTANT:** This repo is deprecated, please use refer to https://github.com/etesync/server/
This is a reusable django app that implements the server side of EteSync
![GitHub tag](https://img.shields.io/github/tag/etesync/journal-manager.svg)
[![PyPI](https://img.shields.io/pypi/v/django-etesync-journal.svg)](https://pypi.python.org/pypi/django-etesync-journal/)
[![Build Status](https://travis-ci.com/etesync/journal-manager.svg?branch=master)](https://travis-ci.com/etesync/journal-manager)
[![Chat on freenode](https://img.shields.io/badge/irc.freenode.net-%23EteSync-blue.svg)](https://webchat.freenode.net/?channels=#etesync)
More info is available on the [EteSync website](https://www.etesync.com)
# Quick start
1. Add "journal" to your INSTALLED_APPS setting like this::
```
INSTALLED_APPS = [
...
'journal.apps.JournalConfig',
]
```
2. Include the "journal" URLconf in your project's urls.py like this:
```
from django.conf.urls import include, url
from rest_framework import routers
from journal import views
router = routers.DefaultRouter()
router.register(r'journals', views.JournalViewSet)
router.register(r'journal/(?P[^/]+)', views.EntryViewSet)
urlpatterns = [
url(r'^api/v1/', include(router.urls)),
]
```
3. Run `python manage.py migrate` to create the journal models
%package -n python3-django-etesync-journal
Summary: The server side implementation of the EteSync protocol.
Provides: python-django-etesync-journal
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-django-etesync-journal
EteSync - Secure Data Sync
**IMPORTANT:** This repo is deprecated, please use refer to https://github.com/etesync/server/
This is a reusable django app that implements the server side of EteSync
![GitHub tag](https://img.shields.io/github/tag/etesync/journal-manager.svg)
[![PyPI](https://img.shields.io/pypi/v/django-etesync-journal.svg)](https://pypi.python.org/pypi/django-etesync-journal/)
[![Build Status](https://travis-ci.com/etesync/journal-manager.svg?branch=master)](https://travis-ci.com/etesync/journal-manager)
[![Chat on freenode](https://img.shields.io/badge/irc.freenode.net-%23EteSync-blue.svg)](https://webchat.freenode.net/?channels=#etesync)
More info is available on the [EteSync website](https://www.etesync.com)
# Quick start
1. Add "journal" to your INSTALLED_APPS setting like this::
```
INSTALLED_APPS = [
...
'journal.apps.JournalConfig',
]
```
2. Include the "journal" URLconf in your project's urls.py like this:
```
from django.conf.urls import include, url
from rest_framework import routers
from journal import views
router = routers.DefaultRouter()
router.register(r'journals', views.JournalViewSet)
router.register(r'journal/(?P[^/]+)', views.EntryViewSet)
urlpatterns = [
url(r'^api/v1/', include(router.urls)),
]
```
3. Run `python manage.py migrate` to create the journal models
%package help
Summary: Development documents and examples for django-etesync-journal
Provides: python3-django-etesync-journal-doc
%description help
EteSync - Secure Data Sync
**IMPORTANT:** This repo is deprecated, please use refer to https://github.com/etesync/server/
This is a reusable django app that implements the server side of EteSync
![GitHub tag](https://img.shields.io/github/tag/etesync/journal-manager.svg)
[![PyPI](https://img.shields.io/pypi/v/django-etesync-journal.svg)](https://pypi.python.org/pypi/django-etesync-journal/)
[![Build Status](https://travis-ci.com/etesync/journal-manager.svg?branch=master)](https://travis-ci.com/etesync/journal-manager)
[![Chat on freenode](https://img.shields.io/badge/irc.freenode.net-%23EteSync-blue.svg)](https://webchat.freenode.net/?channels=#etesync)
More info is available on the [EteSync website](https://www.etesync.com)
# Quick start
1. Add "journal" to your INSTALLED_APPS setting like this::
```
INSTALLED_APPS = [
...
'journal.apps.JournalConfig',
]
```
2. Include the "journal" URLconf in your project's urls.py like this:
```
from django.conf.urls import include, url
from rest_framework import routers
from journal import views
router = routers.DefaultRouter()
router.register(r'journals', views.JournalViewSet)
router.register(r'journal/(?P[^/]+)', views.EntryViewSet)
urlpatterns = [
url(r'^api/v1/', include(router.urls)),
]
```
3. Run `python manage.py migrate` to create the journal models
%prep
%autosetup -n django-etesync-journal-1.2.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-django-etesync-journal -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 1.2.3-1
- Package Spec generated