%global _empty_manifest_terminate_build 0
Name:		python-arv
Version:	0.9.2
Release:	1
Summary:	A fast 23andMe raw genome file parser
License:	https://www.gnu.org/licenses/gpl-3.0.html
URL:		https://github.com/cslarsen/arv
Source0:	https://mirrors.aliyun.com/pypi/web/packages/c2/6a/7198d7adcb9e5f90080c5f2e0bd9dced045f174dd809267b626278995b67/arv-0.9.2.tar.gz
BuildArch:	noarch

Requires:	python3-cython

%description
|travis-status| |versions| |license| |pypi|
Arv (Norwegian; "heritage" or "inheritance") is a Python module for parsing raw
23andMe genome files. It lets you lookup SNPs from RSIDs.
  from arv import load, unphased_match as match
  genome = load("genome.txt")
  print("You are a {gender} with {color} eyes and {complexion} skin.".format(
    gender     = "man" if genome.y_chromosome else "woman",
    complexion = "light" if genome["rs1426654"] == "AA" else "dark",
    color      = match(genome["rs12913832"], {"AA": "brown",
                                              "AG": "brown or green",
                                              "GG": "blue"})))
For my genome, this little program produces::
    You are a man with blue eyes and light skin.
The parser is insanely fast, having been written in finely tuned C++, exposed
via Cython. A 2013 Xeon machine I've tested on parses a 24 Mb file into a hash
table in about 78 ms. The newer 23andMe files are smaller, and parses in a mere
62 ms!
Works with Python 2.7+ and 3+. Installable with pip!
    $ pip install --upgrade arv
See below for software requirements.

%package -n python3-arv
Summary:	A fast 23andMe raw genome file parser
Provides:	python-arv
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-arv
|travis-status| |versions| |license| |pypi|
Arv (Norwegian; "heritage" or "inheritance") is a Python module for parsing raw
23andMe genome files. It lets you lookup SNPs from RSIDs.
  from arv import load, unphased_match as match
  genome = load("genome.txt")
  print("You are a {gender} with {color} eyes and {complexion} skin.".format(
    gender     = "man" if genome.y_chromosome else "woman",
    complexion = "light" if genome["rs1426654"] == "AA" else "dark",
    color      = match(genome["rs12913832"], {"AA": "brown",
                                              "AG": "brown or green",
                                              "GG": "blue"})))
For my genome, this little program produces::
    You are a man with blue eyes and light skin.
The parser is insanely fast, having been written in finely tuned C++, exposed
via Cython. A 2013 Xeon machine I've tested on parses a 24 Mb file into a hash
table in about 78 ms. The newer 23andMe files are smaller, and parses in a mere
62 ms!
Works with Python 2.7+ and 3+. Installable with pip!
    $ pip install --upgrade arv
See below for software requirements.

%package help
Summary:	Development documents and examples for arv
Provides:	python3-arv-doc
%description help
|travis-status| |versions| |license| |pypi|
Arv (Norwegian; "heritage" or "inheritance") is a Python module for parsing raw
23andMe genome files. It lets you lookup SNPs from RSIDs.
  from arv import load, unphased_match as match
  genome = load("genome.txt")
  print("You are a {gender} with {color} eyes and {complexion} skin.".format(
    gender     = "man" if genome.y_chromosome else "woman",
    complexion = "light" if genome["rs1426654"] == "AA" else "dark",
    color      = match(genome["rs12913832"], {"AA": "brown",
                                              "AG": "brown or green",
                                              "GG": "blue"})))
For my genome, this little program produces::
    You are a man with blue eyes and light skin.
The parser is insanely fast, having been written in finely tuned C++, exposed
via Cython. A 2013 Xeon machine I've tested on parses a 24 Mb file into a hash
table in about 78 ms. The newer 23andMe files are smaller, and parses in a mere
62 ms!
Works with Python 2.7+ and 3+. Installable with pip!
    $ pip install --upgrade arv
See below for software requirements.

%prep
%autosetup -n arv-0.9.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-arv -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9.2-1
- Package Spec generated