%global _empty_manifest_terminate_build 0
Name:		python-cryptpy
Version:	0.3.7
Release:	1
Summary:	Dynamically programmable Python/JS botnet (educational purposes only).
License:	GNU General Public License v3 (GPLv3)
URL:		https://github.com/mitsukomegumi/CryptPy.js
Source0:	https://mirrors.aliyun.com/pypi/web/packages/c2/e6/b52c72d6b89f6afb6b37cc1b52e3ddf902512d3e107ee5a1be46314692a4/cryptpy-0.3.7.tar.gz
BuildArch:	noarch

Requires:	python3-ipgetter
Requires:	python3-py3-rest-shell
Requires:	python3-simplejson

%description
![Logo](http://mattnappo.com/crypt.png)

[![Build Status](https://travis-ci.com/mitsukomegumi/CryptPy.js.svg?branch=master)](https://travis-ci.com/mitsukomegumi/CryptPy.js)
___

Dynamically programmable Python botnet (educational purposes only).

## Installation

### Core Installation with PIP (botnet sources)

```BASH
pip install cryptpy
```

### Building the Node Source (GUI Implementation)

Note: requires installation of cryptpy

First, `cd payload/vbucks`.

Build for MacOS:

1. `npm i`

2. `yarn dist`

Build for Windows:

1. `npm i`

2. `npm run dist`

## Usage

Start a Server:

```bash
cryptpy --server --terminal
```

Start and Register a Bot:

```bash
cryptpy
```




%package -n python3-cryptpy
Summary:	Dynamically programmable Python/JS botnet (educational purposes only).
Provides:	python-cryptpy
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-cryptpy
![Logo](http://mattnappo.com/crypt.png)

[![Build Status](https://travis-ci.com/mitsukomegumi/CryptPy.js.svg?branch=master)](https://travis-ci.com/mitsukomegumi/CryptPy.js)
___

Dynamically programmable Python botnet (educational purposes only).

## Installation

### Core Installation with PIP (botnet sources)

```BASH
pip install cryptpy
```

### Building the Node Source (GUI Implementation)

Note: requires installation of cryptpy

First, `cd payload/vbucks`.

Build for MacOS:

1. `npm i`

2. `yarn dist`

Build for Windows:

1. `npm i`

2. `npm run dist`

## Usage

Start a Server:

```bash
cryptpy --server --terminal
```

Start and Register a Bot:

```bash
cryptpy
```




%package help
Summary:	Development documents and examples for cryptpy
Provides:	python3-cryptpy-doc
%description help
![Logo](http://mattnappo.com/crypt.png)

[![Build Status](https://travis-ci.com/mitsukomegumi/CryptPy.js.svg?branch=master)](https://travis-ci.com/mitsukomegumi/CryptPy.js)
___

Dynamically programmable Python botnet (educational purposes only).

## Installation

### Core Installation with PIP (botnet sources)

```BASH
pip install cryptpy
```

### Building the Node Source (GUI Implementation)

Note: requires installation of cryptpy

First, `cd payload/vbucks`.

Build for MacOS:

1. `npm i`

2. `yarn dist`

Build for Windows:

1. `npm i`

2. `npm run dist`

## Usage

Start a Server:

```bash
cryptpy --server --terminal
```

Start and Register a Bot:

```bash
cryptpy
```




%prep
%autosetup -n cryptpy-0.3.7

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-cryptpy -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.7-1
- Package Spec generated