%global _empty_manifest_terminate_build 0
Name: python-Hamlish-Jinja
Version: 0.3.3
Release: 1
Summary: Haml-ish syntax for jinja2 templates
License: UNKNOWN
URL: http://github.com/Pitmairen/hamlish-jinja
Source0: https://mirrors.aliyun.com/pypi/web/packages/b3/d8/706e9f33aa7de1212e20cd06b7062692fe40b0790f661adcd425ef91e88d/Hamlish-Jinja-0.3.3.tar.gz
BuildArch: noarch
%description
This extension to jinja make it possible to use a
`haml `_-ish syntax for your jinja2 templates.
Example template::
-extends 'base.html'
-block title << Memberlist
-block content:
%ul id="memberlist"
-for user in users:
%li
%a href="{{ user.url }}" << {{ user.username }}
For more information read the
`documentation `_
%package -n python3-Hamlish-Jinja
Summary: Haml-ish syntax for jinja2 templates
Provides: python-Hamlish-Jinja
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-Hamlish-Jinja
This extension to jinja make it possible to use a
`haml `_-ish syntax for your jinja2 templates.
Example template::
-extends 'base.html'
-block title << Memberlist
-block content:
%ul id="memberlist"
-for user in users:
%li
%a href="{{ user.url }}" << {{ user.username }}
For more information read the
`documentation `_
%package help
Summary: Development documents and examples for Hamlish-Jinja
Provides: python3-Hamlish-Jinja-doc
%description help
This extension to jinja make it possible to use a
`haml `_-ish syntax for your jinja2 templates.
Example template::
-extends 'base.html'
-block title << Memberlist
-block content:
%ul id="memberlist"
-for user in users:
%li
%a href="{{ user.url }}" << {{ user.username }}
For more information read the
`documentation `_
%prep
%autosetup -n Hamlish-Jinja-0.3.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-Hamlish-Jinja -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.3.3-1
- Package Spec generated