%global _empty_manifest_terminate_build 0
Name:		python-ztv
Version:	0.2.3.post4
Release:	1
Summary:	Simple python image viewer, largely intended for astronomical applications
License:	MIT License
URL:		https://github.com/henryroe/ztv
Source0:	https://mirrors.aliyun.com/pypi/web/packages/56/30/65674e2ea9b18388e75d019ec353d59db95d94f5fdff0f90f231431b8961/ztv-0.2.3.post4.tar.gz
BuildArch:	noarch

Requires:	python3-astropy
Requires:	python3-astropy-helpers
Requires:	python3-matplotlib
Requires:	python3-psutil
Requires:	python3-wxPython

%description
*ztv* is an astronomical image viewer designed to be used from a python
command line for display and analysis.
*ztv* is useful as-is for display and simple analysis of images already
loaded in to `numpy arrays <http://www.numpy.org>`__, as well as `FITS
files <http://fits.gsfc.nasa.gov/fits_primer.html>`__. It can display
the most recently acquired image by watching a directory for new FITS
files to appear or watching a single FITS file for when it changes. It
can also receive new images via an `ActiveMQ message
stream <http://activemq.apache.org>`__.
*ztv* is intended for real-time display and analysis. *ztv* is not
intended to produce publication quality figures.
*ztv* comes with a number of built-in control panels, for: - selecting
input source (FITS file, auto-reload from FITS file, etc) - selecting a
frame to subtract (e.g. sky or dark) and a flat field frame to divide by
- setting colormap, stretch, and lower/upper limits - doing basic slice
plots, statistics, and aperture photometry. Additional panels can be
written and added, for e.g. controlling a camera. (One example add-on
panel is included that generates faked images in the FITS format.)
If proper FITS header keywords are available, *ztv* will display the
ra/dec of the cursor point.

%package -n python3-ztv
Summary:	Simple python image viewer, largely intended for astronomical applications
Provides:	python-ztv
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-ztv
*ztv* is an astronomical image viewer designed to be used from a python
command line for display and analysis.
*ztv* is useful as-is for display and simple analysis of images already
loaded in to `numpy arrays <http://www.numpy.org>`__, as well as `FITS
files <http://fits.gsfc.nasa.gov/fits_primer.html>`__. It can display
the most recently acquired image by watching a directory for new FITS
files to appear or watching a single FITS file for when it changes. It
can also receive new images via an `ActiveMQ message
stream <http://activemq.apache.org>`__.
*ztv* is intended for real-time display and analysis. *ztv* is not
intended to produce publication quality figures.
*ztv* comes with a number of built-in control panels, for: - selecting
input source (FITS file, auto-reload from FITS file, etc) - selecting a
frame to subtract (e.g. sky or dark) and a flat field frame to divide by
- setting colormap, stretch, and lower/upper limits - doing basic slice
plots, statistics, and aperture photometry. Additional panels can be
written and added, for e.g. controlling a camera. (One example add-on
panel is included that generates faked images in the FITS format.)
If proper FITS header keywords are available, *ztv* will display the
ra/dec of the cursor point.

%package help
Summary:	Development documents and examples for ztv
Provides:	python3-ztv-doc
%description help
*ztv* is an astronomical image viewer designed to be used from a python
command line for display and analysis.
*ztv* is useful as-is for display and simple analysis of images already
loaded in to `numpy arrays <http://www.numpy.org>`__, as well as `FITS
files <http://fits.gsfc.nasa.gov/fits_primer.html>`__. It can display
the most recently acquired image by watching a directory for new FITS
files to appear or watching a single FITS file for when it changes. It
can also receive new images via an `ActiveMQ message
stream <http://activemq.apache.org>`__.
*ztv* is intended for real-time display and analysis. *ztv* is not
intended to produce publication quality figures.
*ztv* comes with a number of built-in control panels, for: - selecting
input source (FITS file, auto-reload from FITS file, etc) - selecting a
frame to subtract (e.g. sky or dark) and a flat field frame to divide by
- setting colormap, stretch, and lower/upper limits - doing basic slice
plots, statistics, and aperture photometry. Additional panels can be
written and added, for e.g. controlling a camera. (One example add-on
panel is included that generates faked images in the FITS format.)
If proper FITS header keywords are available, *ztv* will display the
ra/dec of the cursor point.

%prep
%autosetup -n ztv-0.2.3.post4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-ztv -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.3.post4-1
- Package Spec generated