%global _empty_manifest_terminate_build 0
Name:		python-imgMS
Version:	0.2.7
Release:	1
Summary:	Package for data reduction of LA-ICP-MS data.
License:	LICENSE.txt
URL:		https://github.com/nikadilli/imgMS
Source0:	https://mirrors.aliyun.com/pypi/web/packages/e9/26/f23b56d67490b765b21bef5554c98d7398814fe1af500bafd242a2bff8ac/imgMS-0.2.7.tar.gz
BuildArch:	noarch

Requires:	python3-matplotlib
Requires:	python3-pandas
Requires:	python3-numpy
Requires:	python3-patsy
Requires:	python3-Pillow
Requires:	python3-scikit-learn
Requires:	python3-scipy
Requires:	python3-sklearn
Requires:	python3-statsmodels
Requires:	python3-xlrd
Requires:	python3-XlsxWriter

%description
[![Documentation Status](https://readthedocs.org/projects/imgms/badge/?version=latest)](https://imgms.readthedocs.io/en/latest/?badge=latest)

# imgMS

## Introduction
LA-ICP-MS data require high level of manual processing to achieve results. Often the time needed for data evaluation by far exceeds the time necessary for data aquisition. During analysis, mass spectra are either written as a separate files, or as a continuous data stream into one single file. Both of these aproaches require a different workflow of processing steps. *imgMS* is a Python package which aims to provide an easy and intuitive way of working with LA-ICP-MS data acquired into single file.

*imgMS* automatically processes these steps of analysis:
1. bacground/signal identification
2. signal despiking
3. background substraction
4. total sum normalisation
5. internal standard normalisation
6. quantification to reference material
7. generation of elemental maps

## Motivation

As a Phd student in the field of analytical chemistry using LA-ICP-MS for rutine analysis as well as research tasks, I found it pretty difficult and time consuming to evaluate data without an appropriate software. Despite the fact, that there exists multiple free or open source software, I couldn't find any that would fit the workflow of our department. What started as a simple script for data reduction of LA-ICP-MS data, is now a complete python package.  

This package is intended to provide a quick, as well as (hopefully) easy to undestand, way of getting a results from bulk analysis or elemental imaging using LA-ICP-MS.

## Installation

*imgMS* is a python package registered at PyPI, and therefore can be installed with pip:

```
pip install imgMS
```

## Limitations

- So far there is only option to directly import data from 2 instruments (ThermoFisher Element2 and Agilent) in 3 formats (.csv, .xlsx, .asc). In the future there will be more options.

- imgMS only works with multiple analysis with reference analysis acquired in one file, unlike many other software aimed on LA-ICP-MS data reduction. 







%package -n python3-imgMS
Summary:	Package for data reduction of LA-ICP-MS data.
Provides:	python-imgMS
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-imgMS
[![Documentation Status](https://readthedocs.org/projects/imgms/badge/?version=latest)](https://imgms.readthedocs.io/en/latest/?badge=latest)

# imgMS

## Introduction
LA-ICP-MS data require high level of manual processing to achieve results. Often the time needed for data evaluation by far exceeds the time necessary for data aquisition. During analysis, mass spectra are either written as a separate files, or as a continuous data stream into one single file. Both of these aproaches require a different workflow of processing steps. *imgMS* is a Python package which aims to provide an easy and intuitive way of working with LA-ICP-MS data acquired into single file.

*imgMS* automatically processes these steps of analysis:
1. bacground/signal identification
2. signal despiking
3. background substraction
4. total sum normalisation
5. internal standard normalisation
6. quantification to reference material
7. generation of elemental maps

## Motivation

As a Phd student in the field of analytical chemistry using LA-ICP-MS for rutine analysis as well as research tasks, I found it pretty difficult and time consuming to evaluate data without an appropriate software. Despite the fact, that there exists multiple free or open source software, I couldn't find any that would fit the workflow of our department. What started as a simple script for data reduction of LA-ICP-MS data, is now a complete python package.  

This package is intended to provide a quick, as well as (hopefully) easy to undestand, way of getting a results from bulk analysis or elemental imaging using LA-ICP-MS.

## Installation

*imgMS* is a python package registered at PyPI, and therefore can be installed with pip:

```
pip install imgMS
```

## Limitations

- So far there is only option to directly import data from 2 instruments (ThermoFisher Element2 and Agilent) in 3 formats (.csv, .xlsx, .asc). In the future there will be more options.

- imgMS only works with multiple analysis with reference analysis acquired in one file, unlike many other software aimed on LA-ICP-MS data reduction. 







%package help
Summary:	Development documents and examples for imgMS
Provides:	python3-imgMS-doc
%description help
[![Documentation Status](https://readthedocs.org/projects/imgms/badge/?version=latest)](https://imgms.readthedocs.io/en/latest/?badge=latest)

# imgMS

## Introduction
LA-ICP-MS data require high level of manual processing to achieve results. Often the time needed for data evaluation by far exceeds the time necessary for data aquisition. During analysis, mass spectra are either written as a separate files, or as a continuous data stream into one single file. Both of these aproaches require a different workflow of processing steps. *imgMS* is a Python package which aims to provide an easy and intuitive way of working with LA-ICP-MS data acquired into single file.

*imgMS* automatically processes these steps of analysis:
1. bacground/signal identification
2. signal despiking
3. background substraction
4. total sum normalisation
5. internal standard normalisation
6. quantification to reference material
7. generation of elemental maps

## Motivation

As a Phd student in the field of analytical chemistry using LA-ICP-MS for rutine analysis as well as research tasks, I found it pretty difficult and time consuming to evaluate data without an appropriate software. Despite the fact, that there exists multiple free or open source software, I couldn't find any that would fit the workflow of our department. What started as a simple script for data reduction of LA-ICP-MS data, is now a complete python package.  

This package is intended to provide a quick, as well as (hopefully) easy to undestand, way of getting a results from bulk analysis or elemental imaging using LA-ICP-MS.

## Installation

*imgMS* is a python package registered at PyPI, and therefore can be installed with pip:

```
pip install imgMS
```

## Limitations

- So far there is only option to directly import data from 2 instruments (ThermoFisher Element2 and Agilent) in 3 formats (.csv, .xlsx, .asc). In the future there will be more options.

- imgMS only works with multiple analysis with reference analysis acquired in one file, unlike many other software aimed on LA-ICP-MS data reduction. 







%prep
%autosetup -n imgMS-0.2.7

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-imgMS -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.7-1
- Package Spec generated