%global _empty_manifest_terminate_build 0
Name: python-ROSSpy
Version: 0.1.7
Release: 1
Summary: Software for predicting the brine concentrations and scaling quantities after RO desalination.
License: MIT License Copyright (c) 2022 Andrew Philip Freiburger Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions: The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software. THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
URL: https://github.com/freiburgermsu/ROSSpy
Source0: https://mirrors.aliyun.com/pypi/web/packages/dd/48/c7a3a9187d6cb3d43be7eb4958cb08f74fa0c297deb10f6a6a3b8fab88b0/ROSSpy-0.1.7.tar.gz
BuildArch: noarch
%description
|PyPI version| |DOI| |Actions Status| |Downloads| |docs| |License|
`Reverse Osmosis Scaling Software in Python (ROSSpy) `_ offers an open-source API to simulate the reactive transport geochemistry of Reverse Osmosis desalination. ROSSpy essentially translates user specifications of an RO system into `PHREEQpy `_, which is the Python version of `PHREEQC `_. The ``examples/scaling/scaling_validation`` directory of the `ROSSpy GitHub `_ details the numerous functions and accuracy of ROSSPy via Notebook examples. We encourage users and developers to critique and improve ROSSpy, as an open-source (`MIT License `_) library, through `GitHub issues `_.
The complete documentation is provided by `ReadTheDocs `_.
++++++++++++++++++++++
Installation
++++++++++++++++++++++
ROSSpy is installed in a command prompt, Powershell, Terminal, or Anaconda Command Prompt via ``pip``::
pip install rosspy
The IPHREEQC module must then be installed, since this is the source of geochemical calculations and data for ROSSpy. The appropriate version of IPHREEQC can be installed from the `USGS `_ .
**Linux** installation may require addition steps (Ubuntu < 20 is currently unsupported)::
wget https://water.usgs.gov/water-resources/software/PHREEQC/iphreeqc-3.7.3-15968.tar.gz
tar -xzvf iphreeqc-3.7.3-15968.tar.gz
cd iphreeqc-3.7.3-15968
./configure
make
make check
sudo make install
pip show phreeqpy
sudo cp /usr/local/lib/libiphreeqc.so /path/to/site-packages/phreeqpy/iphreeqc/libiphreeqc.so.0.0.0
++++++++++++++++++++++
Citation
++++++++++++++++++++++
Please cite this work::
Freiburger, Andrew P. and Molins, Sergi and Buckley, Heather L., A One-Dimensional Reactive Transport Model of Geochemical Scaling in Reverse Osmosis Desalination. http://dx.doi.org/10.2139/ssrn.4124149
%package -n python3-ROSSpy
Summary: Software for predicting the brine concentrations and scaling quantities after RO desalination.
Provides: python-ROSSpy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-ROSSpy
|PyPI version| |DOI| |Actions Status| |Downloads| |docs| |License|
`Reverse Osmosis Scaling Software in Python (ROSSpy) `_ offers an open-source API to simulate the reactive transport geochemistry of Reverse Osmosis desalination. ROSSpy essentially translates user specifications of an RO system into `PHREEQpy `_, which is the Python version of `PHREEQC `_. The ``examples/scaling/scaling_validation`` directory of the `ROSSpy GitHub `_ details the numerous functions and accuracy of ROSSPy via Notebook examples. We encourage users and developers to critique and improve ROSSpy, as an open-source (`MIT License `_) library, through `GitHub issues `_.
The complete documentation is provided by `ReadTheDocs `_.
++++++++++++++++++++++
Installation
++++++++++++++++++++++
ROSSpy is installed in a command prompt, Powershell, Terminal, or Anaconda Command Prompt via ``pip``::
pip install rosspy
The IPHREEQC module must then be installed, since this is the source of geochemical calculations and data for ROSSpy. The appropriate version of IPHREEQC can be installed from the `USGS `_ .
**Linux** installation may require addition steps (Ubuntu < 20 is currently unsupported)::
wget https://water.usgs.gov/water-resources/software/PHREEQC/iphreeqc-3.7.3-15968.tar.gz
tar -xzvf iphreeqc-3.7.3-15968.tar.gz
cd iphreeqc-3.7.3-15968
./configure
make
make check
sudo make install
pip show phreeqpy
sudo cp /usr/local/lib/libiphreeqc.so /path/to/site-packages/phreeqpy/iphreeqc/libiphreeqc.so.0.0.0
++++++++++++++++++++++
Citation
++++++++++++++++++++++
Please cite this work::
Freiburger, Andrew P. and Molins, Sergi and Buckley, Heather L., A One-Dimensional Reactive Transport Model of Geochemical Scaling in Reverse Osmosis Desalination. http://dx.doi.org/10.2139/ssrn.4124149
%package help
Summary: Development documents and examples for ROSSpy
Provides: python3-ROSSpy-doc
%description help
|PyPI version| |DOI| |Actions Status| |Downloads| |docs| |License|
`Reverse Osmosis Scaling Software in Python (ROSSpy) `_ offers an open-source API to simulate the reactive transport geochemistry of Reverse Osmosis desalination. ROSSpy essentially translates user specifications of an RO system into `PHREEQpy `_, which is the Python version of `PHREEQC `_. The ``examples/scaling/scaling_validation`` directory of the `ROSSpy GitHub `_ details the numerous functions and accuracy of ROSSPy via Notebook examples. We encourage users and developers to critique and improve ROSSpy, as an open-source (`MIT License `_) library, through `GitHub issues `_.
The complete documentation is provided by `ReadTheDocs `_.
++++++++++++++++++++++
Installation
++++++++++++++++++++++
ROSSpy is installed in a command prompt, Powershell, Terminal, or Anaconda Command Prompt via ``pip``::
pip install rosspy
The IPHREEQC module must then be installed, since this is the source of geochemical calculations and data for ROSSpy. The appropriate version of IPHREEQC can be installed from the `USGS `_ .
**Linux** installation may require addition steps (Ubuntu < 20 is currently unsupported)::
wget https://water.usgs.gov/water-resources/software/PHREEQC/iphreeqc-3.7.3-15968.tar.gz
tar -xzvf iphreeqc-3.7.3-15968.tar.gz
cd iphreeqc-3.7.3-15968
./configure
make
make check
sudo make install
pip show phreeqpy
sudo cp /usr/local/lib/libiphreeqc.so /path/to/site-packages/phreeqpy/iphreeqc/libiphreeqc.so.0.0.0
++++++++++++++++++++++
Citation
++++++++++++++++++++++
Please cite this work::
Freiburger, Andrew P. and Molins, Sergi and Buckley, Heather L., A One-Dimensional Reactive Transport Model of Geochemical Scaling in Reverse Osmosis Desalination. http://dx.doi.org/10.2139/ssrn.4124149
%prep
%autosetup -n ROSSpy-0.1.7
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-ROSSpy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.1.7-1
- Package Spec generated