%global _empty_manifest_terminate_build 0
Name: python-cis-interface
Version: 0.7.10
Release: 1
Summary: A framework for combining interdependent models from multiple languages.
License: BSD
URL: https://github.com/cropsinsilico/cis_interface
Source0: https://mirrors.aliyun.com/pypi/web/packages/33/c5/4108a6fa4667ad26c752cb1a3d36f0914d17d523a343e458eccac8d0edee/cis_interface-0.7.10.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-scipy
Requires: python3-pyyaml
Requires: python3-pystache
Requires: python3-pyzmq
Requires: python3-psutil
Requires: python3-jsonschema
Requires: python3-perf
Requires: python3-sysv-ipc
Requires: python3-pandas
Requires: python3-matplotlib
Requires: python3-pint
Requires: python3-pandas
Requires: python3-rapidjson
Requires: python3-unyt
Requires: python3-matplotlib
%description
|PyPI version| |Build Status| |Build status| |Coverage Status| |codecov|
|PEP8|
The CiS framework provides support for combining scientific models
written in different programming languages. To combine two models,
modelers add simple communications interfaces to the model code and
provide simple declarative specification files that identify the models
that should be run and the inputs and outputs those models expect.
The system uses the specification files to configure the communications
channels and expose them to the models. The complexity of the particular
communications system is managed by the framework, which performs
communication setup, binds the communications to simple interfaces
within the models, and manages execution of the models. The complexities
of model registration and discovery, as well as the complexities of
setup and management of the communications system are handled
under-the-hood by the framework under direction of the model
specification, freeing the domain scientist from implementing
communications protocols or translating models to the same programming
language.
Please refer to the package
`documentation `__ for
additional information about the package and directions for installing
it.
.. warning:: This will be the last release of the Crops in Silico
framework under the name ``cis_interface``. Moving forward,
the package will be refered to as ``yggdrasil``. The new
Github repository for ``yggdrasil`` can be found
`here `__
and the new documentation can be found
`here `__.
Future versions of the ``yggdrasil`` package be installed from
PyPI via ``pip install yggdrasil-framework``. We apologize for
any inconvenince this change causes, but feel the new name
better reflects the spirit of the project.
.. |PyPI version| image:: https://img.shields.io/pypi/v/cis_interface.svg?colorB=g&style=flat
:target: https://pypi.org/project/cis-interface/
.. |Build Status| image:: https://img.shields.io/travis/cropsinsilico/yggdrasil/cis_interface.svg?style=flat
:target: https://travis-ci.org/cropsinsilico/yggdrasil
.. |Build status| image:: https://img.shields.io/appveyor/ci/langmm/yggdrasil/cis_interface.svg?style=flat
:target: https://ci.appveyor.com/project/langmm/yggdrasil/branch/cis_interface
.. |Coverage Status| image:: https://coveralls.io/repos/github/cropsinsilico/yggdrasil/badge.svg?branch=cis_interface
:target: https://coveralls.io/github/cropsinsilico/yggdrasil?branch=cis_interface
.. |codecov| image:: https://codecov.io/gh/cropsinsilico/yggdrasil/branch/cis_interface/graph/badge.svg
:target: https://codecov.io/gh/cropsinsilico/yggdrasil
.. |PEP8| image:: https://img.shields.io/badge/code%20style-pep8-orange.svg
:target: https://www.python.org/dev/peps/pep-0008/
%package -n python3-cis-interface
Summary: A framework for combining interdependent models from multiple languages.
Provides: python-cis-interface
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-cis-interface
|PyPI version| |Build Status| |Build status| |Coverage Status| |codecov|
|PEP8|
The CiS framework provides support for combining scientific models
written in different programming languages. To combine two models,
modelers add simple communications interfaces to the model code and
provide simple declarative specification files that identify the models
that should be run and the inputs and outputs those models expect.
The system uses the specification files to configure the communications
channels and expose them to the models. The complexity of the particular
communications system is managed by the framework, which performs
communication setup, binds the communications to simple interfaces
within the models, and manages execution of the models. The complexities
of model registration and discovery, as well as the complexities of
setup and management of the communications system are handled
under-the-hood by the framework under direction of the model
specification, freeing the domain scientist from implementing
communications protocols or translating models to the same programming
language.
Please refer to the package
`documentation `__ for
additional information about the package and directions for installing
it.
.. warning:: This will be the last release of the Crops in Silico
framework under the name ``cis_interface``. Moving forward,
the package will be refered to as ``yggdrasil``. The new
Github repository for ``yggdrasil`` can be found
`here `__
and the new documentation can be found
`here `__.
Future versions of the ``yggdrasil`` package be installed from
PyPI via ``pip install yggdrasil-framework``. We apologize for
any inconvenince this change causes, but feel the new name
better reflects the spirit of the project.
.. |PyPI version| image:: https://img.shields.io/pypi/v/cis_interface.svg?colorB=g&style=flat
:target: https://pypi.org/project/cis-interface/
.. |Build Status| image:: https://img.shields.io/travis/cropsinsilico/yggdrasil/cis_interface.svg?style=flat
:target: https://travis-ci.org/cropsinsilico/yggdrasil
.. |Build status| image:: https://img.shields.io/appveyor/ci/langmm/yggdrasil/cis_interface.svg?style=flat
:target: https://ci.appveyor.com/project/langmm/yggdrasil/branch/cis_interface
.. |Coverage Status| image:: https://coveralls.io/repos/github/cropsinsilico/yggdrasil/badge.svg?branch=cis_interface
:target: https://coveralls.io/github/cropsinsilico/yggdrasil?branch=cis_interface
.. |codecov| image:: https://codecov.io/gh/cropsinsilico/yggdrasil/branch/cis_interface/graph/badge.svg
:target: https://codecov.io/gh/cropsinsilico/yggdrasil
.. |PEP8| image:: https://img.shields.io/badge/code%20style-pep8-orange.svg
:target: https://www.python.org/dev/peps/pep-0008/
%package help
Summary: Development documents and examples for cis-interface
Provides: python3-cis-interface-doc
%description help
|PyPI version| |Build Status| |Build status| |Coverage Status| |codecov|
|PEP8|
The CiS framework provides support for combining scientific models
written in different programming languages. To combine two models,
modelers add simple communications interfaces to the model code and
provide simple declarative specification files that identify the models
that should be run and the inputs and outputs those models expect.
The system uses the specification files to configure the communications
channels and expose them to the models. The complexity of the particular
communications system is managed by the framework, which performs
communication setup, binds the communications to simple interfaces
within the models, and manages execution of the models. The complexities
of model registration and discovery, as well as the complexities of
setup and management of the communications system are handled
under-the-hood by the framework under direction of the model
specification, freeing the domain scientist from implementing
communications protocols or translating models to the same programming
language.
Please refer to the package
`documentation `__ for
additional information about the package and directions for installing
it.
.. warning:: This will be the last release of the Crops in Silico
framework under the name ``cis_interface``. Moving forward,
the package will be refered to as ``yggdrasil``. The new
Github repository for ``yggdrasil`` can be found
`here `__
and the new documentation can be found
`here `__.
Future versions of the ``yggdrasil`` package be installed from
PyPI via ``pip install yggdrasil-framework``. We apologize for
any inconvenince this change causes, but feel the new name
better reflects the spirit of the project.
.. |PyPI version| image:: https://img.shields.io/pypi/v/cis_interface.svg?colorB=g&style=flat
:target: https://pypi.org/project/cis-interface/
.. |Build Status| image:: https://img.shields.io/travis/cropsinsilico/yggdrasil/cis_interface.svg?style=flat
:target: https://travis-ci.org/cropsinsilico/yggdrasil
.. |Build status| image:: https://img.shields.io/appveyor/ci/langmm/yggdrasil/cis_interface.svg?style=flat
:target: https://ci.appveyor.com/project/langmm/yggdrasil/branch/cis_interface
.. |Coverage Status| image:: https://coveralls.io/repos/github/cropsinsilico/yggdrasil/badge.svg?branch=cis_interface
:target: https://coveralls.io/github/cropsinsilico/yggdrasil?branch=cis_interface
.. |codecov| image:: https://codecov.io/gh/cropsinsilico/yggdrasil/branch/cis_interface/graph/badge.svg
:target: https://codecov.io/gh/cropsinsilico/yggdrasil
.. |PEP8| image:: https://img.shields.io/badge/code%20style-pep8-orange.svg
:target: https://www.python.org/dev/peps/pep-0008/
%prep
%autosetup -n cis_interface-0.7.10
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-cis-interface -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.7.10-1
- Package Spec generated