%global _empty_manifest_terminate_build 0 Name: python-cameramodels Version: 0.2.12 Release: 1 Summary: A python library for cameramodels License: MIT URL: https://github.com/iory/cameramodels Source0: https://mirrors.aliyun.com/pypi/web/packages/ad/b1/74400c1653de6288e64869b06515e7d72deb8d017de20d940bc7db466717/cameramodels-0.2.12.tar.gz BuildArch: noarch Requires: python3-numpy Requires: python3-pillow Requires: python3-pyyaml Requires: python3-scipy Requires: python3-open3d Requires: python3-opencv-python Requires: python3-opencv-python %description # Camera Models [![Build Status](https://github.com/iory/cameramodels/workflows/Run%20Tests/badge.svg?branch=master)](https://github.com/iory/cameramodels/actions)

Documentation | Python API |

Manipulate Camera Library. ## Installation ```bash pip install cameramodels ``` If you would like to use `open3d` conversion functions, ```bash pip install cameramodels[all] ``` %package -n python3-cameramodels Summary: A python library for cameramodels Provides: python-cameramodels BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-cameramodels # Camera Models [![Build Status](https://github.com/iory/cameramodels/workflows/Run%20Tests/badge.svg?branch=master)](https://github.com/iory/cameramodels/actions)

Documentation | Python API |

Manipulate Camera Library. ## Installation ```bash pip install cameramodels ``` If you would like to use `open3d` conversion functions, ```bash pip install cameramodels[all] ``` %package help Summary: Development documents and examples for cameramodels Provides: python3-cameramodels-doc %description help # Camera Models [![Build Status](https://github.com/iory/cameramodels/workflows/Run%20Tests/badge.svg?branch=master)](https://github.com/iory/cameramodels/actions)

Documentation | Python API |

Manipulate Camera Library. ## Installation ```bash pip install cameramodels ``` If you would like to use `open3d` conversion functions, ```bash pip install cameramodels[all] ``` %prep %autosetup -n cameramodels-0.2.12 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-cameramodels -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Tue Jun 20 2023 Python_Bot - 0.2.12-1 - Package Spec generated