%global _empty_manifest_terminate_build 0
Name: python-wandb-ng
Version: 0.0.44
Release: 1
Summary: A CLI and library for interacting with the Weights and Biases API.
License: MIT license
URL: https://github.com/wandb/client
Source0: https://mirrors.aliyun.com/pypi/web/packages/2c/16/0da44fabb2c639897672b4e30cc24afe25e152ec4ea6f05a130be9601504/wandb-ng-0.0.44.tar.gz
BuildArch: noarch
Requires: python3-Click
Requires: python3-GitPython
Requires: python3-dateutil
Requires: python3-requests
Requires: python3-promise
Requires: python3-shortuuid
Requires: python3-six
Requires: python3-watchdog
Requires: python3-psutil
Requires: python3-sentry-sdk
Requires: python3-subprocess32
Requires: python3-docker-pycreds
Requires: python3-configparser
Requires: python3-protobuf
Requires: python3-PyYAML
Requires: python3-enum34
Requires: python3-typing
Requires: python3-boto3
Requires: python3-google-cloud-storage
Requires: python3-grpcio
Requires: python3-kubernetes
Requires: python3-minio
Requires: python3-google-cloud-storage
Requires: python3-sh
%description
# Weights and Biases [](https://circleci.com/gh/wandb/client-ng) [](https://pypi.python.org/pypi/wandb) [](https://coveralls.io/github/wandb/client-ng)
Use W&B to organize and analyze machine learning experiments. It's framework-agnostic and lighter than TensorBoard. Each time you run a script instrumented with `wandb`, we save your hyperparameters and output metrics. Visualize models over the course of training, and compare versions of your models easily. We also automatically track the state of your code, system metrics, and configuration parameters.
[Sign up for a free account →](https://wandb.com)
## Features
- Store hyper-parameters used in a training run
- Search, compare, and visualize training runs
- Analyze system usage metrics alongside runs
- Collaborate with team members
- Replicate historic results
- Run parameter sweeps
- Keep records of experiments available forever
[Documentation →](https://docs.wandb.com)
## Quickstart
```shell
pip install wandb
```
In your training script:
```python
import wandb
# Your custom arguments defined here
args = ...
wandb.init(config=args, project="my-project")
wandb.config["more"] = "custom"
def training_loop():
while True:
# Do some machine learning
epoch, loss, val_loss = ...
# Framework agnostic / custom metrics
wandb.log({"epoch": epoch, "loss": loss, "val_loss": val_loss})
```
If you're already using Tensorboard or [TensorboardX](https://github.com/lanpa/tensorboardX), you can integrate with one line:
```python
wandb.init(sync_tensorboard=True)
```
## Running your script
Run `wandb login` from your terminal to signup or authenticate your machine (we store your api key in ~/.netrc). You can also set the `WANDB_API_KEY` environment variable with a key from your [settings](https://app.wandb.ai/settings).
Run your script with `python my_script.py` and all metadata will be synced to the cloud. You will see a url in your terminal logs when your script starts and finishes. Data is staged locally in a directory named _wandb_ relative to your script. If you want to test your script without syncing to the cloud you can set the environment variable `WANDB_MODE=dryrun`.
If you are using [docker](https://docker.com) to run your code, we provide a wrapper command `wandb docker` that mounts your current directory, sets environment variables, and ensures the wandb library is installed. Training your models in docker gives you the ability to restore the exact code and environment with the `wandb restore` command.
## Web Interface
[Sign up for a free account →](https://wandb.com)
[](https://youtu.be/EeqhOSvNX-A)
[Introduction video →](https://youtu.be/EeqhOSvNX-A)
## Detailed Usage
Framework specific and detailed usage can be found in our [documentation](http://docs.wandb.com/).
## Testing
To run basic test use `make test`. More detailed information can be found at CONTRIBUTING.md.
We use [circleci](https://circleci.com) for CI.
# Academic Researchers
If you'd like a free academic account for your research group, [reach out to us →](https://www.wandb.com/academic)
We make it easy to cite W&B in your published paper. [Learn more →](https://www.wandb.com/academic)
[](https://www.wandb.com/academic)
## Community
Got questions, feedback or want to join a community of ML engineers working on exciting projects?
Join our [slack](https://bit.ly/wb-slack) community.
[](https://twitter.com/weights_biases) Follow us on [Twitter](https://twitter.com/weights_biases).
%package -n python3-wandb-ng
Summary: A CLI and library for interacting with the Weights and Biases API.
Provides: python-wandb-ng
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-wandb-ng
# Weights and Biases [](https://circleci.com/gh/wandb/client-ng) [](https://pypi.python.org/pypi/wandb) [](https://coveralls.io/github/wandb/client-ng)
Use W&B to organize and analyze machine learning experiments. It's framework-agnostic and lighter than TensorBoard. Each time you run a script instrumented with `wandb`, we save your hyperparameters and output metrics. Visualize models over the course of training, and compare versions of your models easily. We also automatically track the state of your code, system metrics, and configuration parameters.
[Sign up for a free account →](https://wandb.com)
## Features
- Store hyper-parameters used in a training run
- Search, compare, and visualize training runs
- Analyze system usage metrics alongside runs
- Collaborate with team members
- Replicate historic results
- Run parameter sweeps
- Keep records of experiments available forever
[Documentation →](https://docs.wandb.com)
## Quickstart
```shell
pip install wandb
```
In your training script:
```python
import wandb
# Your custom arguments defined here
args = ...
wandb.init(config=args, project="my-project")
wandb.config["more"] = "custom"
def training_loop():
while True:
# Do some machine learning
epoch, loss, val_loss = ...
# Framework agnostic / custom metrics
wandb.log({"epoch": epoch, "loss": loss, "val_loss": val_loss})
```
If you're already using Tensorboard or [TensorboardX](https://github.com/lanpa/tensorboardX), you can integrate with one line:
```python
wandb.init(sync_tensorboard=True)
```
## Running your script
Run `wandb login` from your terminal to signup or authenticate your machine (we store your api key in ~/.netrc). You can also set the `WANDB_API_KEY` environment variable with a key from your [settings](https://app.wandb.ai/settings).
Run your script with `python my_script.py` and all metadata will be synced to the cloud. You will see a url in your terminal logs when your script starts and finishes. Data is staged locally in a directory named _wandb_ relative to your script. If you want to test your script without syncing to the cloud you can set the environment variable `WANDB_MODE=dryrun`.
If you are using [docker](https://docker.com) to run your code, we provide a wrapper command `wandb docker` that mounts your current directory, sets environment variables, and ensures the wandb library is installed. Training your models in docker gives you the ability to restore the exact code and environment with the `wandb restore` command.
## Web Interface
[Sign up for a free account →](https://wandb.com)
[](https://youtu.be/EeqhOSvNX-A)
[Introduction video →](https://youtu.be/EeqhOSvNX-A)
## Detailed Usage
Framework specific and detailed usage can be found in our [documentation](http://docs.wandb.com/).
## Testing
To run basic test use `make test`. More detailed information can be found at CONTRIBUTING.md.
We use [circleci](https://circleci.com) for CI.
# Academic Researchers
If you'd like a free academic account for your research group, [reach out to us →](https://www.wandb.com/academic)
We make it easy to cite W&B in your published paper. [Learn more →](https://www.wandb.com/academic)
[](https://www.wandb.com/academic)
## Community
Got questions, feedback or want to join a community of ML engineers working on exciting projects?
Join our [slack](https://bit.ly/wb-slack) community.
[](https://twitter.com/weights_biases) Follow us on [Twitter](https://twitter.com/weights_biases).
%package help
Summary: Development documents and examples for wandb-ng
Provides: python3-wandb-ng-doc
%description help
# Weights and Biases [](https://circleci.com/gh/wandb/client-ng) [](https://pypi.python.org/pypi/wandb) [](https://coveralls.io/github/wandb/client-ng)
Use W&B to organize and analyze machine learning experiments. It's framework-agnostic and lighter than TensorBoard. Each time you run a script instrumented with `wandb`, we save your hyperparameters and output metrics. Visualize models over the course of training, and compare versions of your models easily. We also automatically track the state of your code, system metrics, and configuration parameters.
[Sign up for a free account →](https://wandb.com)
## Features
- Store hyper-parameters used in a training run
- Search, compare, and visualize training runs
- Analyze system usage metrics alongside runs
- Collaborate with team members
- Replicate historic results
- Run parameter sweeps
- Keep records of experiments available forever
[Documentation →](https://docs.wandb.com)
## Quickstart
```shell
pip install wandb
```
In your training script:
```python
import wandb
# Your custom arguments defined here
args = ...
wandb.init(config=args, project="my-project")
wandb.config["more"] = "custom"
def training_loop():
while True:
# Do some machine learning
epoch, loss, val_loss = ...
# Framework agnostic / custom metrics
wandb.log({"epoch": epoch, "loss": loss, "val_loss": val_loss})
```
If you're already using Tensorboard or [TensorboardX](https://github.com/lanpa/tensorboardX), you can integrate with one line:
```python
wandb.init(sync_tensorboard=True)
```
## Running your script
Run `wandb login` from your terminal to signup or authenticate your machine (we store your api key in ~/.netrc). You can also set the `WANDB_API_KEY` environment variable with a key from your [settings](https://app.wandb.ai/settings).
Run your script with `python my_script.py` and all metadata will be synced to the cloud. You will see a url in your terminal logs when your script starts and finishes. Data is staged locally in a directory named _wandb_ relative to your script. If you want to test your script without syncing to the cloud you can set the environment variable `WANDB_MODE=dryrun`.
If you are using [docker](https://docker.com) to run your code, we provide a wrapper command `wandb docker` that mounts your current directory, sets environment variables, and ensures the wandb library is installed. Training your models in docker gives you the ability to restore the exact code and environment with the `wandb restore` command.
## Web Interface
[Sign up for a free account →](https://wandb.com)
[](https://youtu.be/EeqhOSvNX-A)
[Introduction video →](https://youtu.be/EeqhOSvNX-A)
## Detailed Usage
Framework specific and detailed usage can be found in our [documentation](http://docs.wandb.com/).
## Testing
To run basic test use `make test`. More detailed information can be found at CONTRIBUTING.md.
We use [circleci](https://circleci.com) for CI.
# Academic Researchers
If you'd like a free academic account for your research group, [reach out to us →](https://www.wandb.com/academic)
We make it easy to cite W&B in your published paper. [Learn more →](https://www.wandb.com/academic)
[](https://www.wandb.com/academic)
## Community
Got questions, feedback or want to join a community of ML engineers working on exciting projects?
Join our [slack](https://bit.ly/wb-slack) community.
[](https://twitter.com/weights_biases) Follow us on [Twitter](https://twitter.com/weights_biases).
%prep
%autosetup -n wandb-ng-0.0.44
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-wandb-ng -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.0.44-1
- Package Spec generated