%global _empty_manifest_terminate_build 0
Name: python-Better-Than-You-Found-It
Version: 0.9.1
Release: 1
Summary: PEP8 clean only the parts of the files which you have touched since the last commit, a previous commit or (the merge-base of) a branch.
License: MIT License
URL: https://github.com/hayd/pep8radius
Source0: https://mirrors.aliyun.com/pypi/web/packages/8c/a5/a34c54cb3f8de3c1bdb792acc67c5ca6781c7c0fe20878e8a2aafd6df485/Better-Than-You-Found-It-0.9.1.tar.gz
BuildArch: noarch
%description
`PEP8 `__ clean only the
parts of the files touched since the last commit, a previous commit or
(the merge-base of) a branch.
|Current PyPi Version| |MIT licensed| |Travis CI Status| |Coverage
Status| |PyPi Monthly Downloads|
Fixing the entire project of PEP8 infractions ("PEP8 storms") can lead
to merge conflicts, add noise to merges / pull requests and break (git)
blame. pep8radius solves this problem by fixing only those PEP8
infractions incontained on the lines of the project which you've been
working, leaving these sections "better than you found it" whilst
keeping your commits focused on the areas of the codebase you were
actually working on.
%package -n python3-Better-Than-You-Found-It
Summary: PEP8 clean only the parts of the files which you have touched since the last commit, a previous commit or (the merge-base of) a branch.
Provides: python-Better-Than-You-Found-It
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-Better-Than-You-Found-It
`PEP8 `__ clean only the
parts of the files touched since the last commit, a previous commit or
(the merge-base of) a branch.
|Current PyPi Version| |MIT licensed| |Travis CI Status| |Coverage
Status| |PyPi Monthly Downloads|
Fixing the entire project of PEP8 infractions ("PEP8 storms") can lead
to merge conflicts, add noise to merges / pull requests and break (git)
blame. pep8radius solves this problem by fixing only those PEP8
infractions incontained on the lines of the project which you've been
working, leaving these sections "better than you found it" whilst
keeping your commits focused on the areas of the codebase you were
actually working on.
%package help
Summary: Development documents and examples for Better-Than-You-Found-It
Provides: python3-Better-Than-You-Found-It-doc
%description help
`PEP8 `__ clean only the
parts of the files touched since the last commit, a previous commit or
(the merge-base of) a branch.
|Current PyPi Version| |MIT licensed| |Travis CI Status| |Coverage
Status| |PyPi Monthly Downloads|
Fixing the entire project of PEP8 infractions ("PEP8 storms") can lead
to merge conflicts, add noise to merges / pull requests and break (git)
blame. pep8radius solves this problem by fixing only those PEP8
infractions incontained on the lines of the project which you've been
working, leaving these sections "better than you found it" whilst
keeping your commits focused on the areas of the codebase you were
actually working on.
%prep
%autosetup -n Better-Than-You-Found-It-0.9.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-Better-Than-You-Found-It -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.9.1-1
- Package Spec generated