%global _empty_manifest_terminate_build 0
Name: python-magnetos
Version: 0.8.0
Release: 1
Summary: Some hacker scripts.
License: MIT
URL: https://github.com/restran/magnetos
Source0: https://mirrors.aliyun.com/pypi/web/packages/7e/a4/c29971f40f16faa89f19e57755134a0ba200592057b8cb188136e3dc94c5/magnetos-0.8.0.tar.gz
BuildArch: noarch
Requires: python3-requests
Requires: python3-future
Requires: python3-validators
Requires: python3-mountains
Requires: python3-html5lib
Requires: python3-beautifulsoup4
%description
# magnetos
[![travis-ci](https://travis-ci.org/restran/magnetos.svg?branch=master)](https://travis-ci.org/restran/magnetos) [![Coverage Status](https://coveralls.io/repos/github/restran/magnetos/badge.svg?branch=master)](https://coveralls.io/github/restran/magnetos?branch=master) [![pypi package](https://img.shields.io/pypi/v/magnetos.svg)](https://pypi.python.org/pypi/magnetos/)
一款帮你在 CTF 比赛中加速解题的工具
## 依赖的第三方工具
- [zsteg](https://github.com/zed-0xff/zsteg)
- pngcheck
- [stegdetect](https://github.com/abeluck/stegdetect)
- exiftool
```
apt install pngcheck
apt install libimage-exiftool-perl
gem install zsteg
wget http://launchpadlibrarian.net/16746333/stegdetect_0.6-6_amd64.deb
dpkg -i stegdetect_0.6-6_amd64.deb
```
## 安装方法
pip3 install magnetos
## 提供的工具
以下工具可以在命令行下直接执行
- what_format,类似 binwalk 和 foremost,但可以分离出一些其他文件,例如 psd
- what_code_scheme,检测编码类型
- what_encode,自动检测文件编码并进行模糊测试
- what_steg,隐写题目自动化解题工具
- web_get,自动下载指定 URL 的所有资源到本地
- file_hash,计算文件 hash
- file_strings,与 strings 命令相同,但是会自动过滤掉\0
- find_ctf_flag,根据 flag 特征从文本文件或目录中查找可能的 flag
- reverse_proxy,反向代理
- steg_hide_cracker,爆破 steghide 密码
%package -n python3-magnetos
Summary: Some hacker scripts.
Provides: python-magnetos
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-magnetos
# magnetos
[![travis-ci](https://travis-ci.org/restran/magnetos.svg?branch=master)](https://travis-ci.org/restran/magnetos) [![Coverage Status](https://coveralls.io/repos/github/restran/magnetos/badge.svg?branch=master)](https://coveralls.io/github/restran/magnetos?branch=master) [![pypi package](https://img.shields.io/pypi/v/magnetos.svg)](https://pypi.python.org/pypi/magnetos/)
一款帮你在 CTF 比赛中加速解题的工具
## 依赖的第三方工具
- [zsteg](https://github.com/zed-0xff/zsteg)
- pngcheck
- [stegdetect](https://github.com/abeluck/stegdetect)
- exiftool
```
apt install pngcheck
apt install libimage-exiftool-perl
gem install zsteg
wget http://launchpadlibrarian.net/16746333/stegdetect_0.6-6_amd64.deb
dpkg -i stegdetect_0.6-6_amd64.deb
```
## 安装方法
pip3 install magnetos
## 提供的工具
以下工具可以在命令行下直接执行
- what_format,类似 binwalk 和 foremost,但可以分离出一些其他文件,例如 psd
- what_code_scheme,检测编码类型
- what_encode,自动检测文件编码并进行模糊测试
- what_steg,隐写题目自动化解题工具
- web_get,自动下载指定 URL 的所有资源到本地
- file_hash,计算文件 hash
- file_strings,与 strings 命令相同,但是会自动过滤掉\0
- find_ctf_flag,根据 flag 特征从文本文件或目录中查找可能的 flag
- reverse_proxy,反向代理
- steg_hide_cracker,爆破 steghide 密码
%package help
Summary: Development documents and examples for magnetos
Provides: python3-magnetos-doc
%description help
# magnetos
[![travis-ci](https://travis-ci.org/restran/magnetos.svg?branch=master)](https://travis-ci.org/restran/magnetos) [![Coverage Status](https://coveralls.io/repos/github/restran/magnetos/badge.svg?branch=master)](https://coveralls.io/github/restran/magnetos?branch=master) [![pypi package](https://img.shields.io/pypi/v/magnetos.svg)](https://pypi.python.org/pypi/magnetos/)
一款帮你在 CTF 比赛中加速解题的工具
## 依赖的第三方工具
- [zsteg](https://github.com/zed-0xff/zsteg)
- pngcheck
- [stegdetect](https://github.com/abeluck/stegdetect)
- exiftool
```
apt install pngcheck
apt install libimage-exiftool-perl
gem install zsteg
wget http://launchpadlibrarian.net/16746333/stegdetect_0.6-6_amd64.deb
dpkg -i stegdetect_0.6-6_amd64.deb
```
## 安装方法
pip3 install magnetos
## 提供的工具
以下工具可以在命令行下直接执行
- what_format,类似 binwalk 和 foremost,但可以分离出一些其他文件,例如 psd
- what_code_scheme,检测编码类型
- what_encode,自动检测文件编码并进行模糊测试
- what_steg,隐写题目自动化解题工具
- web_get,自动下载指定 URL 的所有资源到本地
- file_hash,计算文件 hash
- file_strings,与 strings 命令相同,但是会自动过滤掉\0
- find_ctf_flag,根据 flag 特征从文本文件或目录中查找可能的 flag
- reverse_proxy,反向代理
- steg_hide_cracker,爆破 steghide 密码
%prep
%autosetup -n magnetos-0.8.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-magnetos -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.8.0-1
- Package Spec generated