%global _empty_manifest_terminate_build 0
Name: python-fluidtopics-markdown
Version: 0.13.5
Release: 1
Summary: A Markdown to FluidTopics command line tool
License: LGPL-3.0-or-later
URL: https://pypi.org/project/fluidtopics-markdown/
Source0: https://mirrors.aliyun.com/pypi/web/packages/3b/3e/86fe63dc58d2c0e865c339ee2fb3d6399cf4504243dcad91df6a7e1cd4a1/fluidtopics_markdown-0.13.5.tar.gz
BuildArch: noarch
Requires: python3-PyYAML
Requires: python3-click
Requires: python3-click-log
Requires: python3-fluidtopics
Requires: python3-importlib-metadata
Requires: python3-lxml
Requires: python3-slugify
Requires: python3-requests
%description
# Markdown to Fluidtopics Command Line Tool
The purpose of this tool is to collect documentation existing in the form
of Markdown files from various places in a project and push it to
a [Fluid Topics](https://www.fluidtopics.com/) portal.
The tool uses the FTML connector:
- https://doc.fluidtopics.com/r/Upload-FTML-Content-to-Fluid-Topics/Configure-FTML-Content
## Features
- Collect all Markdown files (.md) contained in a project.
- Make it possible to define content as public or internal based on [metadata contained
in the Markdown files](https://stackoverflow.com/questions/44215896/markdown-metadata-format).
- Build the Table of Contents in FLuid Topics (ftmap) based on metadata contained in the Markdown files.
- Publish the collected documentation to a Fluid Topics portal.
## Documentation
Documentation of the md2ft commmand line tool is available [here](https://doc.fluidtopics.com/r/Technical-Notes/Markdown-to-Fluid-Topics-md2ft).
## Availability
fluidtopics-markdown is available:
- as a Python module:
- as a Docker image that can be used along with a CI:
%package -n python3-fluidtopics-markdown
Summary: A Markdown to FluidTopics command line tool
Provides: python-fluidtopics-markdown
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-fluidtopics-markdown
# Markdown to Fluidtopics Command Line Tool
The purpose of this tool is to collect documentation existing in the form
of Markdown files from various places in a project and push it to
a [Fluid Topics](https://www.fluidtopics.com/) portal.
The tool uses the FTML connector:
- https://doc.fluidtopics.com/r/Upload-FTML-Content-to-Fluid-Topics/Configure-FTML-Content
## Features
- Collect all Markdown files (.md) contained in a project.
- Make it possible to define content as public or internal based on [metadata contained
in the Markdown files](https://stackoverflow.com/questions/44215896/markdown-metadata-format).
- Build the Table of Contents in FLuid Topics (ftmap) based on metadata contained in the Markdown files.
- Publish the collected documentation to a Fluid Topics portal.
## Documentation
Documentation of the md2ft commmand line tool is available [here](https://doc.fluidtopics.com/r/Technical-Notes/Markdown-to-Fluid-Topics-md2ft).
## Availability
fluidtopics-markdown is available:
- as a Python module:
- as a Docker image that can be used along with a CI:
%package help
Summary: Development documents and examples for fluidtopics-markdown
Provides: python3-fluidtopics-markdown-doc
%description help
# Markdown to Fluidtopics Command Line Tool
The purpose of this tool is to collect documentation existing in the form
of Markdown files from various places in a project and push it to
a [Fluid Topics](https://www.fluidtopics.com/) portal.
The tool uses the FTML connector:
- https://doc.fluidtopics.com/r/Upload-FTML-Content-to-Fluid-Topics/Configure-FTML-Content
## Features
- Collect all Markdown files (.md) contained in a project.
- Make it possible to define content as public or internal based on [metadata contained
in the Markdown files](https://stackoverflow.com/questions/44215896/markdown-metadata-format).
- Build the Table of Contents in FLuid Topics (ftmap) based on metadata contained in the Markdown files.
- Publish the collected documentation to a Fluid Topics portal.
## Documentation
Documentation of the md2ft commmand line tool is available [here](https://doc.fluidtopics.com/r/Technical-Notes/Markdown-to-Fluid-Topics-md2ft).
## Availability
fluidtopics-markdown is available:
- as a Python module:
- as a Docker image that can be used along with a CI:
%prep
%autosetup -n fluidtopics_markdown-0.13.5
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-fluidtopics-markdown -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.13.5-1
- Package Spec generated