%global _empty_manifest_terminate_build 0
Name: python-evalutils
Version: 0.4.2
Release: 1
Summary: evalutils helps users create extensions for grand-challenge.org
License: MIT
URL: https://github.com/comic/evalutils
Source0: https://mirrors.aliyun.com/pypi/web/packages/d7/9c/b365d1e65a9c4f091386c3b373f7db109218ceb7dc341dfa4de440f428ac/evalutils-0.4.2.tar.gz
BuildArch: noarch
Requires: python3-imageio[tifffile]
Requires: python3-SimpleITK
Requires: python3-cookiecutter
Requires: python3-click
Requires: python3-scipy
Requires: python3-scikit-learn
Requires: python3-numpy
Requires: python3-pandas
Requires: python3-pip-tools
%description
# evalutils
[](https://github.com/comic/evalutils/actions?query=workflow%3ACI+branch%3Amain)
[](https://badge.fury.io/py/evalutils)
[](https://pypi.org/project/evalutils/)
[](https://comic.github.io/evalutils/)
[](https://github.com/ambv/black)
evalutils helps challenge administrators easily create evaluation
containers for grand-challenge.org.
- Free software: MIT license
- Documentation: .
## Features
- Generation your challenge evaluation project boilerplate using
[Cookiecutter](https://github.com/audreyr/cookiecutter)
- Scripts to build, test and export your generated docker container
for grand-challenge.org
- Loading of CSV, ITK and Pillow compatible prediction files
- Validation of submitted predictions
- Interface to SciKit-Learn metrics and Pandas aggregations
- Bounding box annotations with Jaccard Index calculations
## Getting Started
[evalutils](https://github.com/comic/evalutils) requires Python 3.8 or
above, and can be installed from `pip`.
Please see the [Getting Started](https://comic.github.io/evalutils/usage.html)
documentation for more details.
%package -n python3-evalutils
Summary: evalutils helps users create extensions for grand-challenge.org
Provides: python-evalutils
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-evalutils
# evalutils
[](https://github.com/comic/evalutils/actions?query=workflow%3ACI+branch%3Amain)
[](https://badge.fury.io/py/evalutils)
[](https://pypi.org/project/evalutils/)
[](https://comic.github.io/evalutils/)
[](https://github.com/ambv/black)
evalutils helps challenge administrators easily create evaluation
containers for grand-challenge.org.
- Free software: MIT license
- Documentation: .
## Features
- Generation your challenge evaluation project boilerplate using
[Cookiecutter](https://github.com/audreyr/cookiecutter)
- Scripts to build, test and export your generated docker container
for grand-challenge.org
- Loading of CSV, ITK and Pillow compatible prediction files
- Validation of submitted predictions
- Interface to SciKit-Learn metrics and Pandas aggregations
- Bounding box annotations with Jaccard Index calculations
## Getting Started
[evalutils](https://github.com/comic/evalutils) requires Python 3.8 or
above, and can be installed from `pip`.
Please see the [Getting Started](https://comic.github.io/evalutils/usage.html)
documentation for more details.
%package help
Summary: Development documents and examples for evalutils
Provides: python3-evalutils-doc
%description help
# evalutils
[](https://github.com/comic/evalutils/actions?query=workflow%3ACI+branch%3Amain)
[](https://badge.fury.io/py/evalutils)
[](https://pypi.org/project/evalutils/)
[](https://comic.github.io/evalutils/)
[](https://github.com/ambv/black)
evalutils helps challenge administrators easily create evaluation
containers for grand-challenge.org.
- Free software: MIT license
- Documentation: .
## Features
- Generation your challenge evaluation project boilerplate using
[Cookiecutter](https://github.com/audreyr/cookiecutter)
- Scripts to build, test and export your generated docker container
for grand-challenge.org
- Loading of CSV, ITK and Pillow compatible prediction files
- Validation of submitted predictions
- Interface to SciKit-Learn metrics and Pandas aggregations
- Bounding box annotations with Jaccard Index calculations
## Getting Started
[evalutils](https://github.com/comic/evalutils) requires Python 3.8 or
above, and can be installed from `pip`.
Please see the [Getting Started](https://comic.github.io/evalutils/usage.html)
documentation for more details.
%prep
%autosetup -n evalutils-0.4.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-evalutils -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.4.2-1
- Package Spec generated