%global _empty_manifest_terminate_build 0 Name: python-mdx_smartypants Version: 1.5.1 Release: 1 Summary: Python-Markdown extension using smartypants to emit typographically nicer ("curly") quotes, proper ("em" and "en") dashes, etc. License: UNKNOWN URL: http://bitbucket.org/jeunice/mdx_smartypants Source0: https://mirrors.aliyun.com/pypi/web/packages/84/54/f0ac8b82524d094755a9b83eb96a2d98155100b80fff45736a2b619218b8/mdx_smartypants-1.5.1.tar.gz BuildArch: noarch %description import markdown text = """ Markdown makes HTML from simple text files. But--it lacks typographic "prettification." That... That'd be sweet. Definitely 7---8 on a '10-point scale'. Now it has it. Huzzah! """ print markdown.markdown(text, extensions=['smartypants(entities=named)']) This produces nice HTML output, including typographically "pretty" quotes and other punctuation. It also (optionally) renders HTML entities in their named rather than numeric form, which is easier on the eyes and more readily comprehended::

Markdown makes HTML from simple text files. But—it lacks typographic “prettification.” That… That’d be sweet. Definitely 7–8 on a ‘10-point scale’. Now it has it.

Huzzah!

Note that you don't really need to do an ``import mdx_smartypants``. You're welcome to if you like, and it may help to advertise that the code depends on ``mdx_smartypants`` being available. But ``markdown`` will look for ``mdx_smartypants`` simply by virtue of the ``extensions=['smartypants']`` declaration. ``mdx_smartypants`` will not massage code blocks (either indentded or fenced), or HTML included within ``
`` sections, so your
program snippets are safe.

%package -n python3-mdx_smartypants
Summary:	Python-Markdown extension using smartypants to emit typographically nicer ("curly") quotes, proper ("em" and "en") dashes, etc.
Provides:	python-mdx_smartypants
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-mdx_smartypants
    import markdown
    text = """
    Markdown makes HTML from simple text files. But--it lacks typographic
    "prettification." That... That'd be sweet. Definitely 7---8 on a '10-point
    scale'. Now it has it.
    Huzzah!
    """
    print markdown.markdown(text, extensions=['smartypants(entities=named)'])
This produces nice HTML output, including typographically "pretty" quotes and
other punctuation. It also (optionally) renders HTML entities in their named rather than
numeric form, which is easier on the eyes and more readily comprehended::
    

Markdown makes HTML from simple text files. But—it lacks typographic “prettification.” That… That’d be sweet. Definitely 7–8 on a ‘10-point scale’. Now it has it.

Huzzah!

Note that you don't really need to do an ``import mdx_smartypants``. You're welcome to if you like, and it may help to advertise that the code depends on ``mdx_smartypants`` being available. But ``markdown`` will look for ``mdx_smartypants`` simply by virtue of the ``extensions=['smartypants']`` declaration. ``mdx_smartypants`` will not massage code blocks (either indentded or fenced), or HTML included within ``
`` sections, so your
program snippets are safe.

%package help
Summary:	Development documents and examples for mdx_smartypants
Provides:	python3-mdx_smartypants-doc
%description help
    import markdown
    text = """
    Markdown makes HTML from simple text files. But--it lacks typographic
    "prettification." That... That'd be sweet. Definitely 7---8 on a '10-point
    scale'. Now it has it.
    Huzzah!
    """
    print markdown.markdown(text, extensions=['smartypants(entities=named)'])
This produces nice HTML output, including typographically "pretty" quotes and
other punctuation. It also (optionally) renders HTML entities in their named rather than
numeric form, which is easier on the eyes and more readily comprehended::
    

Markdown makes HTML from simple text files. But—it lacks typographic “prettification.” That… That’d be sweet. Definitely 7–8 on a ‘10-point scale’. Now it has it.

Huzzah!

Note that you don't really need to do an ``import mdx_smartypants``. You're welcome to if you like, and it may help to advertise that the code depends on ``mdx_smartypants`` being available. But ``markdown`` will look for ``mdx_smartypants`` simply by virtue of the ``extensions=['smartypants']`` declaration. ``mdx_smartypants`` will not massage code blocks (either indentded or fenced), or HTML included within ``
`` sections, so your
program snippets are safe.

%prep
%autosetup -n mdx_smartypants-1.5.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-mdx_smartypants -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Jun 20 2023 Python_Bot  - 1.5.1-1
- Package Spec generated