%global _empty_manifest_terminate_build 0 Name: python-mdx-unimoji Version: 1.1 Release: 1 Summary: Python-Markdown extension that replaces common smileys with their Unicode emoji emoticons. ;) License: GPLv3+ URL: https://github.com/kernc/mdx_unimoji Source0: https://mirrors.aliyun.com/pypi/web/packages/2e/d5/abbfb4db7610837fab0134c70a17fb06c9c4366b1a13b984e3f180a068f5/mdx_unimoji-1.1.tar.gz BuildArch: noarch %description Converts defined emoticon symbols to Unicode emojis, supported on a variety of devices [1]. [1]: http://apps.timwhitlock.info/emoji/tables/unicode#block-1-emoticons Usage: ```python >>> from __future__ import print_function >>> from markdown import markdown >>> text = 'I <3 you! :P' >>> print(markdown(text, ['mdx_unimoji'])) # doctest: +NORMALIZE_WHITESPACE

I you! 😛

``` **NOTE**: The emojis are only replaced when whitespace-delimited on both sides! The following options are accepted: - `emoji`, the emoticon-to-list-of-aliases mapping, - `span_class`, the class name of the encompassing `` element (default: 'emoji'). No element is created if `None`. An example with these custom settings: ```python >>> from mdx_unimoji import UnimojiExtension >>> img_heart = 'love' >>> img_tongue = ':P' >>> overrides = UnimojiExtension.EMOJI >>> overrides.update({img_heart: ['<3'], >>> print(markdown(text,

I love you! \ :P

``` You can use the `span_class` value in your CSS, e.g.: .emoji { font-family: "Apple Color Emoji", "Segoe UI Emoji", "Noto Color Emoji", EmojiSymbols, "DejaVu Sans", Symbola; } %package -n python3-mdx-unimoji Summary: Python-Markdown extension that replaces common smileys with their Unicode emoji emoticons. ;) Provides: python-mdx-unimoji BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-mdx-unimoji Converts defined emoticon symbols to Unicode emojis, supported on a variety of devices [1]. [1]: http://apps.timwhitlock.info/emoji/tables/unicode#block-1-emoticons Usage: ```python >>> from __future__ import print_function >>> from markdown import markdown >>> text = 'I <3 you! :P' >>> print(markdown(text, ['mdx_unimoji'])) # doctest: +NORMALIZE_WHITESPACE

I you! 😛

``` **NOTE**: The emojis are only replaced when whitespace-delimited on both sides! The following options are accepted: - `emoji`, the emoticon-to-list-of-aliases mapping, - `span_class`, the class name of the encompassing `` element (default: 'emoji'). No element is created if `None`. An example with these custom settings: ```python >>> from mdx_unimoji import UnimojiExtension >>> img_heart = 'love' >>> img_tongue = ':P' >>> overrides = UnimojiExtension.EMOJI >>> overrides.update({img_heart: ['<3'], >>> print(markdown(text,

I love you! \ :P

``` You can use the `span_class` value in your CSS, e.g.: .emoji { font-family: "Apple Color Emoji", "Segoe UI Emoji", "Noto Color Emoji", EmojiSymbols, "DejaVu Sans", Symbola; } %package help Summary: Development documents and examples for mdx-unimoji Provides: python3-mdx-unimoji-doc %description help Converts defined emoticon symbols to Unicode emojis, supported on a variety of devices [1]. [1]: http://apps.timwhitlock.info/emoji/tables/unicode#block-1-emoticons Usage: ```python >>> from __future__ import print_function >>> from markdown import markdown >>> text = 'I <3 you! :P' >>> print(markdown(text, ['mdx_unimoji'])) # doctest: +NORMALIZE_WHITESPACE

I you! 😛

``` **NOTE**: The emojis are only replaced when whitespace-delimited on both sides! The following options are accepted: - `emoji`, the emoticon-to-list-of-aliases mapping, - `span_class`, the class name of the encompassing `` element (default: 'emoji'). No element is created if `None`. An example with these custom settings: ```python >>> from mdx_unimoji import UnimojiExtension >>> img_heart = 'love' >>> img_tongue = ':P' >>> overrides = UnimojiExtension.EMOJI >>> overrides.update({img_heart: ['<3'], >>> print(markdown(text,

I love you! \ :P

``` You can use the `span_class` value in your CSS, e.g.: .emoji { font-family: "Apple Color Emoji", "Segoe UI Emoji", "Noto Color Emoji", EmojiSymbols, "DejaVu Sans", Symbola; } %prep %autosetup -n mdx_unimoji-1.1 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-mdx-unimoji -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Tue Jun 20 2023 Python_Bot - 1.1-1 - Package Spec generated