%global _empty_manifest_terminate_build 0
Name: python-astro-trigger-filter
Version: 0.1.21
Release: 1
Summary: A package for filtering triggers from radio astronomical matched template pulse searches.
License: MIT
URL: https://github.com/sitmo/astro-trigger-filter
Source0: https://mirrors.aliyun.com/pypi/web/packages/9f/39/900603c0e3d362571db5e5aa98254c9371bd490d408f11759930820a821f/astro-trigger-filter-0.1.21.tar.gz
BuildArch: noarch
%description
# astro-trigger-filter
A Python package for filtering radio astronomical pulse matched template searches.
## Installation
```
pip install astro-trigger-filter
```
## Command line Amber tool
```
shell> ambertf -i CM??.trigger -o output.txt -v
```
## Documentation
%package -n python3-astro-trigger-filter
Summary: A package for filtering triggers from radio astronomical matched template pulse searches.
Provides: python-astro-trigger-filter
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-astro-trigger-filter
# astro-trigger-filter
A Python package for filtering radio astronomical pulse matched template searches.
## Installation
```
pip install astro-trigger-filter
```
## Command line Amber tool
```
shell> ambertf -i CM??.trigger -o output.txt -v
```
## Documentation
%package help
Summary: Development documents and examples for astro-trigger-filter
Provides: python3-astro-trigger-filter-doc
%description help
# astro-trigger-filter
A Python package for filtering radio astronomical pulse matched template searches.
## Installation
```
pip install astro-trigger-filter
```
## Command line Amber tool
```
shell> ambertf -i CM??.trigger -o output.txt -v
```
## Documentation
%prep
%autosetup -n astro-trigger-filter-0.1.21
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-astro-trigger-filter -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.1.21-1
- Package Spec generated