%global _empty_manifest_terminate_build 0
Name: python-torchani
Version: 2.2.3
Release: 1
Summary: PyTorch implementation of ANI
License: MIT
URL: https://github.com/aiqm/torchani
Source0: https://mirrors.aliyun.com/pypi/web/packages/2f/5b/b3b3dc51917cf407b3562ec2cbeb798e1791d0069f434bee41af45a1f1da/torchani-2.2.3.tar.gz
BuildArch: noarch
Requires: python3-torch
Requires: python3-lark-parser
Requires: python3-requests
Requires: python3-importlib-metadata
%description
#
Accurate Neural Network Potential on PyTorch
Metrics:


Checks:
[](https://www.codefactor.io/repository/github/aiqm/torchani/overview/master)
[](https://lgtm.com/projects/g/aiqm/torchani/alerts/)
[](https://github.com/aiqm/torchani/actions)
[](https://github.com/aiqm/torchani/actions)
[](https://github.com/aiqm/torchani/actions)
[](https://github.com/aiqm/torchani/actions)
[](https://github.com/aiqm/torchani/actions)
[](https://github.com/aiqm/torchani/actions)
[](https://github.com/aiqm/torchani/actions)
[](https://github.com/aiqm/torchani/actions)
Deploy:
[](https://github.com/aiqm/torchani/actions)
[](https://github.com/aiqm/torchani/actions)
We only provide compatibility with nightly PyTorch, but you can check if stable PyTorch happens to be supported by looking at the following badge:
[](https://github.com/aiqm/torchani/actions)
TorchANI is a pytorch implementation of ANI. It is currently under alpha release, which means, the API is not stable yet. If you find a bug of TorchANI, or have some feature request, feel free to open an issue on GitHub, or send us a pull request.
# Install
TorchANI requires the latest preview version of PyTorch. Please install PyTorch before installing TorchANI.
Please see [PyTorch's official site](https://pytorch.org/get-started/locally/) for instructions of installing latest preview version of PyTorch.
Note that if you updated TorchANI, you may also need to update PyTorch.
After installing the correct PyTorch, you can install TorchANI by `pip` or `conda`:
```bash
pip install torchani
```
or
```bash
conda install -c conda-forge torchani
```
See https://github.com/conda-forge/torchani-feedstock for more information about the conda package.
To run the tests and examples, you must manually download a data package
```bash
./download.sh
```
[CUAEV](https://github.com/aiqm/torchani/tree/master/torchani/cuaev) (Optional)
To install AEV CUDA Extension (speedup for AEV forward and backward), please follow the instruction at [torchani/cuaev](https://github.com/aiqm/torchani/tree/master/torchani/cuaev).
# Citation
Please cite the following paper if you use TorchANI
* Xiang Gao, Farhad Ramezanghorbani, Olexandr Isayev, Justin S. Smith, and Adrian E. Roitberg. *TorchANI: A Free and Open Source PyTorch Based Deep Learning Implementation of the ANI Neural Network Potentials*. Journal of Chemical Information and Modeling 2020 60 (7), 3408-3415, [](https://doi.org/10.1021/acs.jcim.0c00451)
[](https://pubs.acs.org/toc/jcisd8/60/7)
* Please refer to [isayev/ASE_ANI](https://github.com/isayev/ASE_ANI) for ANI model references.
# ANI model parameters
All the ANI model parameters including (ANI2x, ANI1x, and ANI1ccx) are accessible from the following repositories:
- [isayev/ASE_ANI](https://github.com/isayev/ASE_ANI)
- [aiqm/ani-model-zoo](https://github.com/aiqm/ani-model-zoo)
# Develop
To install TorchANI from GitHub:
```bash
git clone https://github.com/aiqm/torchani.git
cd torchani
pip install -e .
```
After TorchANI has been installed, you can build the documents by running `sphinx-build docs build`. But make sure you
install dependencies:
```bash
pip install -r docs_requirements.txt
```
To manually run unit tests, do
```bash
pytest -v
```
If you opened a pull request, you could see your generated documents at https://aiqm.github.io/torchani-test-docs/ after you `docs` check succeed.
Keep in mind that this repository is only for the purpose of convenience of development, and only keeps the latest push.
The CI runing for other pull requests might overwrite this repository. You could rerun the `docs` check to overwrite this repo to your build.
# Note to TorchANI developers
Never commit to the master branch directly. If you need to change something, create a new branch, submit a PR on GitHub.
You must pass all the tests on GitHub before your PR can be merged.
Code review is required before merging pull request.
%package -n python3-torchani
Summary: PyTorch implementation of ANI
Provides: python-torchani
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-torchani
#
Accurate Neural Network Potential on PyTorch
Metrics:


Checks:
[](https://www.codefactor.io/repository/github/aiqm/torchani/overview/master)
[](https://lgtm.com/projects/g/aiqm/torchani/alerts/)
[](https://github.com/aiqm/torchani/actions)
[](https://github.com/aiqm/torchani/actions)
[](https://github.com/aiqm/torchani/actions)
[](https://github.com/aiqm/torchani/actions)
[](https://github.com/aiqm/torchani/actions)
[](https://github.com/aiqm/torchani/actions)
[](https://github.com/aiqm/torchani/actions)
[](https://github.com/aiqm/torchani/actions)
Deploy:
[](https://github.com/aiqm/torchani/actions)
[](https://github.com/aiqm/torchani/actions)
We only provide compatibility with nightly PyTorch, but you can check if stable PyTorch happens to be supported by looking at the following badge:
[](https://github.com/aiqm/torchani/actions)
TorchANI is a pytorch implementation of ANI. It is currently under alpha release, which means, the API is not stable yet. If you find a bug of TorchANI, or have some feature request, feel free to open an issue on GitHub, or send us a pull request.
# Install
TorchANI requires the latest preview version of PyTorch. Please install PyTorch before installing TorchANI.
Please see [PyTorch's official site](https://pytorch.org/get-started/locally/) for instructions of installing latest preview version of PyTorch.
Note that if you updated TorchANI, you may also need to update PyTorch.
After installing the correct PyTorch, you can install TorchANI by `pip` or `conda`:
```bash
pip install torchani
```
or
```bash
conda install -c conda-forge torchani
```
See https://github.com/conda-forge/torchani-feedstock for more information about the conda package.
To run the tests and examples, you must manually download a data package
```bash
./download.sh
```
[CUAEV](https://github.com/aiqm/torchani/tree/master/torchani/cuaev) (Optional)
To install AEV CUDA Extension (speedup for AEV forward and backward), please follow the instruction at [torchani/cuaev](https://github.com/aiqm/torchani/tree/master/torchani/cuaev).
# Citation
Please cite the following paper if you use TorchANI
* Xiang Gao, Farhad Ramezanghorbani, Olexandr Isayev, Justin S. Smith, and Adrian E. Roitberg. *TorchANI: A Free and Open Source PyTorch Based Deep Learning Implementation of the ANI Neural Network Potentials*. Journal of Chemical Information and Modeling 2020 60 (7), 3408-3415, [](https://doi.org/10.1021/acs.jcim.0c00451)
[](https://pubs.acs.org/toc/jcisd8/60/7)
* Please refer to [isayev/ASE_ANI](https://github.com/isayev/ASE_ANI) for ANI model references.
# ANI model parameters
All the ANI model parameters including (ANI2x, ANI1x, and ANI1ccx) are accessible from the following repositories:
- [isayev/ASE_ANI](https://github.com/isayev/ASE_ANI)
- [aiqm/ani-model-zoo](https://github.com/aiqm/ani-model-zoo)
# Develop
To install TorchANI from GitHub:
```bash
git clone https://github.com/aiqm/torchani.git
cd torchani
pip install -e .
```
After TorchANI has been installed, you can build the documents by running `sphinx-build docs build`. But make sure you
install dependencies:
```bash
pip install -r docs_requirements.txt
```
To manually run unit tests, do
```bash
pytest -v
```
If you opened a pull request, you could see your generated documents at https://aiqm.github.io/torchani-test-docs/ after you `docs` check succeed.
Keep in mind that this repository is only for the purpose of convenience of development, and only keeps the latest push.
The CI runing for other pull requests might overwrite this repository. You could rerun the `docs` check to overwrite this repo to your build.
# Note to TorchANI developers
Never commit to the master branch directly. If you need to change something, create a new branch, submit a PR on GitHub.
You must pass all the tests on GitHub before your PR can be merged.
Code review is required before merging pull request.
%package help
Summary: Development documents and examples for torchani
Provides: python3-torchani-doc
%description help
#
Accurate Neural Network Potential on PyTorch
Metrics:


Checks:
[](https://www.codefactor.io/repository/github/aiqm/torchani/overview/master)
[](https://lgtm.com/projects/g/aiqm/torchani/alerts/)
[](https://github.com/aiqm/torchani/actions)
[](https://github.com/aiqm/torchani/actions)
[](https://github.com/aiqm/torchani/actions)
[](https://github.com/aiqm/torchani/actions)
[](https://github.com/aiqm/torchani/actions)
[](https://github.com/aiqm/torchani/actions)
[](https://github.com/aiqm/torchani/actions)
[](https://github.com/aiqm/torchani/actions)
Deploy:
[](https://github.com/aiqm/torchani/actions)
[](https://github.com/aiqm/torchani/actions)
We only provide compatibility with nightly PyTorch, but you can check if stable PyTorch happens to be supported by looking at the following badge:
[](https://github.com/aiqm/torchani/actions)
TorchANI is a pytorch implementation of ANI. It is currently under alpha release, which means, the API is not stable yet. If you find a bug of TorchANI, or have some feature request, feel free to open an issue on GitHub, or send us a pull request.
# Install
TorchANI requires the latest preview version of PyTorch. Please install PyTorch before installing TorchANI.
Please see [PyTorch's official site](https://pytorch.org/get-started/locally/) for instructions of installing latest preview version of PyTorch.
Note that if you updated TorchANI, you may also need to update PyTorch.
After installing the correct PyTorch, you can install TorchANI by `pip` or `conda`:
```bash
pip install torchani
```
or
```bash
conda install -c conda-forge torchani
```
See https://github.com/conda-forge/torchani-feedstock for more information about the conda package.
To run the tests and examples, you must manually download a data package
```bash
./download.sh
```
[CUAEV](https://github.com/aiqm/torchani/tree/master/torchani/cuaev) (Optional)
To install AEV CUDA Extension (speedup for AEV forward and backward), please follow the instruction at [torchani/cuaev](https://github.com/aiqm/torchani/tree/master/torchani/cuaev).
# Citation
Please cite the following paper if you use TorchANI
* Xiang Gao, Farhad Ramezanghorbani, Olexandr Isayev, Justin S. Smith, and Adrian E. Roitberg. *TorchANI: A Free and Open Source PyTorch Based Deep Learning Implementation of the ANI Neural Network Potentials*. Journal of Chemical Information and Modeling 2020 60 (7), 3408-3415, [](https://doi.org/10.1021/acs.jcim.0c00451)
[](https://pubs.acs.org/toc/jcisd8/60/7)
* Please refer to [isayev/ASE_ANI](https://github.com/isayev/ASE_ANI) for ANI model references.
# ANI model parameters
All the ANI model parameters including (ANI2x, ANI1x, and ANI1ccx) are accessible from the following repositories:
- [isayev/ASE_ANI](https://github.com/isayev/ASE_ANI)
- [aiqm/ani-model-zoo](https://github.com/aiqm/ani-model-zoo)
# Develop
To install TorchANI from GitHub:
```bash
git clone https://github.com/aiqm/torchani.git
cd torchani
pip install -e .
```
After TorchANI has been installed, you can build the documents by running `sphinx-build docs build`. But make sure you
install dependencies:
```bash
pip install -r docs_requirements.txt
```
To manually run unit tests, do
```bash
pytest -v
```
If you opened a pull request, you could see your generated documents at https://aiqm.github.io/torchani-test-docs/ after you `docs` check succeed.
Keep in mind that this repository is only for the purpose of convenience of development, and only keeps the latest push.
The CI runing for other pull requests might overwrite this repository. You could rerun the `docs` check to overwrite this repo to your build.
# Note to TorchANI developers
Never commit to the master branch directly. If you need to change something, create a new branch, submit a PR on GitHub.
You must pass all the tests on GitHub before your PR can be merged.
Code review is required before merging pull request.
%prep
%autosetup -n torchani-2.2.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-torchani -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 2.2.3-1
- Package Spec generated