%global _empty_manifest_terminate_build 0
Name: python-inference-tools
Version: 0.11.0
Release: 1
Summary: A collection of python tools for Bayesian data analysis
License: MIT
URL: https://github.com/C-bowman/inference-tools
Source0: https://mirrors.aliyun.com/pypi/web/packages/f4/34/4666a4890a09786c4be51e2c6ce631942cd0db760666e14425214bea6fee/inference-tools-0.11.0.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-scipy
Requires: python3-matplotlib
Requires: python3-importlib-metadata
Requires: python3-sphinx
Requires: python3-sphinx-rtd-theme
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-pyqt5
Requires: python3-hypothesis
Requires: python3-freezegun
%description
# inference-tools
[![Documentation Status](https://readthedocs.org/projects/inference-tools/badge/?version=stable)](https://inference-tools.readthedocs.io/en/stable/?badge=stable)
[![GitHub license](https://img.shields.io/github/license/C-bowman/inference-tools?color=blue)](https://github.com/C-bowman/inference-tools/blob/master/LICENSE)
[![PyPI - Downloads](https://img.shields.io/pypi/dm/inference-tools?color=purple)](https://pypi.org/project/inference-tools/)
![PyPI - Python Version](https://img.shields.io/pypi/pyversions/inference-tools)
[![DOI](https://zenodo.org/badge/149741362.svg)](https://zenodo.org/badge/latestdoi/149741362)
This package provides a set of Python-based tools for Bayesian data analysis
which are simple to use, allowing them to applied quickly and easily.
Inference-tools is not a framework for Bayesian modelling (e.g. like [PyMC](https://docs.pymc.io/)),
but instead provides tools to sample from user-defined models using MCMC, and to analyse and visualise
the sampling results.
## Features
- Implementations of MCMC algorithms like Gibbs sampling and Hamiltonian Monte-Carlo for
sampling from user-defined posterior distributions.
- Density estimation and plotting tools for analysing and visualising inference results.
- Gaussian-process regression and optimisation.
| | | |
|:-------------------------:|:-------------------------:|:-------------------------:|
| [Gibbs Sampling](https://github.com/C-bowman/inference-tools/blob/master/demos/gibbs_sampling_demo.ipynb) | [Hamiltonian Monte-Carlo](https://github.com/C-bowman/inference-tools/blob/master/demos/hamiltonian_mcmc_demo.ipynb) | [Density estimation](https://github.com/C-bowman/inference-tools/blob/master/demos/density_estimation_demo.ipynb) |
| Matrix plotting | Highest-density intervals | [GP regression](https://github.com/C-bowman/inference-tools/blob/master/demos/gp_regression_demo.ipynb) |
## Installation
inference-tools is available from [PyPI](https://pypi.org/project/inference-tools/),
so can be easily installed using [pip](https://pip.pypa.io/en/stable/) as follows:
```bash
pip install inference-tools
```
## Documentation
Full documentation is available at [inference-tools.readthedocs.io](https://inference-tools.readthedocs.io/en/stable/).
%package -n python3-inference-tools
Summary: A collection of python tools for Bayesian data analysis
Provides: python-inference-tools
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-inference-tools
# inference-tools
[![Documentation Status](https://readthedocs.org/projects/inference-tools/badge/?version=stable)](https://inference-tools.readthedocs.io/en/stable/?badge=stable)
[![GitHub license](https://img.shields.io/github/license/C-bowman/inference-tools?color=blue)](https://github.com/C-bowman/inference-tools/blob/master/LICENSE)
[![PyPI - Downloads](https://img.shields.io/pypi/dm/inference-tools?color=purple)](https://pypi.org/project/inference-tools/)
![PyPI - Python Version](https://img.shields.io/pypi/pyversions/inference-tools)
[![DOI](https://zenodo.org/badge/149741362.svg)](https://zenodo.org/badge/latestdoi/149741362)
This package provides a set of Python-based tools for Bayesian data analysis
which are simple to use, allowing them to applied quickly and easily.
Inference-tools is not a framework for Bayesian modelling (e.g. like [PyMC](https://docs.pymc.io/)),
but instead provides tools to sample from user-defined models using MCMC, and to analyse and visualise
the sampling results.
## Features
- Implementations of MCMC algorithms like Gibbs sampling and Hamiltonian Monte-Carlo for
sampling from user-defined posterior distributions.
- Density estimation and plotting tools for analysing and visualising inference results.
- Gaussian-process regression and optimisation.
| | | |
|:-------------------------:|:-------------------------:|:-------------------------:|
| [Gibbs Sampling](https://github.com/C-bowman/inference-tools/blob/master/demos/gibbs_sampling_demo.ipynb) | [Hamiltonian Monte-Carlo](https://github.com/C-bowman/inference-tools/blob/master/demos/hamiltonian_mcmc_demo.ipynb) | [Density estimation](https://github.com/C-bowman/inference-tools/blob/master/demos/density_estimation_demo.ipynb) |
| Matrix plotting | Highest-density intervals | [GP regression](https://github.com/C-bowman/inference-tools/blob/master/demos/gp_regression_demo.ipynb) |
## Installation
inference-tools is available from [PyPI](https://pypi.org/project/inference-tools/),
so can be easily installed using [pip](https://pip.pypa.io/en/stable/) as follows:
```bash
pip install inference-tools
```
## Documentation
Full documentation is available at [inference-tools.readthedocs.io](https://inference-tools.readthedocs.io/en/stable/).
%package help
Summary: Development documents and examples for inference-tools
Provides: python3-inference-tools-doc
%description help
# inference-tools
[![Documentation Status](https://readthedocs.org/projects/inference-tools/badge/?version=stable)](https://inference-tools.readthedocs.io/en/stable/?badge=stable)
[![GitHub license](https://img.shields.io/github/license/C-bowman/inference-tools?color=blue)](https://github.com/C-bowman/inference-tools/blob/master/LICENSE)
[![PyPI - Downloads](https://img.shields.io/pypi/dm/inference-tools?color=purple)](https://pypi.org/project/inference-tools/)
![PyPI - Python Version](https://img.shields.io/pypi/pyversions/inference-tools)
[![DOI](https://zenodo.org/badge/149741362.svg)](https://zenodo.org/badge/latestdoi/149741362)
This package provides a set of Python-based tools for Bayesian data analysis
which are simple to use, allowing them to applied quickly and easily.
Inference-tools is not a framework for Bayesian modelling (e.g. like [PyMC](https://docs.pymc.io/)),
but instead provides tools to sample from user-defined models using MCMC, and to analyse and visualise
the sampling results.
## Features
- Implementations of MCMC algorithms like Gibbs sampling and Hamiltonian Monte-Carlo for
sampling from user-defined posterior distributions.
- Density estimation and plotting tools for analysing and visualising inference results.
- Gaussian-process regression and optimisation.
| | | |
|:-------------------------:|:-------------------------:|:-------------------------:|
| [Gibbs Sampling](https://github.com/C-bowman/inference-tools/blob/master/demos/gibbs_sampling_demo.ipynb) | [Hamiltonian Monte-Carlo](https://github.com/C-bowman/inference-tools/blob/master/demos/hamiltonian_mcmc_demo.ipynb) | [Density estimation](https://github.com/C-bowman/inference-tools/blob/master/demos/density_estimation_demo.ipynb) |
| Matrix plotting | Highest-density intervals | [GP regression](https://github.com/C-bowman/inference-tools/blob/master/demos/gp_regression_demo.ipynb) |
## Installation
inference-tools is available from [PyPI](https://pypi.org/project/inference-tools/),
so can be easily installed using [pip](https://pip.pypa.io/en/stable/) as follows:
```bash
pip install inference-tools
```
## Documentation
Full documentation is available at [inference-tools.readthedocs.io](https://inference-tools.readthedocs.io/en/stable/).
%prep
%autosetup -n inference-tools-0.11.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-inference-tools -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.11.0-1
- Package Spec generated